Can't install Mountain Lion on an unsupported MacBook

nadation

macrumors newbie
Original poster
Jan 19, 2019
1
0
Morocco
First of all, I'd like to mention that I'm not an advanced user but I manage quite fine

Well, I have this old machine that has been running perfectly on MacOS X Leopard for years now and which I have upgraded to MacOS X Snow Leopard and then to MacOS X Lion but I want to go further, this is why I have been trying to go with ML using MacPostFactor given it's now an unsupported device by Apple but I just don't how to make it work.

It's a 13-inch early 2008 Macbook 4,1 Intel Core 2 Duo, here's a picture for more details :

Screen Shot 2019-01-19 at 7.26.22 PM.png


So I have been using MacPostFactor v2.0.1 because I couldn't find any decent download file of MLPostFactor (I also have tried macOS Extractor but that's another story, lol) to install ML via USB : I follow the guide carefully and make sure to do everything as mentioned but it just never boots, I exit, boot the computer, press alt, I see the USB drive that contains ML with the other drives but once, I select it but it just never boots.. I have even tried to "force start" it, using this but nothing happens…

Screen Shot 2019-01-20 at 3.57.39 AM.png


SO PLEASE CAN SOMEBODY HELP ME? PLEASE!
 

AnonMac50

macrumors 65816
Mar 24, 2010
1,471
276
First of all, I'd like to mention that I'm not an advanced user but I manage quite fine

Well, I have this old machine that has been running perfectly on MacOS X Leopard for years now and which I have upgraded to MacOS X Snow Leopard and then to MacOS X Lion but I want to go further, this is why I have been trying to go with ML using MacPostFactor given it's now an unsupported device by Apple but I just don't how to make it work.

It's a 13-inch early 2008 Macbook 4,1 Intel Core 2 Duo, here's a picture for more details :

View attachment 816547

So I have been using MacPostFactor v2.0.1 because I couldn't find any decent download file of MLPostFactor (I also have tried macOS Extractor but that's another story, lol) to install ML via USB : I follow the guide carefully and make sure to do everything as mentioned but it just never boots, I exit, boot the computer, press alt, I see the USB drive that contains ML with the other drives but once, I select it but it just never boots.. I have even tried to "force start" it, using this but nothing happens…

View attachment 816549

SO PLEASE CAN SOMEBODY HELP ME? PLEASE!
I think there’s an issue with MacPostFactor, I couldn’t get Mountain Lion or Yosemite to install on my Early 2008 MB using it.
 

CooperBox

macrumors 65816
Nov 28, 2010
1,071
1,049
France - between Ricard & Absinthe
According to Dosdude1 who's the patcher tool guru for unsupported Macs, from what I'm reading it would appear that the MacBook4,1 is not supported. Link HERE.
I'm not astute enough to tell you why its worded that way, especially as I note that in his Install Mac OS X 10.8 on an unsupported Mac video, the MacBook4,1 is listed in the MacPostFactor software listing, even supporting up to OS Sierra.

I suggest you head over to the PowerPC forum (even though you have an Intel MacBook), and repost your query there, and all will be revealed.
Good luck, and let us know how how you make out.
 

Bampelito

macrumors newbie
Mar 25, 2019
4
1
First of all, I'd like to mention that I'm not an advanced user but I manage quite fine

Well, I have this old machine that has been running perfectly on MacOS X Leopard for years now and which I have upgraded to MacOS X Snow Leopard and then to MacOS X Lion but I want to go further, this is why I have been trying to go with ML using MacPostFactor given it's now an unsupported device by Apple but I just don't how to make it work.

It's a 13-inch early 2008 Macbook 4,1 Intel Core 2 Duo, here's a picture for more details :

View attachment 816547

So I have been using MacPostFactor v2.0.1 because I couldn't find any decent download file of MLPostFactor (I also have tried macOS Extractor but that's another story, lol) to install ML via USB : I follow the guide carefully and make sure to do everything as mentioned but it just never boots, I exit, boot the computer, press alt, I see the USB drive that contains ML with the other drives but once, I select it but it just never boots.. I have even tried to "force start" it, using this but nothing happens…

View attachment 816549

SO PLEASE CAN SOMEBODY HELP ME? PLEASE!
Hey! I found out solution. It seems that MacPostFactor 2.0.1 has some bugs or something. I used MacPostFactor 1.0.1 and its finally working!