Can't mount Western Digital My Book after Snow leopard Install

Discussion in 'Mac Accessories' started by akutad, Aug 31, 2009.

  1. akutad macrumors regular

    akutad

    Joined:
    Jul 12, 2008
    Location:
    London, Ontario, Canada
    #1
    I jacked in my external drive and I get a alias message error. Not sure what to do. Does you have this problem with your external drive?
     

    Attached Files:

  2. dannys1 macrumors 68020

    dannys1

    Joined:
    Sep 19, 2007
    Location:
    UK
    #2
    I have EXACTLY the same problem with my Western Digital My Book.

    Although it would appear we're the only ones on the net with it - or at least the only ones to report.

    I had a copy of the retail disk a week before release and the same problem persisted, ive just tried a new install again tonight from fresh in case something was corrupted in the process but no - as i booted up exactly the same thing.

    Unfortunatly that makes it unusable for me as the my book is mounted wirelessly and logins in everytime i boot OS X with all my media files attached...

    It must be a WD/MyBook/SL compatibility problem...
     
  3. dannys1 macrumors 68020

    dannys1

    Joined:
    Sep 19, 2007
    Location:
    UK
    #3
    akutad - I poked around a bit and found the answer.

    Download Path Finder 5. You'll be able to access your drive find - right click on it and chose get info.

    In there you see "alias bit" untick this box and suddenly the drive will work perfectly with Snow Leopard.

    Ive yet to try rebooting, mounting and unmounting etc but for now it works - its obviously not the answer if I have to do this ever time i reboot of course!

    Hope it helps though.
     
  4. redknives macrumors member

    Joined:
    Sep 14, 2007
    Location:
    Seattle, WA USA
    #4
    I'm having this problem but with the WD as a wireless shared drive via my Airport Extreme. I wonder if it's related? My drive does mount via FW800.
     
  5. dannys1 macrumors 68020

    dannys1

    Joined:
    Sep 19, 2007
    Location:
    UK
    #5
    Just use my fix - it will work if its exactly the same problem you're having.

    Mine did the same if connected direct via USB or via Airport Extreme.
     
  6. KidMoe85 macrumors member

    Joined:
    Jul 17, 2009
    #6
    Did you guys keep the drive connected while you did the install? I disconnected everything from my computer when I installed SL and when I reattached my WD Studio Book (thru firewire), it recognized it immediately.
     
  7. dannys1 macrumors 68020

    dannys1

    Joined:
    Sep 19, 2007
    Location:
    UK
    #7
    I dont think the first poster did no.

    And mine was connected via Airport Extreme - so it wasn't mounted properly during the install, either way, its a bug that shouldn't exist.
     
  8. TomGlover macrumors newbie

    Joined:
    Sep 7, 2009
    #8
    WD MyBook Studio doesn't mound with SL

    I'm having the same problem (since installing SL my MyBook Studio 500Gig drive won't mount). I can't recall if it was plugged in during the SL install or not. The drive isn't found by the disk utility and isn't found by path finder 5. Any other advice would be appreciated.
     
  9. icemanocp macrumors newbie

    Joined:
    Sep 8, 2009
    #9
    I had problems with my WD MyBook Studio 1TB after upgrading to SL. System profiler and disk utility wouldn't even recognize the drive connected let alone allow Time Machine to do the backups. Thought it might be a driver issue, and it turns out after several hours on the phone with Apple & WD that according to WD, the new drivers compatible with Snow Leopard require a dedicated power outlet from the wall and cannot be used on a power strip. As soon as i switched from the strip straight to the wall the drive loaded up just fine. Have never had issue with this before, as my external drive always worked like a charm in time machine connected to a power strip, but i guess that's not the case with snow leopard- hope this helps for some out there.
     
  10. nawk macrumors member

    Joined:
    Jan 2, 2002
    #10
    I am, unfortunately, having the exact same issue.

    However, I can't imagine how the drive can "sense" when it is connected to a wall outlet versus a power strip. This really can't be the issue.
     
  11. fhall1 macrumors 68040

    fhall1

    Joined:
    Dec 18, 2007
    Location:
    (Central) NY State of mind
    #11
    I have to agree with you there....unless the wall outlet is putting out extra-special energized magical electrons that the power strip filters out :)
     
  12. bladerunner888 macrumors newbie

    Joined:
    Sep 14, 2009
    #12
    dannys1 your pathfinder hack worked - thanks!!!.

    However the drive (WD 2TB in RAID0) will still not mount if connected via firewire. USB sees the drive with the alias bit on.

    What in snow leopard is causing this strange behavior ?? Will have to keep it connected via USB for now.
     
  13. denis arvay macrumors newbie

    Joined:
    Sep 11, 2009
    #13
    RE: Pathfinder fix. The drive shows up in disk utility but not in Pathfinder. The utility won't let me do anything to it, and pathfinder doesn't even see it.
     
  14. denis arvay macrumors newbie

    Joined:
    Sep 11, 2009
    #14
    It shows up in the disk utility when I connect it via USB, but that only seems willing to let me erase and re-format. It's giving me a number of reformatting options, anyone know which one I sould pick? Seems promising -- it's reporting the disk as unformatted.
     
  15. jr98664 macrumors newbie

    Joined:
    Sep 19, 2009
    #15
    I'm having this very same problem with my 500 GB My Book and 1.66 GHz Core Duo Mac Mini. It worked perfectly fine over firewire before the upgrade and for a few days after the installation, until one day I went to start iPhoto, and I was told that my mac couldn't find the external hard drive on which my photos are stored. I've tried all of the fixes mentioned here, and nothing seems to work. I've tried USB instead, Path Finder, plugging the power cord directly into the wall, and now it's not even showing up when plugged into Windows computers via USB.

    Any other suggestions?
     
  16. macuser1939 macrumors newbie

    Joined:
    Sep 26, 2009
    #16
    different cord

    I tried everything, including the pathfinder option. My book was just not being detected. My solution was to just try a different usb cord that I had for one of my cameras and it worked immediately and I am able to back up again using time machine and access all my files on the my book. So try a different cord!!
     
  17. scubasme macrumors newbie

    Joined:
    May 8, 2009
    #17
    wd drive not connecting

    this sucks same prob here it was working fine until tonight i have my 1tb full of clients work!!!
     
  18. macuser154 macrumors 6502

    Joined:
    Jan 17, 2009
    Location:
    UK
    #18
    I am having a similar problem, where drives will just refuse to mount. Even some DMGs refuse to mount.
     
  19. simon202 macrumors newbie

    Joined:
    Jul 10, 2008
    #19
    Good news!!!

    Good news I hope! :cool:

    I just downloaded and installed the firmware from http://support.wdc.com/product/download.asp?groupid=113&sid=60&lang=en

    :eek:

    It's dated Jan 2009 release date but it seems to have to have solved the problem of my WD not connecting in SL :D


    Mac Pro 8 core 3.0GHz 8GB RAM, 4TB HD
    15" MacBook Pro (Penryn), 2.66 GHz, 4GB RAM, 320GB HD
    16GB iPhone 3G
     
  20. Guido Jones macrumors newbie

    Joined:
    Oct 22, 2009
    #20
    WD Studio II Drive USB to Airport Extreme Will Not Mount in SL

    Hi everyone...

    Thank goodness that this forum exists; I didn't know what was going on with my 1Tb WD MyBook Studio II Drive.

    I have two external drives connected to my network via a USB hub to an Airport Extreme: a 1TB WD MyBook Studio II drive and a 1TB WD MyBook Premium II drive.

    I use ChronoSync 4 for periodic network backups from one WD MyBook drive to the other.

    I have routinely updated firmware on both these drives and both are up-to-date and all is working fine with OS 10.4 OS 10.5 and Windows XP.

    Upon installation of OS 10.6, I am unable to mount the 1TB MyBook Studio II drive; but the 1TB MyBook Premium II drive mounts just fine.

    What is surprising about this is that the WD Premium II drive is an earlier version of the MyBook Series drives!

    Judging from this forum, I suspect a firmware problem for the Studio II is the cause.

    I thought it helpful to post my issue so that others won't get unduly frustrated after spending needless time checking over network configurations, connections and settings.

    Bye for now...

    G
     
  21. Guido Jones macrumors newbie

    Joined:
    Oct 22, 2009
    #21
    WD Studio II Drive USB to Airport Extreme Will Not Mount in SL

    I've just sent off an email to WD support with regards to my WD MyBook Studio II mounting issue on Mac OS 10.6 (Snow Leopard).

    I'll post their reply upon its receipt.

    Bye for now...

    ...G
     
  22. Guido Jones macrumors newbie

    Joined:
    Oct 22, 2009
    #22
    WD Studio II Drive USB to Airport Extreme Will Not Mount in SL

    Hi everyone...

    I've just received a reply from Western Digital Support regarding my WD Studio II Drive networking issue; confirming that firmware is to blame:

    "Thank you for contacting Western Digital Customer Service and Support. My name is N.V.

    I truly apologize for the inconvenience you are currently experiencing. At this time we are working in order to create the firmware update to make this unit compatible with Snow Leopard, unfortunately we do not have a release date yet. Please keep checking WD website for any news update.

    I hope that we have met your expectations today and that you are satisfied with our service. If you have any further questions, please reply to this email and we will be happy to assist you further."

    So I guess that I'll (we'll) just have to wait...

    ...G
     
  23. sparkn macrumors newbie

    Joined:
    Oct 20, 2009
    #23
    Went through this all over again after reinstalling Snow Leopard after a hard drive replacement.

    After installing the WD Button Manager and rebooting the computer I unplugged BOTH the Firewire connection and the power to the drive.

    Wait 30 seconds before plugging in just the power to the drive.

    TURN ON the drive after plugging it in from the button on the front. It should now be lit up.

    Now you can plug in the Firewire cable to the drive. Do not plug the Firewire cable in until you have done everything else.

    Drive should appear and will work normally now upon reboot and such. Follow these steps again if the drive ever fails to appear again.

    This works for the MyBook Premium. Other versions may vary but it usually comes down to the drive uses power from both Firewire and wall outlet and needs to be completely powered down and brought back up in sequence.

    I hope this helps at least some of you out with this problem.
     
  24. gregoir macrumors newbie

    Joined:
    Jan 19, 2010
    #24
    Hard drive format

    Hi guys,
    Had the same problem with the WD My Book Home edition not mounting from Airport Extreme. It would show as shared in Airport Utility but you couldn't access it. I did the firmware update but still no success, then I remembered something to do with partitions. If you partition the drive (with 1 partition) and choose in the options to have GUID Partition Table, problem solved (for me anyhow). My drive was formatted Windows fat32 when I got it. As such it had the option "Master Boot Record" which I assume was preventing the drive from mounting.
     
  25. mgp5000 macrumors newbie

    Joined:
    Mar 12, 2010
    #25
    WD Studio 1TB Drive Won't Mount in Leopard

    I had the same issue on OS 10.5.8 (Leopard). I have two WD My Studio 1 TB drives that I rotate for Time Machine backup. I connect via FireWire 800. Time Machine stopped working and neither drive would mount.

    Solution: as mentioned earlier, the sequence to connect the drive.

    1: remove both the power cable and FW cable from the drive
    2: wait for the drive to spin down
    3: plug the power cable back in
    4: press the power button; you should see the light
    5: then connect the FW cable

    Now enjoying the quiet purr of a Time Machine backup. Bizarre issue. Thanks for the help, all.
     

Share This Page