Can't recieve MMS from another carrier.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by SRLMJ23, Sep 28, 2009.

  1. SRLMJ23 macrumors 65816

    SRLMJ23

    Joined:
    Jul 11, 2008
    Location:
    New York
    #1
    Is anyone else experiencing an issue where they can send media to anyone on any network but cant recieve media from anyone unless they are on AT&T??? My girlfriend has tried to send me some pictures, shes on Verizon and they never come through, yet I can send pictures to her fine. When one of my friends on AT&T send me media I get it fine. Just curious if this is a known issue, I called Apple...they weren't sure what was going on, havent contacted AT&T yet. I appreciate the help or answer, thank you in advance. I did search the forum and didnt get much of anything about this issue.

    Thanks.
     
  2. Vandam500 macrumors 68000

    Vandam500

    Joined:
    Sep 29, 2008
    #2
    Why would you call Apple and not AT&T? Apple has nothing to do with your problem. The network is AT&T's, call them first.
     
  3. abijnk macrumors 68040

    abijnk

    Joined:
    Oct 15, 2007
    Location:
    Los Angeles, CA
    #3
    Because as soon as you call AT&T and say something is wrong with your iPhone they put you over to Applecare anyways...
     
  4. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #4
    I used to always have this trouble when my wife had Verizon a few years ago, I'd never get her texts. I wanted to finally test MMS on my iPhone just now and I sent one from my T-Mobile Blackberry to my iPhone 3GS, came through ok. :)

    Of note, I have a jailbroken 3.0.1 that I had to wrestle with to the get the carrier file loaded but seems to work ok.
     
  5. Luigi239 macrumors 6502a

    Joined:
    Jan 25, 2007
    #5
    I had this issue initially on Friday. A friend on Verizon sent me a picture twice and I didn't receive it.

    I'm having the friend resend it now, so we will see if it works.
     
  6. SRLMJ23 thread starter macrumors 65816

    SRLMJ23

    Joined:
    Jul 11, 2008
    Location:
    New York
    #6
    I didn't call AT&T because like someone else said, they always send you to Apple Tech. Support.

    I used to have a problem like this when I was with Nextel like 4-5 years ago, never had the issue when I was Sprint, and now with AT&T it feels like they can't even get this to work...I mean they had how many months to deploy this and now it doesnt even work completely.
     
  7. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #7
    Your girlfriend should call Verizon to make a complaint that her MMS's are not being delivered to an AT&T number, as the fault is probably there. Can she still text you OK?
     
  8. SRLMJ23 thread starter macrumors 65816

    SRLMJ23

    Joined:
    Jul 11, 2008
    Location:
    New York
    #8
    She can send me normal texts absolutely fine, no delay or anything. It's just the MMS. I have a feeling it's probably nothing to do with Verizon, it's probably something to do with AT&T and iPhone specifically. I know she can send to other non-iPhone AT&T phones, so it has to be something with iphone and at&t.

    I'm going to reset my network settings and see if that does anything.
     
  9. gr8phan macrumors member

    Joined:
    Mar 9, 2006
    Location:
    NJ
    #9
    I'm having the same issue. I spent over two hours on the phone with both AT&T and Apple, with no resolution. The last tech suggested the Verizon user contact Verizon, as Verizon knows the message is being sent to an iPhone and they are not formatting it correctly. How could Verizon possibly know that? I understand that it *could* be incompatible, BUT Verizon wouldn't know what device was receiving the image, and that doesn't explain how other iPhones can receive messages from Verizon users. Per AT&T's Facebook page, I sent mail to help@attnews.us, and will update back.
     
  10. Rodimus Prime macrumors G4

    Rodimus Prime

    Joined:
    Oct 9, 2006
    #10
    And on an issue here AT&T is going to also turn around and point the finger at Verizon. Verizon will point the finger at AT&T and you will get no where. As soon as you deal with another carrier there is no hope.
     
  11. jaseone macrumors 65816

    jaseone

    Joined:
    Nov 7, 2004
    Location:
    Houston, USA
    #11
    I am receiving MMS's from my friend on Verizon to my iPhone on AT&T just fine, Verizon especially is notorious for inter carrier texts not going through so it could be extended to MMS's as well.
     
  12. thecellar macrumors regular

    Joined:
    Feb 13, 2008
    #12
    i just got a 3gs and i still had my verizon bb curve, and i tested the mms delivery back and forth from each phone, at first i did not receive messages from the vzw blackberry to the iphone. Then toying around with it and trying different things, i found that i only received messages from the verizon blackberry to the iphone mif the picture was stored in the bb's phone memory. Anything i sent from the memory card in the bb was not received when sent to the iphone.....i know this is odd, i dont understand why this happens....maybe its a verizon thing or a blackberry issue? dont know
     
  13. daihard macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
    #13
    I am having a similar issue of not being able to send/receive MMS with those with T-Mobile and Verizon. In particular, I am able to send SMS (i.e. text-only) to a co-worker who uses a jailbroken iPhone with T-Mobile, but he does not receive any of my MMS's. :(
     
  14. SRLMJ23 thread starter macrumors 65816

    SRLMJ23

    Joined:
    Jul 11, 2008
    Location:
    New York
    #14
    I think I figured it out...I reset my network settings on both my iPhone 3g and 3GS and BAM, pictures from my girlfriend (verizon) and friends (sprint) started coming through fine. So I suggest you try that, might be the answer.

    But thanks to everyone for the help!!
     
  15. Loud328 macrumors newbie

    Joined:
    Sep 28, 2009
    #15
    I am having the same problem but it is limited to only a few friends who are on verizon. Some people on the verizon network can send MMS to me and it works fine while others cannot. I am going to try resetting the network settings and see if this works for me as well. anymore info on this subject would be appreciated
     
  16. thecellar macrumors regular

    Joined:
    Feb 13, 2008
    #16
    i just tested again.....this time sent a video from my vzw blackberry to my att iphone.....took about a minute, received it with no problem. tryed sending a picture again (that was stored on the vzw bb memory card) never received it on the iphone.
     
  17. SRLMJ23 thread starter macrumors 65816

    SRLMJ23

    Joined:
    Jul 11, 2008
    Location:
    New York
    #17
    Yea it appears that resetting your network settings is only a temporary fix...as I just had some friends on Verizon send me pics again...got nothing again.

    I think I might restore the phone completely...
     
  18. Redneck1089 macrumors 65816

    Redneck1089

    Joined:
    Jan 18, 2004
    #18
    This is a problem I have experienced for some time now in Canada. A lot of my friends that are on the Telus network cannot receive my MMS'. In particular, sending video MMS' are the worst and are usually only received a quarter of the time. Another problem with the video MMS' is that people on Bell or Telus get the video with corrupted audio.

    People with other iPhones and or other phones but are still on the Roger's or Fido networks receive MMS' pictures and video just fine...
     
  19. daihard macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
    #19
    When you send/receive MMS with other iPhone users, how long does an MMS typically take to get to the recipient? I am asking because it seems to take at least a few minutes in my case whereas an SMS is almost instant.
     
  20. Primejimbo macrumors 68040

    Joined:
    Aug 10, 2008
    Location:
    Around
    #20
    sorry for the dumb question, how do you rest the network?
     
  21. Luigi239 macrumors 6502a

    Joined:
    Jan 25, 2007
    #21
    I found the same thing as you.

    If you restore, please let us know if it fixes the problem.
     
  22. SRLMJ23 thread starter macrumors 65816

    SRLMJ23

    Joined:
    Jul 11, 2008
    Location:
    New York
    #22
    To reset your network simply go to settings...scroll all the way down to the bottom where it says reset, go in that menu and you'll see a tab for reset network settings...you will lose any passwords for your wi-fi and stuff like that, nothing big though.


    I will be doing the reset around 10:30 ET, ill update and let ya know...
     
  23. Primejimbo macrumors 68040

    Joined:
    Aug 10, 2008
    Location:
    Around
    #23
    Thanks!!! I'll check back to see how it goes for you.
     
  24. Loud328 macrumors newbie

    Joined:
    Sep 28, 2009
    #24
    I reset the network settings and still having the same problems. I am going to take it to an AT&T store first and then try the apple store by my house. i just find it strange that so far the only MMS messages that i dont receive are only from one person but this person has received all of mine. I have had friends on AT&T, Verizon, and Sprint all send me MMS texts and all have worked. I just find this to be very odd
     
  25. WolverineGuy macrumors member

    Joined:
    Mar 10, 2009
    #25
    I'm having the exact same problem. My friend is on the Verizon network. She's received everything I've sent, but I can't get anything from her.
     

Share This Page