Can't Select Airplay Device for Output Audio

Discussion in 'OS X Mountain Lion (10.8)' started by Peligroso, Jul 26, 2012.

  1. Peligroso macrumors member


    Aug 29, 2009
    New Mexico
    It shows up as one of the options, but when I select it to automatically reselects the built-in speakers. Any ideas?

    Thanks in advance!
  2. bitrip macrumors newbie

    Jul 25, 2010
    Same problem here. Hope someone knows a solution.
  3. tkermit macrumors 68040


    Feb 20, 2004
    Restarting the Airport base station solved it for me.
  4. bitrip macrumors newbie

    Jul 25, 2010
    weird...same here!
    Thanks pal...i could have find out myself :)
  5. wlow3, Jul 27, 2012
    Last edited: Jul 29, 2012

    wlow3 macrumors regular

    Sep 9, 2008
    Same issue

    Same problem here. My 2008 iMac with Mountain Lion sees both my Apple TV and my AirPort Express but it won't let me keep the choice of either in the Sound pane of System Preferences (it bounces it back to "headphones" for my attached speakers). I tried restarting the AirPort Express but that did not help. I do have it password protected and nothing has prompted me for a password the way iTunes initially does. (Airplay does work normally with iTunes on my computer.)

    Update: I restarted my computer to address another bug and Airplay started working.
  6. drpeacock macrumors newbie

    Aug 7, 2012
    Same here - rebooting my 2009 iMac fixes the problem. Quite annoying and I hope Apple addresses this because it is the main reason I upgraded to Mountain Lion.
  7. jensg macrumors newbie

    Sep 21, 2012
    I have the same problem... running Mountain Lion on a new Macbook Air 2012 model and I have the new Apple TV. If I restart my Mac, the problem seems to disappear... I think the problem may occur when other devices have recently Airplay'ed something to the Apple TV... my girlfriend and I Airplay music to the ATV from 4 different devices (3 iOS and one OS X).
  8. mozzacheeze macrumors newbie

    Dec 7, 2009
  9. outie2k macrumors regular

    Jun 20, 2010
    It's a bug and should resolve after restarting your Mac. However it will happen again after few uses.
  10. -rhys- macrumors newbie

    Oct 17, 2008
    Same problem! (retina mbp + ATV3).

    Killing coreaudio fixed it for me without a reboot:
    sudo kill `ps -ax | grep 'coreaudiod' | grep 'sbin' |awk '{print $1}'`
  11. twintin, Oct 27, 2012
    Last edited: Oct 29, 2012

    twintin macrumors 6502

    Aug 10, 2012
    Had same issue up to ML on my MBA 2012. However, after upgrade to I have no seen it so far.

    EDIT: Happend again today aftrer 23 days of uptime. However, restarting coreaudiod as suggested above fixed the problem. Now I have reported this to Apple.
  12. rogerjeffs macrumors newbie

    Nov 21, 2012
    Airplay bug

    The fix posted by -rhys- worked for me too. Thanks.
    I wonder why the last 2 messages in this thread are dated 27th Oct when today is only 21st. Another bug?
  13. twintin macrumors 6502

    Aug 10, 2012
    Probably because today we are 21:th of November, not October when those were written. ;)
  14. odog101 macrumors newbie

    Dec 3, 2012
    Try restarting Wi-Fi only

    I was able to get my Airplay enabled speakers selected after just turning off and turning back on my Wi-Fi. A little easier than a full OSX restart.
  15. chrisando1 macrumors newbie

    Dec 3, 2012
    The solution!

    Thanks for the advice, had exactly the same problem and switching on and off the WIFI fixed it immediately:)
  16. MattDell macrumors 6502


    Sep 2, 2006
    London, UK
    Worked for me. Gonna keep this one handy until Apple fixes this permanently. Thanks rhys!
  17. mattyv123 macrumors newbie

    Sep 13, 2012
    Great Tip

    This was killin' me. Great tip, works perfectly every time...

  18. mack3r macrumors newbie

    Nov 30, 2007
    Same here, worked like a charm. Irritating that Apple still hasn't fixed this issue. Hope everyone filed a radar.
  19. bandydesign macrumors newbie

    Jan 11, 2013
    Hack to make the coreaudio fix easier

    Love the sudo command to reboot coreaudio, works like a charm.

    I hate that I have to do that but I made it a little bit easier by making an alias.

    • Open terminal and type:
      vi ~/.bash_profile
    • and add the line:
      alias fixairplay="sudo kill `ps -ax | grep 'coreaudiod' | grep 'sbin' |awk '{print $1}'`"
    • Save the file and close vi :)wq)
    • Restart terminal
    • Then type in:
    • Type in your password and...
    • Voila! You should be good.

    Now each time you run into the issue just type fixairplay in terminal and you're good to go!
  20. deadbolt macrumors newbie

    Jan 19, 2013
    thx + pkill

    Thanks a bunch for this solution guys! I've got the same problem, and it usually started working again by reconnecting to the wifi or sleeping/unsleeping the mac, but suddenly that stopped working too.

    FYI; the command 'pkill' will kill a process by name, so a tad easier solution would be:
    sudo pkill coreaudiod
  21. hougej macrumors newbie

    Feb 9, 2013
    alias help

    This is a great tip and while the code works perfectly, I cannot get the alias to work. Followed the steps above, confirmed the code was saved to ~/.bash_profile, but when I enter "fixairplay" I get <command not found>
  22. artemisworks macrumors newbie

    Oct 29, 2012
    You just need to load your bash_profile.

    Do this at the terminal prompt in your home directory:
    . .bash_profile

    Then your alias should work.

  23. 1=1? macrumors regular


    Jun 1, 2010
    Logged in just to upvote this. Thanks dude.
  24. ironklad macrumors newbie

    Mar 24, 2013
    Toggle Bluetooth fixes this for me

    I am having the same issue with my late 2010 13" MacBook Air with latest updates. I find that when it refuses to select an output device that toggling Bluetooth on or off resolves the issue for me. Frustrating I have to deal with this but at least toggling Bluetooth is a fast operation (though likely not an option if you use a bluetooth keyboard/mouse).
  25. rocteur macrumors newbie

    Nov 20, 2010

    Killing coreaudio fixed it here as well. 2013 iMac.

    I just can't imagine why this problem is not yet solved...

Share This Page