Can't Select Airplay Device for Output Audio

twintin

macrumors 6502
Aug 10, 2012
486
44
Sweden
I just can't imagine why this problem is not yet solved...
As with most bugs, probably because it is not easily reproduceable in a controlled environment or because there are way more bugs that they can handle and hence must prioritize them and this one is not imprortant enough to get any attention (I hope you have reported your issue to Apple to increase the chances to get this fixed).
 
Last edited:

XXXREME

macrumors newbie
Jun 29, 2012
2
0
Orange County, CA
I was able to get my Airplay enabled speakers selected after just turning off and turning back on my Wi-Fi. A little easier than a full OSX restart.
Clicking the Wi-fi icon located in the top right of the screen and turning Wi-Fi off and then back on worked for me. Thanks "odog101"
 

wischnu

macrumors newbie
May 21, 2013
1
0
For someone interested in a small automation of this workaround, I have written a small apple script that toggles between internal speakers and Airplay - taking into account that from time-to-time it is not possible to switch because of the Apple Bug. In this case, the script asks for the Admin password and restarts core audio before continuing.

It is mainly based on the small C program to toggle airplay found here :
http://whoshacks.blogspot.de/2009/01/change-audio-devices-via-shell-script.html

And a proposal applescript that implements it:
http://www.macuser.de/forum/f30/applescript-um-airplay-672797/

Just copy the C programme into the user folder, paste the code below into the AppleScript Editor and save it there as a program.

Code:
property audiodeviceOutputExecutable : "~/audiodevice output "
property internalAudioDevices : "Internal Speakers"
property airplayDevice : "Airplay"
property kill_audio : "pkill coreaudio"


set currentDevice to do shell script audiodeviceOutputExecutable
if currentDevice is airplayDevice then
	do shell script audiodeviceOutputExecutable & quoted form of internalAudioDevices
	
	set currentDevice to do shell script audiodeviceOutputExecutable
	if currentDevice is airplayDevice then
		do shell script kill_audio with administrator privileges
		do shell script audiodeviceOutputExecutable & quoted form of internalAudioDevices
	end if
else
	do shell script audiodeviceOutputExecutable & quoted form of airplayDevice
	set currentDevice to do shell script audiodeviceOutputExecutable
	if currentDevice is internalAudioDevices then
		do shell script kill_audio with administrator privileges
		do shell script audiodeviceOutputExecutable & quoted form of airplayDevice
	end if
	
end if
For me this is working fine and it is much quicker to change to airplay via the dock.
 

swingerofbirch

macrumors 68040
I just started using my Airport Express again (10.8.3) and keep running into this issue. Killing coreaudiod solves it, but I'm not sure what is causing it. Unfortunately, I was working on recording a podcast at the same time and killing coreaudiod messed up the program I was using and it ended up not recording any audio.
 

Europe calling

macrumors regular
Jun 27, 2007
236
0
The Netherlands
I run into the same problem once in a while.
You might want to check if multiple devices are trying to access your remote speakers via airplay simultaneously.
I found out that airplay is blocked for one device when i have activated airplay on another.
For example when have used airplay on my iPad, and have not switched it off after use, iTunes on my MBP will not connect via airplay to my Airport Express (where my speakers are connected to). It is simply 'Occupied' by some app on my iPad. Even when the app isn't running! It seems to remember the setting even when not in use.
If i have not 'disconnected' airplay from within the app (say soundcloud, or Youtube or whatever) airplay will not be available to another device.
 

spjika

macrumors newbie
Sep 1, 2013
1
0
Fixed

I was able to get my Airplay enabled speakers selected after just turning off and turning back on my Wi-Fi. A little easier than a full OSX restart.
Worked for me too, thanks man! Spent some time pssing around with this, thought it was a Spotify issue for ages. Reboot was just not cool, despite being fast (switched from Windows with this BP 2013) it's a pain when you're actually doing something, or have friends over and need to "go reboot" to get music back, lame.

Still, is bug. Fix.
 

BulletinRazu

macrumors newbie
Sep 3, 2013
1
0
Reproduced on latest hardware with all software updated.
Macbook Air 6,2 (2013), 10.8.4. Apple TV 3 (MD199B/A), software 5.3 (6105).

sudo pkill coreaudiod workaround works.

If there is a radar bug for this, please post on this thread.
 

drdeputy

macrumors newbie
Aug 17, 2009
11
0
How long.........?????

This has been messed up for about a year and still no fix from Apple. The wifi and the sudo pkill coreaudiod is nice, but geezzz come on Apple.

The still have ignored the Mail problem with replying with the wrong address too.

Don't care or aren't listening. Take your pick.
 

Stingray454

macrumors 6502a
Sep 22, 2009
587
104
For someone interested in a small automation of this workaround, I have written a small apple script that toggles between internal speakers and Airplay - taking into account that from time-to-time it is not possible to switch because of the Apple Bug. In this case, the script asks for the Admin password and restarts core audio before continuing.

It is mainly based on the small C program to toggle airplay found here :
http://whoshacks.blogspot.de/2009/01/change-audio-devices-via-shell-script.html

And a proposal applescript that implements it:
http://www.macuser.de/forum/f30/applescript-um-airplay-672797/

Just copy the C programme into the user folder, paste the code below into the AppleScript Editor and save it there as a program.

For me this is working fine and it is much quicker to change to airplay via the dock.
Thanks! I did this, the only change needed was that my Apple TV device was called "Apple TV" and not "Airplay". Other than that, it works flawlessly. :)

I had a hard time making my girlfriend going into the terminal when she wants to listen to music in the living room ;) A button to click marked "Music in livingroom" was a bit easier to handle for her.
 

shane9666

macrumors newbie
Oct 12, 2013
1
0
An interesting twist...

I'm running Mavericks and the problem I'm currently having is that selecting Airdisplay for the display and selecting it for the audio are mutually exclusive. Before killing audio I was having the exact same problem everyone describes: I would select it as the audio output and it would automatically reselect built-in audio output. When I killed audio it stopped my airdisplay, and now the two things are mutually exclusive. Anyone else seen this issue?
 

drevicko

macrumors newbie
Jan 4, 2014
1
0
I found that with opt-click on the task bar sound icon didn't have the airport I wanted in the dropdown after restarting (aka killing) coreaudio - I had to go to the system sound preferences, and could select it from there. After that it appeared in the dropbdown.

I have 2 airports daisy-chained (an old one "joining" the network of a new one, which is attached by cable to my adsl modem).

I did this so music to the old has a dedicated wifi n/w. I have a suspicion that the problem is related to wifi communication/bandwidth issues: when there's lots of wifi traffic and/or a weak connection, stuff gets lost, if too much gets lost, I guess something panics :)
 

jasonefmonk

macrumors regular
May 5, 2011
200
174
I just found and killed the coreaudio process in Activity Monitor and it worked. Thanks for the tip.
 

Krayle

macrumors newbie
Apr 20, 2014
1
0
This guy nailed the simpler of workarounds....

Guys,

Loving the creative command and alias workarounds, but it just doesn't get any simpler than what this guy is suggesting. I did it and it works. No need for command line interfacing whatsoever.

I was able to get my Airplay enabled speakers selected after just turning off and turning back on my Wi-Fi. A little easier than a full OSX restart.

Yup, just flicking the WiFi off and back on from the (for me) upper right corner of my screen does the trick. Done and done.

Thanks odog101!:D


--Krayle
 

sweetdovejoy

macrumors newbie
May 2, 2014
1
0
my apple mac book air 13 inch sound wont work anymore

i've tried everything but sound refuses to come back and whenever i try to turn up or reduce the volume it comes up with a mute signal then i tried to take off the mute, it failed to go off. On preferences my sound has no input nor output but sound effects has options, im unable to select any options on sound effect and it marks the mute box which means my laptop is permanently muted. PLEASE HELP
 

noiseordinance

macrumors regular
Sep 12, 2012
249
8
What a stupid problem to have exist for over two years across 2 OSX distros... possibly 3 if still present in Yosemite. The idea that this problem is difficult to replicate, and thus hard to fix, is complete hogwash. This is a constant, weekly problem for folks who use Airplay.
 

allenkey

macrumors newbie
Sep 23, 2013
6
0
hi, i tried the codes:
sudo killall coreaudiod

and

sudo kill `ps -ax | grep 'coreaudiod' | grep 'sbin' |awk '{print $1}'`

and they seemed to work, but now a day later, i can connect to the airport, but no audio is coming out of the speakers... neither from my laptop nor iphone.

i have tried rebooting the computer, and unplugging the router for 30s... and tested the speakers to be working when hard wired. still no luck on the airport express airplay, which did work before i tried the codes.

any thoughts?
 

tomguine

macrumors newbie
Aug 26, 2015
1
0
Same problem! (retina mbp + ATV3).

Killing coreaudio fixed it for me without a reboot:
sudo kill `ps -ax | grep 'coreaudiod' | grep 'sbin' |awk '{print $1}'`
Thanks, -rhys-. Created an account just to thank you, only your solution worked for me! Thanks again!