Can't send SMS messages on iOS 9.1 AND 9.2b1

Discussion in 'iOS 9' started by gabriellefunk, Nov 3, 2015.

  1. gabriellefunk macrumors member

    Joined:
    Jun 10, 2015
    #1
    I have an iPhone 5C on AT&T and I haven't been able to send SMS messages on both iOS 9.1 GM and 9.2 beta 1 AND beta 2. I have Reset Network Settings, done a hard restart, toggled iMessage and SMS Messaging off and then back on....I feel like I've tried everything.

    Has anybody else had this problem? If so, how did you fix it or are you still dealing with it?
     
  2. snsking macrumors 6502

    snsking

    Joined:
    Jun 10, 2013
    #2
    YES! I thought I was the only one.. I am currently on the 9.2 (B1) and almost every SMS message I try to send, never sends. It comes up with that exclamation mark saying "not delivered". Extremely annoying. I am not sure what is the case or what is happening with the network management on iOS9.2
     
  3. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #3
    I don't get the exclamation mark OR the "Not Delivered," mine goes all the way through and LOOKS like it's sent but when I ask the recipient if they got the messages, they say no every time. It's quite deceiving. I'm not sure either but I would love it if they got it fixed soon. I'm going to report it as a bug, but in the mean time it's nice to know that I'm not the only one suffering out there.
     
  4. snsking macrumors 6502

    snsking

    Joined:
    Jun 10, 2013
    #4
    [​IMG]

    It'll go through, but 3 seconds later, it appears like that. Only with SMS.
     
  5. sbailey4 macrumors 68030

    sbailey4

    Joined:
    Dec 5, 2011
    Location:
    USA
    #5
    Verizon here and no issue with SMS on either 9.1 or 9.2.b1. Maybe its an AT&T thing not an iOS bug.
     
  6. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #6
    That's actually really helpful, thank you. AT&T always causes issues and it's getting annoying. Streaming Apple Music still lags sometimes.
     
  7. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #7
    Maybe sbailey4 is right, and it's just an issue for AT&T users?
     
  8. WaruiKoohii macrumors regular

    Joined:
    Oct 4, 2015
    Location:
    Boston
    #8
    I had this happen on a couple of the 9.1 Betas and also the GM.

    Turn off LTE entirely, see if you can send a SMS/iMessage. If you can, turn LTE back on, try it again.

    Every time this happened to me, turning off LTE then turning it back on fixed the issue for me. Resetting network settings and doing a hard reboot did not help.

    EDIT: I'm an AT&T user for what it's worth.
     
  9. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #9
    I was just about to ask you if you were an AT&T user when I noticed your edit. I tried that and I didn't have any luck, but I really appreciate your help! Are you running iOS 9.2 now? Is the issue resolved for you? I'm fortunate to not have very many friends that don't own an iPhone, but my boss has an Android so it's given us lots of problems recently.
     
  10. WaruiKoohii macrumors regular

    Joined:
    Oct 4, 2015
    Location:
    Boston
    #10
    I was on 9.2B1, and now I'm on 9.2B2, and the issue hasn't happened again. I suspect it was a radio bug since the modem firmware was updated in the same 9.1 build where I first encountered the SMS bug. 9.2B1 (and B2) introduced new modem firmware.
     
  11. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #11
    I first encountered it with 9.1 as well, but it's stuck with me through both 9.2 betas. Any idea why?
     
  12. WaruiKoohii macrumors regular

    Joined:
    Oct 4, 2015
    Location:
    Boston
    #12
    Really can't say.

    Try disabling LTE and rebooting, then sending an SMS using 3G. Just for laughs, since it can't hurt.
     
  13. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #13
    Unfortunately, that didn't work either. I appreciate everything you've done for me though! I guess I'm just going to have to utilize FB Messenger or some other messaging app in the meantime. Hopefully beta 3 or even 4 fixes this.
     
  14. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #14
    The weirdest part is that I can receive them, I just can't send them. It does not make any sense whatsoever.
     
  15. WaruiKoohii macrumors regular

    Joined:
    Oct 4, 2015
    Location:
    Boston
    #15
    Yeah that's what was happening to me as well. Very strange. I think it's probably a modem firmware bug.

    Out of curiosity, what's the modem firmware version for you in 9.2? iOS 9.1 upgraded it to 6.01.00. It's possible that it hasn't changed again (like the 6s modem firmware has).
     
  16. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #16
    It says that my Modem Firmware is 5.00.11.
     
  17. snsking macrumors 6502

    snsking

    Joined:
    Jun 10, 2013
    #17
    Whats also weird is it takes forever to send. Normally, an SMS would be sent within 1-2 seconds. Now it takes about 3-4. I also suspect its a network iOS bug, and not so much AT&T
     
  18. AmazingTechGeek macrumors 6502

    AmazingTechGeek

    Joined:
    Mar 6, 2015
    #18
    Has anyone tried deactivating and then reactiviating iMessage?
     
  19. WolfSnap macrumors 6502a

    Joined:
    Sep 18, 2012
    Location:
    SoCal
  20. S8ER01Z macrumors member

    Joined:
    Jun 17, 2015
  21. snsking macrumors 6502

    snsking

    Joined:
    Jun 10, 2013
    #21
    It seems others are having this issue as well. One user mentioned this as a solution: turn LTE to data only. Disable for voice. Its worked for now, and it seems to be an AT&T issue and they are working on a fix
     
  22. WolfSnap macrumors 6502a

    Joined:
    Sep 18, 2012
    Location:
    SoCal
    #22
    So, I was able to get ahold of AT&T tech support. They said there was a missing cellular profile. They resent the activation codes to the iPhone, and now everything works.

    If you're experiencing the issue, have AT&T resend the activation codes. That might help you.
     
  23. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #23
    What does this mean? Basically, was this due to the betas? I just updated to 9.2 b3 and it still seems to be an issue. If that fixed the problem for you I am more than happy trying it out!
     
  24. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #24
    Update: I was on the phone with AT&T Tech Support for an hour. They resent my activation codes, tested my line, and we made sure that I could send SMS messages by texting the number 151 with "Test" in the body. AT&T responded and said that my messaging seems to be working.

    I texted two of my friends, both Android users, and still no luck. The lady that I was working with was super helpful and nice, but unfortunately we didn't get a chance to reconnect because I called her while I was at work and then got busy. So, for right now, I'm still in limbo. Anyone else experiencing this issue still?
     
  25. snsking macrumors 6502

    snsking

    Joined:
    Jun 10, 2013
    #25
    I posted the solution above^^. Disable LTE for voice. Everything will work perfectly after that
     

Share This Page