Can't update AE firmware to 7.5.1

Discussion in 'Mac Accessories' started by Martyimac, Mar 31, 2010.

  1. Martyimac macrumors 6502a

    Martyimac

    Joined:
    Aug 19, 2009
    Location:
    S. AZ.
    #1
    Supposedly a firmware update was released today for the Airport Extreme. It's posted on Apple's site along with an update to Airport Utility. I updated Airport Utility to the most recent version, 5.5.1 IIRC. But using my Macbook, it says no firmware update is available. On my PC, AU also says there is no update available. So has Apple posted a webpage saying there is an update but no update is actually available? My AE is still on 7.4.2.

    Thanks
     
  2. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #2
    The update is for "AirPort Extreme Base Station (Late 2009)". If you have an older model, it's probably not going to work with 7.5.1 (unfortunately).

    I have one of those, which I have to run on 7.4.1 because of trouble with 7.4.2. I was hoping 7.5.1 would fix that, but it looks like I'm out of luck.
     
  3. Martyimac thread starter macrumors 6502a

    Martyimac

    Joined:
    Aug 19, 2009
    Location:
    S. AZ.
    #3
    Found this on another thread:

    Then you don't have the Late-2009 model, which means the update does not apply to you.

    There were two Dual-Band models, the MC763LL/A and the MC340LL/A. The latter being the latest model.
    __________________

    Only the MC340LL/A gets the update I guess. Oh well.
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    Shouldn't that be MB763LL/A is the older and the MC340LL/A is the newer? You have them both starting with MC.
     
  5. Martyimac thread starter macrumors 6502a

    Martyimac

    Joined:
    Aug 19, 2009
    Location:
    S. AZ.
    #5
    Yep, the MB is the older model.. I had just cut and pasted that post from somewhere else and didn't proof it.

    Thanks
     

Share This Page