Auto CarPlay - Can't get it to come on with Pioneer AVH-4200NEX

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by convergent, Jun 7, 2016.

  1. convergent macrumors 68000

    convergent

    Joined:
    May 6, 2008
    Location:
    Raleigh, NC
    #1
    Because MR won't create a CarPlay forum, this is where this gets to go.

    This is to hopefully help other folks that are having a problem with new CarPlay use.

    I bought and installed a Pioneer AVH-4200NEX head unit for my F-150 truck. Got it wired up and could not get it to respond to my iPhone 6S+ for CarPlay at all. That unit requires connection via USB for CarPlay. If I connected by Bluetooth it would play music and all fine, and the phone would work through the Pioneer. But connecting to USB resulted in no acknowledgement that it was there.

    On this Pioneer, it has two USB ports and you must use USB port 1 for iPhones and CarPlay, and USB port 2 for Android. I didn't remember for sure if I had the right one, so I took my dash apart again to check. Then tried removing the included extension cable... also tried several different lightening cables. After a couple hours of frustration and cable checking, I decided to try my daughters iPhone 6. It immediately connected and CarPlay worked fine. Argh... hours of frustration.

    Then to figure out why. I could not find the CarPlay option in Settings. Its supposed to show up in General right after Handoff & Suggested Apps. Was there an my daughters, not on mine. After a lot of googling, I discovered that the most likely cause was that it was somehow disabled in Parental Restrictions, which is called just Restrictions under General settings. I tried to go in and change it, and found that I needed a restrictions passcode which I don't have. I don't remember ever setting it, but must have. There is no way to reset this passcode... poor design. I tried a couple of "hacks" I found online to change it, but updating various plists on the phone and/or in the backup file and restore. None of those worked, so my only resolution was to reset my iPhone as new and start over. That was painful, but after doing it all is well and CarPlay works fine.

    Just posting this here to hopefully save others the frustration I went through trying to get it to work.
     
  2. Eriamjh1138@DAN macrumors 6502

    Eriamjh1138@DAN

    Joined:
    Sep 16, 2007
    Location:
    BFE, MI
    #2
    Thank you for this post. I had rented a CarPlay-enabled vehicle, but it wouldn't come up when I plugged in my phone. Searching for Carplay in Settings only comes up with General, but it should also come up under Restrictions, which it doesn't.

    I had stupidly disabled it way back, but I remembered my code. Now, it is enabled, and I have no car rented (returned).

    Until next time...
     

Share This Page