Auto CarPlay issues - disconnects after iOS 10

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by KDR, Sep 16, 2016.

  1. KDR, Sep 16, 2016
    Last edited: Sep 16, 2016

    KDR macrumors regular

    Joined:
    Mar 8, 2007
    #1
    So bummed that CarPlay is not working for me after iOS 10 update. When I connect after a fresh reboot, Carplay will connect for a minute or two. Then the car says no device connected out of nowhere, however if there was music playing (e.g. Pandora), it continues but CarPlay is not accessible. Once I disconnect the phone the phone itself behaves irratically. Freezes up, gets white screen when I go to settings. After rebooting the phone and not connecting the phone to the car the phone works fine. I've tried forgetting the car in carplay setting and re-allowing it, but that doesn't help. Any ideas or similar experiences?

    BTW, this happened on my 6S Plus and now the 7 that I restored the 6 backup to.

    I'm tempted to do a reset and clean install of iOS10 on the new phone, but hate to lose all my data. My email and photos are all in the cloud. Is there a way to save text messages, etc. and restore to a clean install without having to restore everything from an iCloud backup?
     
  2. PeteLP macrumors regular

    Joined:
    Sep 12, 2008
    #2
  3. Madmischief macrumors newbie

    Joined:
    Nov 16, 2013
    #3
    Yeah mine works fine with iOS 10 and a pioneer sph da100
     
  4. scr1968 macrumors regular

    Joined:
    Sep 4, 2007
    #4
    My iPhone 6+ kinds sorta works with CarPlay.

    Most of the time, if my iPhone is "dirty" (i.e. - I have been using it / other apps) and I plug it into my 2016 Honda Civic, CarPlay will "crash" within two minutes with a "No Device Connected" message.

    If I restart my iPhone prior to connecting it to my car, I can't think of an instance where it has not worked flawlessly.

    I just got my Civic a couple of months ago so I can't confirm or deny that CarPlay worked better with iOS 9. Most of my experience has been with iOS 10 and it has been frustrating. Even tried using the latest public beta yesterday and ran into the "No Device Connected" message pretty quickly. Bummer!

    Last week I tried the complete restore (without using a backup) idea but that didn't help in my case.

    SCR
     
  5. xraydoc macrumors 604

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #5
    See if there's a software update from Honda for your vehicle. You'll probably have to do that at the dealer.
     
  6. scr1968 macrumors regular

    Joined:
    Sep 4, 2007
    #6
    I'll self-bump this thread a bit with a little information...

    This still does not work, even with the latest public beta of 10.3. But I have found the root cause (in my case) and I suspect it affects others who are seeing similar issues in their Hondas (or other makes of cars...)

    This has to do with having a large Apple Music library. If you disable Apple Music then CarPlay works much better. Alternately, if you use an iPhone with a small Apple Music library it should also work. For example, my iPhone 6+ has about 37000 songs and does not work but my wife's IPhone 7 with less than 2000 songs (if that) works perfectly fine in my 2016 Civic.

    Rumor has it, this is a Honda issue and that there is a fix in the works but no one has seen it yet.
     

Share This Page