Carrier 5.6 defined

Discussion in 'iPhone' started by Gix1k, Oct 15, 2009.

  1. Gix1k macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
    #1
    Here is why it was released for those that do not know.

    Along with iPhone 3.1.2, AT&T users received a 5.6 carrier file update, but the reason(s) for it weren’t clear. MMS was already enabled, and tethering was nowhere in site, so what was it for? Well, Turns out, it fixed an MMS bug:

    When sending photos or videos in an MMS message, the progress bar would stall at about 90% then result in an error ending with a (!) red exclamation point next to the MMS message. The associated message failed to be properly sent, though standard text messages worked as normal. The 5.6 patch addressed that particular MMS issue.
     
  2. efp1 macrumors 6502

    efp1

    Joined:
    Oct 3, 2008
    Location:
    UK
    #2
    I think it also enabled VoIP over 3G network.

    I'm in Spain and I also upgraded to 3.1.2 but VoIP does not work over 3G, only over wifi. I'm assuming the carrier update AT&T sent out enabled it.
     
  3. ACKRITE macrumors member

    ACKRITE

    Joined:
    May 11, 2008
    Location:
    West Hartford, CT
    #3
    So was it infact this bug, and not a B2B text-only plan, that was causing this issue for so many people? Now that 5.6 have been released show someone with a B2B plan be able to send/receive MMS?
     
  4. ViViDboarder macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #4
    Nope. Whether an app works over 3G or not is totally dependent on the developers.

    They have not yet enabled it because many carriers complained, but due to the recent onset of NetNeutrality in the US, AT&T said they would permit VoIP apps so we'll see if Apple starts approving them.
     
  5. efp1 macrumors 6502

    efp1

    Joined:
    Oct 3, 2008
    Location:
    UK
    #5
    Really? I read in another thread that 3.1.2 enabled VoIP over 3G.

    I hope they enable it soon. Usually the rest of the world suffers when a decision is made that should only affect American users (because of AT&T.)
     
  6. Colonel Badger macrumors 6502

    Joined:
    Jun 30, 2008
    #6
    As was previously said applications like Skype are limited to Wifi in the APP not the baseband file. Skype is in fact waiting for Apple to change its T's&C's before submitting a version that allows VOIP over 3G. Apparently even though AT&T have now allowed this Apple haven't changed their policy yet!
     
  7. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #7
    No, that's a software issue. For VoIP to happen Apple needs to release 3.2.0 or something.
     
  8. ViViDboarder macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #8
    Not true. As stated it's a per app thing. There are lots of apps that are jailbroken that can work over 3G and require no undocumented API's. They just don't get approved by apple because it's against their terms, as stated above.
     
  9. efp1 macrumors 6502

    efp1

    Joined:
    Oct 3, 2008
    Location:
    UK
    #9
    Thanks for the info, guys! At least now I can rest assured that I'll most likely be able to use Skype over 3G even though I'm not in the U.S. :)
     
  10. HKY macrumors newbie

    Joined:
    Oct 17, 2009
    #10
    Will carrier update break jailbreak or unlock?

    From what I have read, carrier wouldn't break the jailbreak. What about ultrasn0w? Does the carreir update the baseband firmware? Can anyone confirm for me on both fronts?
     

Share This Page