Challenging printer problem, I need your help!

Discussion in 'Mac Basics and Help' started by Hobbit, Oct 22, 2007.

  1. Hobbit macrumors member

    Jun 24, 2005
    I am struggling to reinstall my printer Epson DX4850 (same as DX4800).

    My printer was working very well with my MacBook. Never had a problem with it. Recently i was playing with a programme called MacPilot and tried all the options there including cleaning, repairing and deleting preferences, etc. and this seems to have uninstalled my printer somehow.

    I tried to reinstall my printer since then using the driver from Epson website but I keep getting the following error message when i tried to add the printer using the printer setup utility. The message says:


    I searched the forum and tried the following but i'm still getting the same error.

    1. Reset the Printing System via the Printer Setup Utility.
    2. Reboot
    3. Open Terminal
    4. cd /Library/Printers
    5. sudo mv EPSON EPSONold
    6. ctl-D or exit to close Terminal

    Can someone please help.
    Thank you.
  2. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    A question:

    That error seems to be a CUPS error; are you using the CUPS driver? If so, does Epson have a "native" (not sure what the correct term is, actually) for that printer, and does it work?

    If it IS a CUPS error, then it sounds rather like you broke the CUPS subsystem, rather than it being an Epson driver-specific problem--this would explain why a reinstall didn't fix it.

    Just out of curiosity, enter this in the terminal:

    sudo ls /var/spool/cups

    ...then give sudo your password. It should list the contents of the cups director, which will include a "tmp" directory and a few other things. If it doesn't (or you get no list at all), MAYBE that's the issue. Worth a shot recreating those directories.
  3. Hobbit thread starter macrumors member

    Jun 24, 2005

    Thank you for your quick reply. I'm afraid i'm not a computer expert so i'm not sure what CUPS driver means, but i know that the Epson driver installed fine and my printer was working fine in the past.

    I did what you asked me to do in a terminal and here is the reply i got.

    ls: /var/spool/cups: No such file or directory

    Any idea what i should do next? An explanation as to what the problem is would be highly appreciated.

    Thank you.
  4. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    First, CUPS ("Common Unix Printing System") is essentially a cross-platform framework for printer drivers, and there are "unofficial" drivers for a LOT of printers available for it. I don't pretend to understand the details, but basically it's an alternate system the MacOS can use to print stuff.

    My suggestion actually came from suggestions at a Linux help forum; I've never heard of people breaking CUPS on a Mac before, but it sounds like that at least COULD be your problem.

    The message you got means that the /var/spool/cups directory doesn't exist at all. That is (I think) where CUPS stores some of its temporary info. It exists on my Tiger install, so I'm assuming it's necessary, and since the error you are getting appears to be a CUPS error maybe your cleaner tool deleted it.

    You can try entering the following two commands in the terminal, which should re-create the cups folder and the temp (tmp) folder that's supposed to be in it.

    sudo mkdir /var/spool/cups
    sudo mkdir /var/spool/cups/tmp
    The first time you will be asked for your admin password. What those commands are: "sudo" means execute the rest of the command as a superuser, which bypasses the fact that you probably don't normally have permission to write anything to the /var/spool directory. That's what asks you for your password. "mkdir" means "make directory" and then the /var/spool/... is the place to create the directory. Be sure to enter the commands precisely as above, including the initial slash, or it'll create the directory somewhere else.

    If that fixes it, then this was the problem. If not, I'm out of guesses.

    Oh, and on a related note, you should (probably after doing the above, though I don't know that it'll make any difference) run "Repair Disk Permissions" on your startup disk using Disk Utility. That could, theoretically, also make a difference.
  5. Hobbit thread starter macrumors member

    Jun 24, 2005

    Big thank you to you. The problem is now solved after creating the CUPS/temp folder.
  6. JennyPennyO macrumors newbie


    Sep 11, 2008
    Western PA

    i am having the same problem, except my printer is new, and i am installing it onto my macbook for the first time. but every time i try to add the printer, i get that error. i have NO idea how to fix this, and what you guys are talking about reads like german to me (im not very computer smart)

    someone please help me, i need my printer for college :(
  7. alphaod macrumors Core


    Feb 9, 2008
    If you can't put it into Terminal yourself thentake the command and have a friend or Genius do it.

Share This Page