Chinese characters gone in Firefox

Discussion in 'Mac Apps and Mac App Store' started by Dreamer2go, Jan 18, 2008.

  1. Dreamer2go macrumors 6502a

    Jun 23, 2007

    I don't know what I did, but firefox lost the ability to display some chinese characters correctly.

    Safari's character code = default
    Firefox character code = Unicode (UTF-8)

    It only happened today. Before, Firefox displayed the chinese characters correctly.

    The only thing I did today was removing Office 2004, and installing Office 2008. I tried reinstalling Office 2008, and it wasn't the problem.

    Please advise!!!

    Attached Files:

  2. clevin macrumors G3


    Aug 6, 2006
    did you try to change the encoding from view->character encoding?
  3. Dreamer2go thread starter macrumors 6502a

    Jun 23, 2007
    yes I did
    I tried all the related codings for Chinese Traditional, as well as the Unicode, but it doesnt work...
  4. clevin macrumors G3


    Aug 6, 2006
    try clear cache, cookies, let me know if it helps.
  5. Dreamer2go thread starter macrumors 6502a

    Jun 23, 2007
    I tried removing firefox and reinstalling it
    as well as clearing the cache and cookies and browsing history...still doesnt work...

    This is bothering me.
    I don't like to use Safari because there isn't the CMD + 1,2,3.... fast tab switching...
  6. Dreamer2go thread starter macrumors 6502a

    Jun 23, 2007
    ok I found your other post about how to recreate the profile manager

    still doesn't work =(
    It was working like 10 hours ago!! arg I'm kinda mad.
  7. clevin macrumors G3


    Aug 6, 2006
    ok, if it works fine just 10 hours ago, and you did not install any extensions for firefox, I would suggest you wait and see if it will get better tomorrow. sometimes its not your problem.
  8. Dreamer2go thread starter macrumors 6502a

    Jun 23, 2007
    it works for my firefox in windows xp via bootcamp :(
  9. clevin macrumors G3


    Aug 6, 2006
    check font settings for traditional chinese? play around with it a little bit

    Attached Files:

  10. Dreamer2go thread starter macrumors 6502a

    Jun 23, 2007
    how did you get this box? (appreciate your help so far)
  11. CaptainHaddock macrumors 6502

    Jul 6, 2004
    Nagoya, Japan
    Clearly *some* of the Chinese text is working fine. It could just be that Yahoo Hong Kong has some mis-encoded text on their home page at the moment.

    Another possibility is that a font mismatch could have been caused by a font over-written by Office 2008. You could try figuring out what fonts have been changed or added, and what fonts Yahoo specifies. Are you having this problem on other websites?

    You could also try creating another user and running Firefox there to see if there's any difference.
  12. bigcracker22 macrumors newbie

    Jan 19, 2008
    I have the same problem!

    I have the exact same problem!! and i know its not a problem with hong kong yahoo since i have seen other sites like with the same problem too. The only thing i can do for now is to use FireFox 3 beta 2. That seems to be working fine for me. Maybe you can try that too and just wait for FireFox 3 to be release ... :(
  13. Dreamer2go thread starter macrumors 6502a

    Jun 23, 2007
    I did a fresh clean reinstall of OSX just now (I was planning to do it for a while)

    and guess what, it didn't fix anything lol.

    I think it's actually Office:Mac 2008's thing with firefox fonts...the fonts are conflicting I think..
  14. Dreamer2go thread starter macrumors 6502a

    Jun 23, 2007
    I downloaded Firefox 3 beta
    yeah sites like and uwants and returned normal....

    sigh is it really Office Mac 2008's fault? did you install it?
  15. bigcracker22 macrumors newbie

    Jan 19, 2008
    Yep! it was happening ever since i installed office 2008 too. Like you, i tried a lot of different thing like removing firefox and reinstalling it , etc. Thank God Firefox 3 beta is working ... cos just like you .. not a big Safari fans...
  16. armaniboi macrumors newbie

    Jan 22, 2008
    I have the same problem. After installing Office 2008, Firefox couldn't handle some Chinese characters, especially prevalent in the yahoo hong kong blog pages ( Japanese encoding wasn't affected. Works fine on Safari though.

    It's not too big a problem for me, but just annoying since I'd have to use safari for Chinese pages. Hoping for a fix soon, even though I'm not sure which end it would come from.
  17. lotuseater macrumors newbie

    Jan 24, 2008
    i'm having the same problem too, and it started right after installing mac office 2008. i'm downloading firefox 3 now. i hope that this works well, even though it is in beta. as everyone has said, i don't enjoy using safari.

  18. crazzymonkey macrumors newbie

    Feb 1, 2008
    guys, i have the exact same problem here. Just wondering have you guys found a fix other than using firefox 3?

    how's ur experience with FF3 so far?

    i originally wanted to find a way to fix the fonts and tried not to use FF3 since it is still in beta. However, seems like upgrading to FF3 is the easier way out.

    Thanks for your input in advance.
  19. Dreamer2go thread starter macrumors 6502a

    Jun 23, 2007
    firefox 3 is very buggy
    crashes a bit
    but useable...

    I prefer Firefox 2 though...but no choice for now.
  20. spriter macrumors 65816


    May 13, 2004
    I found the 3.0b2 pre quite buggy (banking sites,, crashing editing bookmarks and more). Now I use the 3.0b3 nightly which is much more stable.

    I've not had problems with Office 2008 killing my Firefox Chinese fonts but I cannot get Word (all of Office?) to display chinese characters in documents people send to me properly - characters just show as boxes. If I resave out as .docx then they magically display properly. However, when I email them back to a Word 2004 used they must use a convertor to open the .docx file at their end. So we both have a workaround but it's hardly ideal.

    I'm curious why Word 2008 cannot properly display Word 2004 docs with Chinese characters in. :confused:
  21. niepan macrumors newbie

    Feb 9, 2008
    Here is a quick fix for the font problem

    I had exact problem, after installing office 2008 on my leopard and removing the old Office 2004, firefox and camino can no longer display some chinese pages. Removing profile, preference plist and reinstalling firefox and camino does not help. It seems these pages specify a windows specific font which was included in office 2004 when it is removed, both browser can no longer display the page using these fonts. It is one of the "song ti" font, but I didn't figure out which file I need to keep yet. I hope my time machine kept all the files.

    But for a quick fix:

    in Firefox:
    Preferences -> Content -> In Fonts and Colors section click Advanced -> uncheck "Allow pages to choose their own fonts, instead of my selection above"

    In Camino:
    Preferences -> Appearance -> Fonts -> check "Always use my fonts"

    This is offers a temporary relief. If anyone figures out which font I need to restore please post a message here.
  22. Larry022 macrumors newbie

    Nov 29, 2005
  23. Dreamer2go thread starter macrumors 6502a

    Jun 23, 2007
    I done that
    but some font in the page became...wrong
    like it's not suppose to be that word.
  24. paradyse macrumors newbie

    Feb 26, 2008
    Anyone figure out how to fix it? i have this problem too, got Office 2008 and no Office 2004 installed before.

Share This Page