Chrome excruciatingly slow

Discussion in 'Mac Basics and Help' started by piatti, Mar 15, 2012.

  1. piatti macrumors 6502a

    piatti

    Joined:
    Jun 9, 2010
    Location:
    USA
    #1
    One one of the users the Chrome is very slow and I am not sure what's causing this. Must be a bug with one of the extensions or something. How do I delete the whole thing and start again, without deleting the same in other users?
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    Allow Chrome to update itself. Run an addon called "too many tabs" and demote most of your tabs to the "suspended" column. Enable "click to play" in chrome so flash can't run behind your back.
     
  3. piatti thread starter macrumors 6502a

    piatti

    Joined:
    Jun 9, 2010
    Location:
    USA
    #3
    I've tried some stuff like disabling some extensions but it didn't help and I would like to start from scratch. So I would like to just delete the whole thing and start from scratch.
     
  4. Maverick513 macrumors member

    Joined:
    Dec 13, 2011
    #4
    You can delete the user in Chrome options. Other users will not be affected.
     
  5. blatopilot macrumors regular

    Joined:
    Sep 24, 2011
    #5
    Delete Chrome and reinstall it. Best way to start. your data is safe if it is synced with Chrome.
     
  6. piatti thread starter macrumors 6502a

    piatti

    Joined:
    Jun 9, 2010
    Location:
    USA
    #6
    How do you make it sync with Chrome?
     
  7. blatopilot macrumors regular

    Joined:
    Sep 24, 2011
  8. piatti thread starter macrumors 6502a

    piatti

    Joined:
    Jun 9, 2010
    Location:
    USA
  9. piatti, Mar 19, 2012
    Last edited: Mar 19, 2012

    piatti thread starter macrumors 6502a

    piatti

    Joined:
    Jun 9, 2010
    Location:
    USA
    #9
    I can't select "sign into chrome' because there is no such option.
     
  10. Maverick513 macrumors member

    Joined:
    Dec 13, 2011
    #10
  11. piatti thread starter macrumors 6502a

    piatti

    Joined:
    Jun 9, 2010
    Location:
    USA
    #11
    You mean sign out of my Gmail account? I signed out of my Gmail and the sign into chrome option doesn't appear in the wench icon.

    So this is the problem:

    http://support.google.com/chrome/bin/answer.py?hl=en&answer=185277

    IN this not so helpful google chrome support site, it clearly says:

    Follow these steps to sign in:
     
  12. piatti thread starter macrumors 6502a

    piatti

    Joined:
    Jun 9, 2010
    Location:
    USA
    #12
    As you can see in the attached file, there is no 'sign into chrome' option that appears.
     

    Attached Files:

  13. piatti thread starter macrumors 6502a

    piatti

    Joined:
    Jun 9, 2010
    Location:
    USA
    #13
    I finally got this to work but when I signed in it replaced all my bookmarks which I wanted to sync with all my old bookmarks that needs updating. How do I get back my old bookmarks?
     
  14. Maverick513 macrumors member

    Joined:
    Dec 13, 2011
    #14
    What is the version number of your Chrome? Try to upgrade it to the latest version.
    This is my screenshot. And you can see that "Sign in to Chrome" in it.
     

    Attached Files:

  15. piatti thread starter macrumors 6502a

    piatti

    Joined:
    Jun 9, 2010
    Location:
    USA
    #15
    It says update server not available

    .
     

    Attached Files:

  16. Bob Coxner macrumors 6502a

    Joined:
    Mar 24, 2011
    #16
    The current Chrome version is 18.0.x If you're still on 14.0 then you're FAR behind in updates.
     
  17. piatti thread starter macrumors 6502a

    piatti

    Joined:
    Jun 9, 2010
    Location:
    USA
  18. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #18
    Update Chrome manually by simply downloading the latest version from google.com/chrome.

    jW
     
  19. piatti thread starter macrumors 6502a

    piatti

    Joined:
    Jun 9, 2010
    Location:
    USA
    #19
    I did that but it's now saying that it's updated while not being really so.
     

    Attached Files:

  20. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #20
    Huh? That's weird. I would uninstall Chrome completely and try again. You can also try Chrome Canary (the beta version) which is up to version 20, that's what I use. It's been working well for a long time for me.

    jW
     
  21. Viking23 macrumors member

    Joined:
    Mar 8, 2012
    Location:
    Scotland, UK
    #21
    You could always change to a better browser, such as Firefox or Safari!
     
  22. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #22
    Better is subjective. On my computer, Chrome has run the best for 2 years now, so for me it is the better browser. Other people have other opinions, but switching browsers isn't always the right choice.

    jW
     
  23. DryEyez macrumors 6502

    Joined:
    Nov 21, 2010
    Location:
    UK
  24. crimton macrumors member

    Joined:
    Sep 20, 2011
    #24
    Did this improve the speed of chrome for you? Chrome on my imac is unbearably slow loading pages but isn't on my macbook. I have been using firefox and while it is faster loading pages there is a huge drawback. If I leave firefox open it starts using more and more ram even if no more windows are opened and nothing changes. When I first open it with one tab open it is using about 100mb or so. By the next day it is usually using close to 2 GB!
     
  25. piatti thread starter macrumors 6502a

    piatti

    Joined:
    Jun 9, 2010
    Location:
    USA
    #25
    Yes it is still slow. I updated to 18.0 finally but it's still slow. Even the canary seems slow. Maybe I have too much extensions or certain extension is slowing the browser down?
     

Share This Page