Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

MacinMan

macrumors 6502a
Original poster
Jan 27, 2011
749
350
Daytona Beach, FL
Hey all,
hope this day finds you well. I am looking for some clarification on recommended router settings when it comes to multicast / mDNS, and IGMP. Google's documentation seems to be very vague on the topic.

According to Google, they say if you're running chromecast v1 to enable multicast and IGMP. I have a chromecast gen 3, and a TV with chromecast built in. I have disabled both IGMP proxy, and IGMP snooping in my tp-link C4000 router, and things seem to work. I am just wondering if I should still enable IGMP related stuff for extra reliability. Thanks. Some sites suggest enabling IGMP snooping if AirPlay is used, but many of these sites are older, so I'm not sure what's current.

If anyone can help sort this out, I would really appreciate it. Thanks
 

hallux

macrumors 68040
Apr 25, 2012
3,362
914
I did no special configuration on my router and have never had an issue with Chromecasts working. I can also AirPlay to my new Samsung TV.
 

MacinMan

macrumors 6502a
Original poster
Jan 27, 2011
749
350
Daytona Beach, FL
I did no special configuration on my router and have never had an issue with Chromecasts working. I can also AirPlay to my new Samsung TV.
Thanks for the response. I turned off IGMP snooping and proxy, and everything is working without issues here as well.
My router is the TP-Link C4000. I think my confusion was in googles support document they say to enable mDNS, and IGMP, but they reference the 1rst gen Chromecast. the later generations aren't specified. As far as airplay some older threads i found on other sites suggest iGMP snooping to help with airplay. So since things are working. Maybe the old configuration instructions no longer apply.
 

hallux

macrumors 68040
Apr 25, 2012
3,362
914
I never had a first-gen (the stick), my first was the first "puck" style. I also have a Chromecast Audio that has always just worked, and I now have the new Chromecast with Google TV and that's also worked fine. I can also "cast" to either (or both) of my Google Home Mini speakers or to my Google Home Hub (now Nest Hub Mini?).

My current router is a Synology RT2600ac. The CC with GTV is also able to "discover" my NAS and play content from it using the VLC app. Still no special config needed.
 

MacinMan

macrumors 6502a
Original poster
Jan 27, 2011
749
350
Daytona Beach, FL
I never had a first-gen (the stick), my first was the first "puck" style. I also have a Chromecast Audio that has always just worked, and I now have the new Chromecast with Google TV and that's also worked fine. I can also "cast" to either (or both) of my Google Home Mini speakers or to my Google Home Hub (now Nest Hub Mini?).

My current router is a Synology RT2600ac. The CC with GTV is also able to "discover" my NAS and play content from it using the VLC app. Still no special config needed.
Just wanted to say thanks for the help. Everything is working nicely. Was finally able to conclude with the right settings for my setup.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.