cMP 4,1 (Early 2009 Mac Pro) (with 5,1 (2010) firmware hack) upgradable to High Sierra?

Discussion in 'macOS High Sierra (10.13)' started by applCore, Aug 14, 2017.

  1. applCore macrumors regular

    applCore

    Joined:
    May 3, 2011
    #1
    Does anyone have this configuration working with High Sierra? And if so, how did you install it successfully?

    I'm running an Early 2009 Mac Pro with upgraded processors, memory and an RX 480 video card with Sierra and when I run the beta installer it never succeeds with the installation. I proceed as the installer instructs with a shutdown. I then hold the power button until the power light flashes rapidly and upon release a loud and long sound plays to indicate firmware update. After allowing this to proceed for some minutes, the system works for another few minutes and then 10.12.6 starts right back up and I get the same Install macOS screen again as when I first started:

    [​IMG]
     
  2. nekton1 macrumors 6502

    Joined:
    Apr 15, 2010
    Location:
    Asia
    #2
    You must have an Apple efi card installed to complete the firmware update—the update will not proceed with a RX480.
     
  3. applCore thread starter macrumors regular

    applCore

    Joined:
    May 3, 2011
    #3
    Yes, you're spot on @nekton1. Thanks. I had to put my old video card back in and once I did that installation proceeded.
     
  4. seclusion macrumors regular

    seclusion

    Joined:
    Jul 15, 2007
    #4
    I have been able to update to Beta 5 and 6, I don't get the request to do the firmware update on my 5.1 Mac Pro. When I look on software updates it doesn't have anything there now.
    Is there a way to download the firmware update?
     
  5. applCore thread starter macrumors regular

    applCore

    Joined:
    May 3, 2011
    #5
    The firmware update came through the ß5 download for me (I accidentally grabbed it yesterday before it came up so I had to update to 6 afterwards). I don't know of any way to download the firmware from an ancillary site atm...
     
  6. carpsafari, Sep 3, 2017
    Last edited: Sep 3, 2017

    carpsafari Suspended

    carpsafari

    Joined:
    Sep 13, 2015
    Location:
    the Netherlands
    #6
    I'm running the Hi Sierra update from the App Store and its giving me public beta 8.:cool:
     
  7. Tizucumacu macrumors newbie

    Joined:
    Jun 21, 2010
    #7
    So it worked ? Did it boot ok after the Firmware update ?
     

Share This Page