Compressor messing with my surround sound files...

Discussion in 'Digital Audio' started by nateo200, Dec 15, 2011.

  1. nateo200 macrumors 68030

    nateo200

    Joined:
    Feb 4, 2009
    Location:
    Northern District NY
    #1
    I don't feel like typing up a long story so I'll keep it short and sweet and if you need more details don't be shy.

    I download a BluRay rip and 75% of the time its AAC 6 channel which is crap for my 5.1 surround sound decoder....so I convert it to AC-3 using Compressor....almost every time it does it flawless...but it throws all the dialog on either the left front or right front speaker instead of the front center speaker...How do I get it to stop doing this? I have a feeling its some dumb "feature" compressor automatically checks as if I convert using Handbrake I never have this issue as I'm assuming Handbrake converts the channels over without fudging them up. I want a solution to the problem with Compressor not an alternative option just to be up front...thanks in advance...
     
  2. nateo200 thread starter macrumors 68030

    nateo200

    Joined:
    Feb 4, 2009
    Location:
    Northern District NY
  3. Britvolante macrumors newbie

    Joined:
    Sep 27, 2008
    Location:
    In the sticks
    #3
    Hi, while I don't have an answer for your question I am curious as to how you get the 6 channel file to work with the BRrip? I am a complete novice at this and want to use the 6 channel file withe the movie file. One is an .m4a file while the movie is an Mp4. How to i add on to the other or can i just get them to run in syncro? Thanks
     
  4. nateo200 thread starter macrumors 68030

    nateo200

    Joined:
    Feb 4, 2009
    Location:
    Northern District NY
    #4
    Don't know if you figured it out yet but its pretty simple if you have the right software.

    1) Take the BluRay's .m4a file and convert it to .ac3 format (Dolby Digital). You can do this by using handbrake and setting the video settings size, bit rate, and resolution really really low so it doesn't take forever to encode. Start with the AppleTV preset. For settings I'll give you an idea:
    Video Resolution: 240x120, for codec choose: MPEG-4 FFmpeg, its a lower quality codec that mp4 uses in older files and for me it encodes faster with this, file size: as low as it can go, make it low but the bit rate has to be higher than 1 or you will start to cut into the audios compression settings.

    Under audio settings the AppleTV preset should have it setting already BUT make sure the first track is AAC with Mono, stereo, Dolby Surround or Dolby Pro Logic II, these are all 2 channel encoding techniques to produce pseudo non-discrete sound but the purpose of this is, is that many devices will not play AC3 discrete tracks and mp4 is really picky about this. Next under the second track choose AC3 and go down to 6 channel discrete, the bit rate should be similar to what the AAC bit rate was. There is an app called "media info" which is great for finding out what a media file contains and the specs on the items in it like bit rate. Now run the encode. Should take less than an hour, I've had it take only 20 minutes before.

    2) Next download Subler: http://code.google.com/p/subler/ . This neat piece of software can mux together H.264 video (codec used for most videos on the web and BluRays primary codec) and AAC/AC3 sound into an Mp4 container (if your video contains an AC3 track use .m4v, you just have to change the extension nothing major).

    3) With Subler installed you open your video that you want to have AC3 tracks in it so you can [presuably] pass it to a compatible surround sound system. When you open it, it will show the video file and the 6 channel AAC audio file, don't modify any of those just yet and make sure it says "pass thru".

    4) There will be a plus on the left upper side of the application, click on it. You'll get an option to add another video and/or audio file. Select the crappy encode of the BluRay rip and add it in. Now you should see 4 or 5 files. Delete the 6 channel AAC file(s) and add in the 6 channel AC3 that you "borrowed" from the low quality crappy encode from handbrake, now add the 2 channel AAC/.m4a file from the crappy encode, make sure pass thru is selected on all files. Delete the low quality video file, careful though; allot of the time the video files will look the same because there is no preview, however, if you use FFMpeg the low quality crappy encode will be displayed as "MPEG-4 VISUAL", delete that one and keep the one that says "H.264".

    5) Now before we send it off to be muxed all together, you should have the following (all of which are pass thru)"

    -One video file listed as H.264
    -One audio file listed as AAC 2 channel
    -One audio file listed as AC3 6 channel

    Make sure you have all those items, in that order...2 channel AAC should be 2nd and the AC3 track should be last for the sake of compatibility...I have encodes with AC3 first and have had no problems with some apps but on others I do. iTunes can be unpredictably picky :/. On the right hand upper corner there is an arrow. Click it, this sends it off to be encoded. Everything will disappear now, go to "Window" and click "Show Queue" you will see your file, go down and click start. It will now start muxing the files together...should take no more than a half hour at the extreme...the software isn't 64 bit like other apps so it can be slow but its WAY faster then re-encoding the entire video and audio files

    6) Subler has a few bugs and I've had a wonderful time figuring how to make it work how I want so just be patient with it is all I can say...when its done, you'll see a green check in the queue..find your newly muxed mp4 and change the extension to .m4v and play the file. Be sure to test BOTH audio tracks for safety...usually one will sound louder than the other but thats nothing to worry about...

    Hope that works if you haven't already figured it out....
     
  5. dj-anon macrumors member

    dj-anon

    Joined:
    Mar 23, 2011
    #5
    The central channel moving to the left or right front channels is an indication of a stereo file that was not properly down-mixed.

    In the inspector, on the Encoder tab as a file format choose Dolby Digital Professional. On Audio Coding Mode, click on the asterisk-like button and choose 3/2.

    Or with file format H.264 for Apple Devices, as well on the encoder tab, check Include Dolby 5.1.
     
  6. Jude If macrumors newbie

    Joined:
    Feb 21, 2012
    #6
  7. CraigCyril macrumors newbie

    Joined:
    Jan 18, 2012
    #7
    How does audio file compression affect surround sound? I suspect the filtering of the sound will destroy the encoding, but will loss less WMA continue to replicate the audio tricks that enable surround sound to be encoded within two channels?
     

Share This Page