Congratulations Amazon User!

Discussion in 'Site and Forum Feedback' started by M.PaulCezanne, Jan 11, 2018.

  1. I7guy macrumors P6

    I7guy

    Joined:
    Nov 30, 2013
    Location:
    Gotta be in it to win it
    #51
    This just started, again, twice in a few minutes. I’m guessing ads are being hijacked as they are loaded.
     
  2. AMTYVLE macrumors 6502

    AMTYVLE

    Joined:
    Sep 23, 2014
    Location:
    Treasure Coast, Florida
    #52
    Yup...been seeing them again in iOS 12.1
     
  3. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #53
    Forums or articles? I've been clicking around and haven't run into it yet.
     
  4. I7guy, Dec 3, 2018
    Last edited: Dec 3, 2018

    I7guy macrumors P6

    I7guy

    Joined:
    Nov 30, 2013
    Location:
    Gotta be in it to win it
    #54
    Reading the forums on ios 12.1.1. Let's say for example I click on the date and time on the "simply too much" thread. The thread loads and then a second or two later the "congratulations amazon" advert takes over the entire page. I press the back button to go back to the forum posts. If lucky won't get another one, however sometimes another advert pops up.

    I also use chrome under Win7. Interesting this page hijacking doesn't occur under chrome.
    --- Post Merged, Dec 3, 2018 ---
    0A2510BF-AD19-4DF7-BA2B-DA8B9C3678FC.jpeg
    Example attached.
     
  5. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #55
    There are generally 2-3 ads per forum thread page, so I'm trying to pin down the problem, but so far still no luck getting it to happen to me. Still working on it.
     
  6. I7guy macrumors P6

    I7guy

    Joined:
    Nov 30, 2013
    Location:
    Gotta be in it to win it
    #56
    PMed the link that came up with some pii removed.
     
  7. The1Biz macrumors newbie

    Joined:
    Dec 7, 2018
    #57
    I think I found the problem is JavaScript is enabled. It sucks because a lot of sites need it to work.

    I used to get iOS Safari hijackings like this with a local news app and complained to one of the writers, and had no luck. I did some research and found disabling JavaScript fixes it. There are a few consistent websites that give me this type of ad redirect as I scroll through.

    If it gets aggressive I’ll go to Safari->Advanced->JavaScript and shut it down so I can read without the hassle. I turn it back on for other sites. It is a hassle but I haven’t found of any other way to stop these attacks.

    Hope this helps.
    --- Post Merged, Dec 7, 2018 ---
    Sorry for the double post, but as I reread earlier someone mentioned the same thing about Javascript. I’ll vouch for it stopping the ad problem on iOS.
     
  8. BrettApple macrumors 65816

    BrettApple

    Joined:
    Apr 3, 2010
    Location:
    Heart of the midwest
    #58
    Glad to find this thread as I just had an occurrence if this. I usually use Safari with an adblocker but I just so happened to be using Chrome at the time.

    Went directly to the ad from the previous MacRumors page. No action was taken other then scrolling down the page at the time, that I am aware of. And it did it a 2nd time right after attempting to log in. Very odd.
     

    Attached Files:

  9. millerj123 macrumors 65816

    Joined:
    Mar 6, 2008
    #59
    I’ve had this 5 times today, the last was trying to post this..,
     
  10. I7guy macrumors P6

    I7guy

    Joined:
    Nov 30, 2013
    Location:
    Gotta be in it to win it
    #60
    Today these ad hijackings are absurdly frequent.
     
  11. Michael Goff macrumors G5

    Michael Goff

    Joined:
    Jul 5, 2012
    #61
    The only fix is the JavaScript thing, but that isn’t a fix.
     
  12. Relentless Power macrumors Penryn

    Relentless Power

    Joined:
    Jul 12, 2016
    #62
    I’m just echoing others experiences, but the ‘Pop-Up’ ads are rampant like I have never experienced on this site. It’s usually just a thread or two for a random ad, however; Almost every single thread I have viewed today, was averted to a spam ad. It’s rather discouraging.
     
  13. walex19 macrumors regular

    walex19

    Joined:
    Jun 28, 2010
    Location:
    Atlanta,GA
    #63
    Man it’s been killing me today! What’s going on???
     
  14. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #64
    I still can't replicate it for some reason. Our ad folks are looking into it.

    Sorry for the inconvenience...these things are really annoying and frustratingly difficult to track down.
     
  15. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
  16. Relentless Power macrumors Penryn

    Relentless Power

    Joined:
    Jul 12, 2016
    #67
    Tuesday was still problematic, after perusing the forums on Wednesday, I didn’t come across any ads.
     
  17. Relentless Power macrumors Penryn

    Relentless Power

    Joined:
    Jul 12, 2016
    #68
    I retract my post from above. The same ‘Amazon’ ads are *literately* ‘Popping’ in every thread I visited.
     
  18. hofnar macrumors regular

    hofnar

    Joined:
    Feb 12, 2006
    Location:
    Brooklyn, NY
    #69
    I've never seen it on Mac Rumors before but gaming Wiki's I look at it, it happens. I always wondered how to stop it.
     
  19. I7guy macrumors P6

    I7guy

    Joined:
    Nov 30, 2013
    Location:
    Gotta be in it to win it
    #70
    I haven't seen it in a while. Approximately since my last post on this subject.
     
  20. rjedoaks macrumors member

    rjedoaks

    Joined:
    Sep 16, 2007
    Location:
    Los Angeles
  21. Beachguy macrumors 6502a

    Beachguy

    Joined:
    Nov 23, 2011
    #72
    I get those often on a number of sites, and sites I know are legit, when using Safari on my iPad, or when viewing a linked page from Facebook. I have a lot of blocking on my MBP plus I am using Brave or Opera, not Safari. I don't know where it comes from but it is very irritating.
     
  22. AppleHeadPhx macrumors newbie

    Joined:
    Mar 7, 2018
    #73
    I’m getting these pop ups but only on AVSForum.com. I’m only getting them on my iPad, nothing on my iPhone. It’s getting to the point where I can’t even go to the site anymore.
     

    Attached Files:

Share This Page