Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Contacts not showing in contact list, but contact name appears when number typed in to make a call

iloveflakes

macrumors newbie
Original poster
Aug 7, 2010
3
1
Dubai, UAE
I'm sure this has been asked many times before, but due to the nature of the problem, it's quite difficult to word the issue and therefore find an existing thread on the matter...

Basically, on my boss's iPhone 7, when he goes to make a call, he has always gone to his Contact list and either scrolls to find the contact, or types the beginning of their name into the search bar at the top of the Contact list.

However recently when he does this with numbers he has had for years and/or has recently added, and is adamant he has not deleted or edited these contacts since adding them in any way, no results appear.

So he has to ask me for the number, and as I recite it to him and he inputs the entire number in manually via his iPhone keypad, the Contact name appears in small font just under the number. So it is saved, right? But where? And why can't we find it in the Contact list?

I went to Settings, Contacts, and made sure that in the "My Info" field his iCloud account (which is his full name in caps) is there, and it is. But strangely, even when I log onto his iCloud on my desktop and look through the Contact list, certain Contacts are still not there, but then again DO appear if he types the number in manually via the phone keypad.
 
  • Like
Reactions: spoon72

Planky

macrumors regular
May 24, 2009
145
23
The Sunny Isle of Wight
I believe that iOS will automatically find contacts in email, recently called etc. when typing in a phone number.

I think it even gives you the option of creating a new contact or adding a new one.
 
  • Like
Reactions: Kingofclouds
Comment

mk313

macrumors 65816
Feb 6, 2012
1,217
514
Planks brings up a good point. If you go Not the recent calls to one of those numbers, if you see the option o create a new contact, you'll know that he number isn't stored in the contacts app.
Currently.
 
Comment

iloveflakes

macrumors newbie
Original poster
Aug 7, 2010
3
1
Dubai, UAE
I believe that iOS will automatically find contacts in email, recently called etc. when typing in a phone number.

I think it even gives you the option of creating a new contact or adding a new one.

Yes this happens on my iPhone a lot which I think is a cool feature, however he doesn't have his emails on his phone, so it doesn't sound as if that's what's doing it.

Could it be something to do with the fact that he has 3 x iPhone back-ups synced to his 1 x iCloud account?

If the "Contacts" toggle is switched On in the iCloud sync settings of each iPhone, does this mean that whenever one of theses 3 x iPhones does an automatic iCloud back-up, they will all share the exact same contact list (and notes, and reminders, and Safari, Calendars etc)?

On his current iPhone 7 he has 3,915 contacts...however I've just dug out his UK iPhone (to do a software update) and noticed that this has 4,144 contacts.

If I back up this UK iPhone to iCloud right now, will that mean his iPhone 7 will then sync to 4,144 contacts too?
 
Comment

gp101

macrumors member
Sep 11, 2014
46
49
Middle Earth
Has he tried turning off, waiting for a bit, and back on Spotlight search for contacts (General -> Spotlight Search (Search results))? I had a colleague once who had a similar problem but that fixed it so hope that helps :)
 
Comment

iloveflakes

macrumors newbie
Original poster
Aug 7, 2010
3
1
Dubai, UAE
^^ No but I'll give that a go.

A couple of month ago I did a soft re-set oh his phone and he never mentioned it again, so I guess that worked.

However now he's piped up about it again! So will just do another sodt re-set to set it that temporarily fixes it again.

Does anyone have any feedback on my other query, though?

If someone has say 4 x iPhones, all logged into the same iCloud, and the "Contacts" toggle is switched On in the iCloud sync settings of each iPhone, does this mean that whenever one of theses 4 x iPhones does an automatic iCloud back-up, they will all share the exact same contact list (and notes, and reminders, and Safari, Calendars etc)?

On his current iPhone 7 he has 3,915 contacts...however I've just dug out his UK iPhone (to do a software update) and noticed that this has 4,144 contacts.

If I back up this UK iPhone to iCloud right now, will that mean his current iPhone 7 will then sync to 4,144 contacts too?
 
Comment

sumaru

macrumors newbie
Nov 7, 2017
4
0
I have this problem too and so does a friend. I can enter a new contact into the Contacts app on my phone, but it doesn't appear in the contacts list or via a search. Yet, if I actually call that contact by keying in the phone number, their name appears.

A lot of my contacts I've had for years have also disappeared from the contacts list and search, but again, if they call me, their name pops up, so they're obviously in there somewhere...

It is REALLY inconvenient and I've searched all over for a fix for it. Any suggestions?



I'm sure this has been asked many times before, but due to the nature of the problem, it's quite difficult to word the issue and therefore find an existing thread on the matter...

Basically, on my boss's iPhone 7, when he goes to make a call, he has always gone to his Contact list and either scrolls to find the contact, or types the beginning of their name into the search bar at the top of the Contact list.

However recently when he does this with numbers he has had for years and/or has recently added, and is adamant he has not deleted or edited these contacts since adding them in any way, no results appear.

So he has to ask me for the number, and as I recite it to him and he inputs the entire number in manually via his iPhone keypad, the Contact name appears in small font just under the number. So it is saved, right? But where? And why can't we find it in the Contact list?

I went to Settings, Contacts, and made sure that in the "My Info" field his iCloud account (which is his full name in caps) is there, and it is. But strangely, even when I log onto his iCloud on my desktop and look through the Contact list, certain Contacts are still not there, but then again DO appear if he types the number in manually via the phone keypad.
 
Comment

123shopper

macrumors newbie
Mar 1, 2018
3
0
I'm sure this has been asked many times before, but due to the nature of the problem, it's quite difficult to word the issue and therefore find an existing thread on the matter...

Basically, on my boss's iPhone 7, when he goes to make a call, he has always gone to his Contact list and either scrolls to find the contact, or types the beginning of their name into the search bar at the top of the Contact list.

However recently when he does this with numbers he has had for years and/or has recently added, and is adamant he has not deleted or edited these contacts since adding them in any way, no results appear.

So he has to ask me for the number, and as I recite it to him and he inputs the entire number in manually via his iPhone keypad, the Contact name appears in small font just under the number. So it is saved, right? But where? And why can't we find it in the Contact list?

I went to Settings, Contacts, and made sure that in the "My Info" field his iCloud account (which is his full name in caps) is there, and it is. But strangely, even when I log onto his iCloud on my desktop and look through the Contact list, certain Contacts are still not there, but then again DO appear if he types the number in manually via the phone keypad.
[doublepost=1519904460][/doublepost]The solution is quiet easy folks!
Go to contacts- In the left top corner there is an option 'Groups' click on it- Then select gmail,icloud and and all the available option you like to sync.
By mistake you must have deselected the icloud option.
Do this and you are good to GO!
 
Comment

spoon72

macrumors regular
Jul 3, 2011
189
18
singapore
I have this problem too and so does a friend. I can enter a new contact into the Contacts app on my phone, but it doesn't appear in the contacts list or via a search. Yet, if I actually call that contact by keying in the phone number, their name appears.

A lot of my contacts I've had for years have also disappeared from the contacts list and search, but again, if they call me, their name pops up, so they're obviously in there somewhere...

It is REALLY inconvenient and I've searched all over for a fix for it. Any suggestions?

I have this problem since iPhone 6s currently using 8 with same issue because maybe I restore from the 6s I’m also looking for solution .
 
Comment

spoon72

macrumors regular
Jul 3, 2011
189
18
singapore
[doublepost=1519904460][/doublepost]The solution is quiet easy folks!
Go to contacts- In the left top corner there is an option 'Groups' click on it- Then select gmail,icloud and and all the available option you like to sync.
By mistake you must have deselected the icloud option.
Do this and you are good to GO!

Omg thanks !!
 
Comment

sumaru

macrumors newbie
Nov 7, 2017
4
0
[doublepost=1519904460][/doublepost]The solution is quiet easy folks!
Go to contacts- In the left top corner there is an option 'Groups' click on it- Then select gmail,icloud and and all the available option you like to sync.
By mistake you must have deselected the icloud option.
Do this and you are good to GO!
[doublepost=1519951239][/doublepost]Thanks that worked!
I can see how this could happen because the iCloud option (which appears as 'All Mac Accounts' on my phone) automatically selects all groups, and if you deselect one, it deselects 'All Mac Accounts' as well, so it would be easy to think that you were just choosing NOT to sync the groups you deselected, when you've actually chosen ONLY to sync the groups you actually selected.
I will let my friend who had the same problem know about this fix.
 
Comment

123shopper

macrumors newbie
Mar 1, 2018
3
0
[doublepost=1519951239][/doublepost]Thanks that worked!
I can see how this could happen because the iCloud option (which appears as 'All Mac Accounts' on my phone) automatically selects all groups, and if you deselect one, it deselects 'All Mac Accounts' as well, so it would be easy to think that you were just choosing NOT to sync the groups you deselected, when you've actually chosen ONLY to sync the groups you actually selected.
I will let my friend who had the same problem know about this fix.
Glad it worked. I myself had the problem and came to this thread looking for solution.None helped.So I did self troubleshooting and wondered, how easy this is. Thought it could help and created an account and posted the fix.This is my first ever online post and it seems, I should do it often if i have few solutions, rather than just looking and going away!
[doublepost=1520005945][/doublepost]
Omg thanks !!
Good luck finding the ALL the contacts ^_^
 
Comment

sumaru

macrumors newbie
Nov 7, 2017
4
0
Glad it worked. I myself had the problem and came to this thread looking for solution.None helped.So I did self troubleshooting and wondered, how easy this is. Thought it could help and created an account and posted the fix.This is my first ever online post and it seems, I should do it often if i have few solutions, rather than just looking and going away!
[doublepost=1520005945][/doublepost]
Good luck finding the ALL the contacts ^_^

Glad you shared your solution - I've been trying to work this out for almost a year!
 
Comment

MKDON

macrumors newbie
Aug 18, 2018
2
0
[doublepost=1519904460][/doublepost]The solution is quiet easy folks!
Go to contacts- In the left top corner there is an option 'Groups' click on it- Then select gmail,icloud and and all the available option you like to sync.
By mistake you must have deselected the icloud option.
Do this and you are good to GO!

Sorry to bump an old post, but I have the same issue and had tried to follow the steps to correct the issue. Unfortunately, I there appears to be no 'Groups' option in the left top corner within contacts? Can someone please clarify?
 
Comment

123shopper

macrumors newbie
Mar 1, 2018
3
0
Sorry to bump an old post, but I have the same issue and had tried to follow the steps to correct the issue. Unfortunately, I there appears to be no 'Groups' option in the left top corner within contacts? Can someone please clarify?
[doublepost=1534658275][/doublepost]Hmm, that's the only fix I found. Yeah, you have to go to general contacts page. And you'll find the icon or groups to the corner.
 
Comment

MKDON

macrumors newbie
Aug 18, 2018
2
0
[doublepost=1534658275][/doublepost]Hmm, that's the only fix I found. Yeah, you have to go to general contacts page. And you'll find the icon or groups to the corner.

Still can not find the groups icon in the corner, screenshot attached:
 

Attachments

  • 45860460-41E3-4C97-BCB1-954359A20B10.jpeg
    45860460-41E3-4C97-BCB1-954359A20B10.jpeg
    239.4 KB · Views: 261
Comment

mk313

macrumors 65816
Feb 6, 2012
1,217
514
Still can not find the groups icon in the corner, screenshot attached:

It looks like you are in the contacts subsection of the phone app, not the contacts app. In the app titled contacts, groups is in the upper left corner of the main screen
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.