Couch Surfer Flash Problem

Discussion in 'Apple TV and Home Theater' started by solidgoldmini, Mar 25, 2008.

  1. solidgoldmini macrumors regular

    Sep 14, 2004
    In a house. On a street. In a city.
    I'm trying to get Flash working on my Take 2 Apple TV Couch Surfer install. Couch Surfer itself is working great, but when I try to load a page with Flash, I see the little blue 'plug-in missing' cubes and it crashes.

    I've followed the instructions regarding copying plug-ins and the 10.4 CoreAudioKit.framework. I think I have the plug-ins necessary, but I think the CoreAudioKit may be the problem. I got them from an iBook with 10.4.11, but because I'm still having problems, I'm thinking/hoping that it has to come from an Intel Mac.

    I don't know about the legality of doing so, but if anyone could somehow send me the CoreAudioKit.framework folder from an Intel Mac installation (preferably 10.4.10 or .11, as that's what the AwkwardTV Wiki specifies) so I can get Flash working, I would greatly appreciate it. Like I said, I don't know if it's a no-no to do so, but if so, can anyone out there tell me how they got Flash working on their CouchSurfer Apple TV install?

    Thank you!
  2. mr_matalino macrumors 6502a


    Oct 14, 2005
    Did you follow the instructions from or another site?
  3. solidgoldmini thread starter macrumors regular

    Sep 14, 2004
    In a house. On a street. In a city.
    I followed the instructions from the awkwardTV wiki at

    I installed CouchSurfer just fine, and it browses, uses bookmarks and all that OK.

    I copied the plug-ins from a Leopard Mac Pro to the /Library/Internet Plug-ins on the AppleTV. And then I found a CoreAudioKit.framework on my old iBook which was running 10.4.11 and put that in the /System/Library/Frameworks folder. Now when I go to a site it doesn't say you need to get flash, I just get the little blue box with the question mark, and it will freeze up and eventually reboot, if I don't ssh in and reboot it myself. I see people saying they have the problem, and then their next post is "I got it working" but how? Do you know if the PPC CoreAudioKit.framework is the problem? I appreciate any help you can provide-I have a bunch of Macs floating around, but only the one Mac Pro which I can't install 10.4.10 on! Frustrating!
  4. solidgoldmini thread starter macrumors regular

    Sep 14, 2004
    In a house. On a street. In a city.
    Like so many others, I figured it out, and it was the Frameworks.

    It doesn't say so specifically anywhere I can find, but if you happen to be having the same problem, you have to make sure the CoreAudioKit.framework folder comes from an Intel install of 10.4. I used the folder from an Intel Mac Mini on 10.4.11 and Flash finally works! I can watch all the South Park episodes on my AppleTV now! :D
  5. mdburke macrumors member

    Apr 17, 2008
    I am experiencing the same problem as you were.

    I pulled my frameworks from my first gen macbook osx dvd.

    Could this be the problem?
  6. mdburke macrumors member

    Apr 17, 2008
    I continued the trend and figured it out on my own.

    I was copying over CoreAudio.Framework instead of CoreAudioKit.Framework.

    All is well now.
  7. modhran macrumors newbie

    Jun 11, 2008
    PowerPC issue

    Hi there,

    I have a PowerPC mac. Is there somewhere I can get an Intel CoreAudioKit.framework folder?

    I'd love to get flash working to watch Leo Laporte Live.
  8. Cordeiro macrumors member

    Feb 12, 2008
    Same problem here :-(
    iMac Power PC..Any kind soul can help me where to find the miraculous CoreAudioKit?
  9. ayale99 macrumors 6502

    Dec 6, 2007
    The problem seems to lie with what version of the CoreAudio.Framework you have. I got my framework from a Macbook 10.4.11 and I still can't get it to work. I've given up until I can find an alternate Framework to try. If anybody would share a copy that is confirmed to work, I would be eternally grateful.
  10. Cordeiro macrumors member

    Feb 12, 2008
    Well according messagens above it seems that must be from an Intel install.
    Was that your case and still didn't work?
  11. ayale99 macrumors 6502

    Dec 6, 2007
    Yes, it was an Intel install. I followed the instructions to a T. I checked and rechecked everything.

    BTW, I haven't tried re-installing atvFlash since the 2.01 update. Has anybody had success?
  12. severe macrumors 6502a

    May 23, 2007
    Hey guys..

    I have the file, however I wasn't able to place it into its proper location via SSH. An error message kept popping up ...something about not having permission. I had researched and found others having this issue as well. I think it can be remedied installing via the command line.

    This was a few weeks back. I had given up. I'll trade the files needed for step-by-step instructions on how to get around this issue. :)
  13. Cordeiro macrumors member

    Feb 12, 2008
    OK..Give it a try. If it solved the problem then you can send me the files :)

    Attached Files:

  14. severe macrumors 6502a

    May 23, 2007
    Thanks, but doesn't help. Here's the deal. The file is on my desktop. I try to drop it in /System/Library/Frameworks via SSH and I get The user does not have sufficient permissions to perform the operation.

    How could I get the file from my desktop to the AppleTV via the command line?
  15. mdburke macrumors member

    Apr 17, 2008
    scp -1 -r ~/Desktop/CoreAudioKit.framework frontrow@AppleTV.local:~
    ssh -1 frontrow@AppleTV.local
    sudo mount -uw /
    sudo mv ~/CoreAudioKit.framework /System/Library/Frameworks
  16. severe macrumors 6502a

    May 23, 2007
    You, my friend, are the man.

    Thanks a lot!
  17. Cordeiro macrumors member

    Feb 12, 2008

    OK I got the files and copied them as above..and still don't works..:-(
    Now I'm pretty sure that the folder with all is files is located in the right place.
    Using ssh I see the folder under /System/Library/Frameworks as it should be.

    So I suppose I had eliminated the incorrect placement or file structure of the files.

    But yet still don't works :-(

    Two Things:
    1st - My apple TV is on 2.1 version(patched). Are yours in the same status?.
    2nd - I opened other folders in folder Frameworks ( for instance folder CoreAudio) and I noticed that the exec files such as CoreAudio and Resources are presented with an arrow behind the file name ( and using "get info" I obtained that they kind are "symbolic link").
    When I do the same in Folder CoreAudioKit those files don't present the arrow behind the name and get info gives me that their kind are "files".
    It seems that by any strange reason those files are not exec. files as they should be after I copied them.
    Could be the reason?

  18. mdburke macrumors member

    Apr 17, 2008
  19. severe macrumors 6502a

    May 23, 2007
    The files with the arrows are aliases. They refer to the files that are deeper in the folders their contained in. If you look in the other folders you'll see the actual files. For whatever reason, this is how the files are to be structured.

    Try mdburke's suggestion.
  20. mrgreen4242 macrumors 601


    Feb 10, 2004
    Bumping this old thread because I need a copy of the CoreAudioKit Framework for my ATV, and was hoping someone could help me out???

  21. guywoodman7 macrumors member

    Jan 28, 2008
    New York
    Trying to get Flash working in the new Couch Surfer. I have the appropriate files but am unable to move the CoreAudioKit.framework file over becuase of insufficient privelages.

    I'm pretty sure I need to move it over via terminal (instead of transmit or cyberduck) but I used these commands and failed. I keep getting a message that says "Protocol major versions differ: 1 vs. 2"

    Am I supposed to substitute the "~" symbol with my username? Is it something else I'm missing. I'm not very good with terminal.

    ANY help would be GREATLY appreciated, I'm SOOOOOOOOO close to getting flash working.
  22. jmir macrumors newbie

    Jun 3, 2008
    Not sure how many people know this but I found this great software called FUGU, its like ftp and allows you to copy and move files without any ssh

    Let me know if this helps

    Can anyone help me with the right kit to get flash running on appletv
  23. micahakaslick macrumors newbie

    Feb 9, 2009
    missing file

    me too! would someone be an absolute legend and help me :)
  24. Mak909090 macrumors newbie

    Feb 18, 2009
    here it is!

    Here is the CoreAudioKit.framework that will work to make flash work, on the apple tv.

    Use the command line, to move the file form your desktop folder (on the apple tv) to the frameworks folder. here is where I got messed up, after running the command lines the folder would not be in the desktop folder any more, but it did not show up in the frameworks folder!!! So i did the command lines 5 or 6 times, What i did not know was that the file, is hidden if you put in the the frameworks folder(LOL). So now i have 5 or 6 copys of the files in the frameworks folder. So run the command lines and go look at the apple tv browser. do not look for it in cyber duck or other SSH,FTP soft ware.

    HiVolt is the guy that posted the file on

Share This Page