Could someone clarify this for me please

Discussion in 'Jailbreaks and iOS Hacks' started by sk8mash, Mar 15, 2009.

  1. sk8mash macrumors 6502a

    sk8mash

    Joined:
    Dec 1, 2007
    Location:
    England
    #1
    If I walk into O2, buy a Pay&Go iPhone 3G, will I be able to unlock it to any sim on its supplied base band with firmware 2.2.1? I have looked on the dev team site, and it is a bit confusing. A simple yes no answer will be fine, or if you have a little more time, tell me if its yell0wsnow, or pwnage I need to use to unlock it.

    I used to keep up with iPhone unlocking, but lost track of it a while ago!

    Thank you for your time.
     
  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #2
    Click Me and you will get help with actually doing jailbreaking/unlocking of it.

    As far as what baseband or firmware it has, its very random. You may be lucky enough to get the 2.2.0 firmware and if this is the case you will be able to unlock. However, if you get an iPhone 3G with 2.2.1 you will not be able to unlock.
     
  3. MistaBungle macrumors 6502a

    MistaBungle

    Joined:
    Apr 3, 2005
    #3
    A brand new iPhone carries the new baseband which is currently not working with the yellowsnow.

    Of course, if you buy an older brand new phone, luck could prevail.
     
  4. sk8mash thread starter macrumors 6502a

    sk8mash

    Joined:
    Dec 1, 2007
    Location:
    England
    #4
    Oh OK, so there is no way to downgrade the baseband? The people here at macrumors are defiantly the most helpful on the internet!
     
  5. sk8mash thread starter macrumors 6502a

    sk8mash

    Joined:
    Dec 1, 2007
    Location:
    England
    #5
    After reading that link, it seems that 2.28.00 is the only baseband that can be unlocked, which was the baseband with 2.2 software update. So if I bought a 2.2.1 iPhone it wouldn't be unlockable. Am I right in thinking you could prevent the baseband from upgrading using pwnage when upgrading from 2.2 to 2.2.1?

    Thanks again.
     
  6. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #6
    Yes, spot on.
     
  7. fabian9 macrumors 65816

    fabian9

    Joined:
    Nov 28, 2007
    Location:
    Bristol, UK
    #7
    Thats right, you can upgrade to 2.2.1 using a custom firmware made in Pwnage tool. Just did this on Friday, took me a few attempts as iTunes kept giving me errors, but got it to work in the end.

    By the way, I was under the impression that the pay as you go o2 iphone is factory-unlocked?! That's why you pay the full price for it isn't it?!

    Fabian
     
  8. koollectablz macrumors 6502

    Joined:
    Feb 1, 2009
  9. TexanMan05 macrumors regular

    TexanMan05

    Joined:
    Jan 23, 2008
    #9
    Not if you unlock it :rolleyes:
     
  10. sk8mash thread starter macrumors 6502a

    sk8mash

    Joined:
    Dec 1, 2007
    Location:
    England
    #10
    So if I made a custom 2.2.1 firmware with the 2.28.00 base band and loaded it onto a 2.2.1 iPhone 3G bought from O2, I would be able to unlock it using yellowsnow? I take it thats what you did?

    Thanks again.
     
  11. MistaBungle macrumors 6502a

    MistaBungle

    Joined:
    Apr 3, 2005
    #11
    If you are buying a retail 2.2.1, it will have the latest (and unlockable) baseband.

    So that means you cannot make a custom firmware with the baseband of your choice because you would then be downgrading, and currently that is not available.
     
  12. fabian9 macrumors 65816

    fabian9

    Joined:
    Nov 28, 2007
    Location:
    Bristol, UK
    #12
    you mean un-unlockable? ;)
     
  13. fabian9 macrumors 65816

    fabian9

    Joined:
    Nov 28, 2007
    Location:
    Bristol, UK
    #13
    no, that's not right. if you got an iPhone which still has 2.2 on it and you made a custom 2.2.1 firmware which has 2.28.00 baseband, then you could use yellowsn0w.

    the baseband can't be downgraded so unless you can get your hands on a new phone still running 2.2 you're out of luck.
     
  14. sk8mash thread starter macrumors 6502a

    sk8mash

    Joined:
    Dec 1, 2007
    Location:
    England
  15. MistaBungle macrumors 6502a

    MistaBungle

    Joined:
    Apr 3, 2005
    #15
    Forgot to negate the negative, good eyes!
     

Share This Page