CS4 Scanning Fix! - TWAIN Scanner's Don't show Up!

Discussion in 'Design and Graphics' started by agentphish, Nov 17, 2008.

  1. agentphish macrumors 65816


    Sep 7, 2004
    Ok, so I have a CanoScan LiDE80 and LiDE100.

    When I got CS4, and installed it, neither of those would show up under the File>Import menu. Normally they'd be there, you'd click them, and it launches the scangear app within photoshop.

    Basically they were MIA.
    I found a folder on the installation DVD called "Goodies"
    In there is a folder called Optional "Plug-Ins"
    In there is a folder called "Import-Export"

    What is the ONE file in that folder??? TWAIN.plugin

    Put that into Adobe Photoshop CS4/Plug-ins/Import-Export and you are golden. This should work for any TWAIN-based scanner. I can NOT believe Adobe didn't include this in the basic install of Photoshop, as it's been there at least since CS, probably since before that, and MOST scanners are still using TWAIN.

    I hope this helps someone!
  2. Roy Hobbs macrumors 68000

    Roy Hobbs

    Apr 29, 2005
  3. jerryrock macrumors 6502


    Sep 11, 2007
    Amsterdam, NY
    Adobe recommends NOT using the Twain Plug-in with Photoshop CS4 running on an intel based Mac.

    "When you use TWAIN to import from an imaging device, such as a scanner, you may encounter problems similar to the following:
    Photoshop or your scanner application freezes or quits unexpectedly.
    You are unable to close the scanner window.
    You encounter errors during import.
    The preview of the imported image, or the imported image itself, appears incorrect on screen. "

  4. Roy Hobbs macrumors 68000

    Roy Hobbs

    Apr 29, 2005
    Works just fine for me, I scanned over 100 images today
  5. aross99 macrumors 68000


    Dec 17, 2006
    East Lansing, MI
    What do they recommend that you use then? Is there some new scanner driver technology on the Mac that has replaced TWAIN? I know Windows has something different, but I thought the Mac drivers were all still TWAIN.
  6. joolk macrumors newbie

    Nov 19, 2008

    Thank you! Due to your instruction I now can scan!

  7. jerryrock macrumors 6502


    Sep 11, 2007
    Amsterdam, NY
    Twain is now "use at your own risk" in Photoshop.

    "The TWAIN plug-in for Macintosh has been removed. If you would like to have TWAIN support on your Macintosh system, we strongly recommend that you access your device through Rosetta (PPC) OS. Otherwise, we suggest that you scan your image in first and then separately open the image in Photoshop.

    The plug-in can be found on your install DVD under:
    //<language>/Goodies/Optional plug-Ins/Import-Export/TWAIN plug-in or online at http://www.adobe.com/support/downloads/product.jsp?product=39&platform=Macintosh .
    Drop this plug-in into the //Adobe Photoshop CS4/Plug-ins/Import-Export folder.

    NOTE (Windows-only): the TWAIN plug-in is installed for Windows users. However, we strongly suggest you use WIA support for your device if available. If your device does not support WIA drivers, then we recommend you try updating your TWAIN driver. Photoshop will not support TWAIN for any 64-bit operating systems. Please contact the manufacturer of your device for further TWAIN support direction."

  8. oreocracker macrumors newbie


    Feb 20, 2007
    Scanner Fixes

    I got so tired of using the plug ins and having issues, I finally got VueScan. It's easier to use and I get support. Not advertising, just a fact. Works great.
  9. Kid Red macrumors 65816

    Dec 14, 2001
    I downloaded the plugin put it as outlined above but CS4 still does not show it as an option.
  10. covisio macrumors 6502


    Aug 22, 2007
    I echo that.
    VueScan is as easy to use as any plug-in for Photoshop. As soon as the scan is executed, it can be set to open the image directly in PS. The Pro version is as sophisticated as you would ever need can be easily calibrated.
  11. cusp2011 macrumors newbie


    Dec 5, 2008
    Try Acrabat Pro

    Adobe Acrobat Pro is bundled with many CS4 suites. There is full scanning capability and plenty of export options available in the program...as well as that cool Distribute Forms feature!

    Go to File>Create PDF> From Scanner
    and then Export it as you choose
  12. dMullins macrumors newbie

    Dec 15, 2008
    A Possible Fix For CS4's TWAIN Issues on OS X

    Hey all, I've been scouring the web all morning trying to get my old scanner to work again, and I think I've found a Universal solution at-last, and I think it's a lot simpler than anyone might have imagined. What I've found is that it's a simple naming error in the software/driver installers.
  13. jerryrock macrumors 6502


    Sep 11, 2007
    Amsterdam, NY
    This forum is not free advertising for your blog. If you have something constructive to add, post it here.
  14. dMullins macrumors newbie

    Dec 15, 2008
    Um, okay. I could truly care less if anyone reads my blog. I was merely trying to be helpful.

    But as you requested, here's the info:

    hew! My upgrade to CS4 has been a complete pain in the rear from the day I pulled the DVDs out of the boxes, but it hasn’t all been Adobe’s fault. First, it was all of my out-dated filters and plug-ins I have purchased over the years. Most of the time, the software providers had been slow on the uptake, and were weeks behind developing updates for their CS3 versions. This time though, it’s Canon that is to blame, and this one takes the cake.
    I have an older scanner that my mom gave me as a High School graduation present back in 2000 — a Canon CanoScan LiDE 50 bus-powered USB scanner. While I do admit that 8-years old is a long time for technology to last nowadays, but there’s a prevailing conventional wisdom in the technology community that if it isn’t broken, it should work and at least attempt to maintain a streamlined, forward-compatibility software structure. Well, before I made the move from San Francisco to Greensboro, NC, I had a couple of projects of mine that I wanted to scan, because I don’t have a nice SLR to reproduce the works digitally. Unfortunately, I could not find the USB cable for the life of me, and I didn’t feel like shelling out $50 for a USB cord for an 8-year old scanner either.
    What do I find though yesterday at long last as I’m unpacking some boxes for my new rack system in the studio room, but the USB cable! I was thinking about it all last night, how I was going to sit down today and crank out these scan jobs, and relish in the fact that I have a functioning scanner again. Of course, when I go to re-install the drivers from Canon’s site, the LiDE 50 doesn’t turn on, let alone show up anywhere; not in Photoshop CS4’s TWAIN Import, not in my system’s Image Capture utility, not in VueScan, or even the ScanGear Toolbox. Not to be discouraged that easily, I hopped on the web and did some quick research, only to find this post on MacRumors.com, which led me to this freeware download on Adobe’s site. Granted, I do I have my original CS4 install discs handy in the other room, but I was feeling extra lazy, because I was up at the break of dawn this morning to take Julie to her first day of orientation at Moses Cone.
    At this point, I’m feeling very optimistic. I’ve got my new drivers from Canon, my TWAIN plug-in for the CS4 platform, and a cup of coffee. I should be scanning in no time, right? It’s been about 45 minutes by now, so I plug in the scanner, and I’m ready to rock and roll at long last.
    Nope. Nothing. At all. No lights on the scanner, no activity in Activity Monitor, no new devices discovered in Image Capture or in TWAIN Queue. ”What the heck is going on,” I’m wondering. ”It’s 2008, this stuff should just WORK.”
    So I dug around a little deeper, and finally found what I was looking for after about another 30 minutes of pro web surfing and reading this obscure little post on MacUpdate.com by CNYMIKE.
    CNYMIKE: I’ve installed the CanoScan Toolbox 5.0 for my Intel iMac but when I go into settings, the scanner doesn’t show in the dropdown because it can’t see a driver. I have the driver but do not know where to install it so that CanoScan Toolbox 5.0 can see it. Putting it in the same folder as the CanoScan Toolbox 5.0 does nothing. Neither does putting it in /library/application support/canon/ScanGear/plugins.

    So that got me thinking — “I should check my directories and see if those folders even exist on my system.” Lo and behold, they didn’t. And at long last, I was sure I had found the solution to this convoluted problem. I quickly created the following two directories on my file system, under my main user account:
    /Library/Application Support/Canon/ScanGear/Plugins

    /Library/Application Support/Canon/ScanGear/Plug-ins

    I’m not sure which is the correct directory, honestly. I merely created them both on my drive, and re-ran the driver installation, assigning the installation to each of the folders (after fully un-installing previous installation attempts, of course). I took a sip of the last bit of my coffee, crossed my fingers, and opened up the CanoScan Toolbox software.
    Nothing, again.
    More frustrated than words could describe, I stood up and walked away from the computer, and moreover the scanner, so that nothing was broken in the fit of anger. ”Hmm…I bet I didn’t set something up right in the CanoScan Toolbox software,” I was thinking. So I walked back over, and looked at the Configuration dialogs. ”Eureka! — that’s gotta be it!.” A little empty box near the bottom of the panel says, “Link scanned image to…” but the link box was empty. I clicked the “Set” button, and navigated to where I had dumped the CS4 TWAIN plug-in inside my Photoshop CS4 directory (Applications/Adobe Photoshop CS4/Plug-ins/Import-Export/TWAIN.plugin) and hit Enter. Suddenly the “SCAN” button was actually clickable. Excitement filled my little heart.
    I hit “SCAN”, and good Lord, my scanner awoke from a four year slumber, just as if it had never hibernated a day in its life.

    Ah, it feels so good to figure that out. Archaic, convoluted, and backwards are just a few ways to describe the process I had to go through to get this to work. I can’t fault Adobe, because it is definitely not their fault. But I certainly have some words for the developers at Canon who built this installer out. Moreover, the lack of documentation is pretty disturbing. It makes me wonder what their motives are for something so atrociously messed up. Are they too tapped for time and resources to develop this out correctly? Do they just want the masses to give up, and go buy a new printer? I really don’t know, but whatever the motives, it’s been a routine in impractical programming and software engineering, and an interesting lesson in perseverance.
    The main reason that I decided to blog this though was to help anyone else out there who comes across the same problem. Hopefully this can help them the way it helped me, and possibly save them another $150-200 that they would have otherwise have spent on a brand new printer when they didn’t need it.

    Feel free to check my blog's comments -- http://blog.dylanmullins.com/ for similar solutions that other users have found to their unique computer setups.
  15. shawnmm macrumors newbie

    Mar 6, 2009
  16. dMullins macrumors newbie

    Dec 15, 2008

    I'm happy to hear this helped you out. I've gotten a lot of great feedback about this post here and on my blog. I just wanted to help others find a similar solution to their problem, as there was almost NO support anywhere online to help me figure out my own.
  17. Sewje macrumors newbie

    Mar 21, 2009
    I have a ide80 scanner this is how to get it working.

    * You need to install the Toolbox first.
    * Then install the scangear driver, this will install the driver into the correct place in the Toolbox.
    * When you hit Scan button it will open the Toolbox and ask to select a program to open the scan with, just browse thru your Applications and Photoshop directory and look for the Photoshop.bin.
    * If it worked it will give the Scan Preview window where you can do all your adjustments.
    * You can configure everything manually in the Toolbox if the above steps didn't work.

    I tried the Twain method, it doesn't work for me either.
  18. MikeMaravilha macrumors newbie

    Jun 3, 2009
    Open using Rosetta

    Just in case somebody doesn't understand this: "If you would like to have TWAIN support on your Macintosh system, we strongly recommend that you access your device through Rosetta (PPC) OS."

    Close Photoshop, find it in your applications folder and select and open 'Get Info' under File in the Finder. There is a check box for 'open using rosetta'.

    I had installed twain, which didn't (and still doesn't) show up in Photoshop under 'File -> Import'. I had put the plugin for my Canon Euroscan N1220U in the Photoshop -> Plug-Ins -> Import-Export folder, but starting Photoshop normally gave an error for the plugin. Having checked the rosetta box it is now working fine.
  19. YrbkladyCarla macrumors newbie

    Jun 8, 2009
    San Jose, CA
    TWAIN plug-in

    Hey all. Just wanted to say that this was all very helpful! Thank you! I did download the TWAIN plug-in and drop it in the Import/Export folder as recommended here and it works perfectly with my crummy Brother MFC.Hoping to upgrade that, soon, but all is working for now. Thanks again!
  20. Ginfiend macrumors newbie

    Jul 2, 2009
    Hurrah - thanks for that - you solved my 'plug-in-not-working' problem! :) I no longer feel the need to break things and shout a lot.
  21. qnofchrts macrumors newbie

    Aug 4, 2009
    Thank you - thank you - thank you

    Now my printer is showing up: an inexpensive Epson I use mostly for faxing. I still cannot get the app to recognize the CanoScan 8400F. Will keep playing.
  22. sraymond macrumors newbie

    Aug 12, 2009
    Come on Adobe!

    I've been using Adobe products for about 15 years now and never have I upgraded to something to find that I had to do something like this. I had CS2 installed and a Xerox Phaser 6115mfp. I upgraded to CS4 and lo and behold I could not scan from Photoshop anymore. I tried reinstalling the printer/scanner drivers and nothing worked until I found this post that I had to go onto the "extras" CD for CS4 and copy the twain plugin over to photoshop. As long as I can remember that scanners have been around the twain plugin has always been a part of the Photoshop install. SHAME on Adobe for not installing it automatically in CS4. What do they think, we have nothing better to do as designers but to try and figure out why our scanner was working in a previous creative suite but not now in the new creative suite we just upgraded? My time is precious and billable and I don't have time to sit and research this sort of crap when we pay enough for each upgrade which seems to happen every year with Adobe that things that were once part of the install should always be part of the install!!!!!!!!~!!!!!!!!!!!! Don't take that stuff away from us and leave us to try to figure it out!!!!
  23. wilsonlaidlaw macrumors 6502


    Oct 29, 2008
    Twain Plugin does not work for my LIDE 35

    Tried the various solutions and nothing works for my LIDE 35. Dialog box says scanner driver not installed. I will go back to using Vuescan even though it is a 2 step solution. This is going to be a PITA when I am back in the UK, as I have a whole bunch of old glass slides to scan in on my LIDE 600. Where did Adobe get the idea that Mac users would not like to be able to scan direct into CS4? I know of at least 2 professional photographers, who do much of their macro like work on scanners.

  24. MRU Suspended


    Aug 23, 2005
    Same model. Same problem. I have to scan via Preview and then load scan into photoshop. It's a pain... I hoped Snow Leopard would fix but no.

    Add that to CS4 not liking images being dragged onto the PS icon. CS4 is looking like the worst adobe upgrade in a long while...
  25. singviol macrumors newbie

    Dec 4, 2009
    Thank you thank you thank you! Could not for the life of me figure this out - and after finding your post, it took me all of 3 minutes to find the plug-in, put it where it needed to go, and voila! My scanner re-appeared. Gotta love the 'net.

Share This Page