CTRL-scroll for zooming stops working

Discussion in 'Mac OS X Lion (10.7)' started by dan1000, Jul 22, 2011.

  1. dan1000 macrumors newbie

    Joined:
    Mar 10, 2008
    #1
    After reboot, all is fine. But after a while, CTRL-scroll to initiate a zoom doesn't work. Yes, I know there are settings in the universal access pref pane, but even without mucking with any of those, a reboot always restores the CTRL-scroll zoom behavior, and after a few hours it always stops working (i.e.: CTRL-scroll produces no effect whatsoever).

    Anyone else notice this, and anyone else come up with a workaround?

    Disclosure: I'm on a 2011 MBP with a 27" monitor attached, and I run total finder and default folder.

    Dan
     
  2. randnc macrumors newbie

    Joined:
    May 13, 2009
    #2
    I'm having the same problem. For some reason CTRL and swiping a finger up or down the magic mouse to zoom stops working for me too. Don't know how to fix it. Double tap zoom continues to work, but I find that double tap zoom doesn't work everywhere. How can we notify Apple?
     
  3. eatmyjustice macrumors member

    eatmyjustice

    Joined:
    Mar 24, 2008
    Location:
    Indiana, USA
  4. baryon macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #4
    Same here... seems like an annoying bug! I think it might have something to do with trying to screen zoom while in full screen mode. Can someone get it to stop working right after they try to zoom in a full screen app?
     
  5. jazzbeaunola macrumors newbie

    Joined:
    Jun 18, 2010
    Location:
    N'Awlins
    #5
    Jumping on the CTRL-scroll bandwagon

    Same problem...this is a feature that I use constantly for editing, and it makes me crazy when it doesn't work. Loving Lion, but really, really need CTRL-scroll to work reliably!
     
  6. RetepNamenots macrumors 6502

    Joined:
    May 30, 2009
    #6
    Mine didn't work, and now for some reason it does. Weird.
     
  7. RickyB macrumors regular

    Joined:
    Oct 28, 2007
    #7
    Me too. It didn't recognise cmd shift + and - for zoom in and out, but now all is fine.
     
  8. ideal.dreams, Jul 24, 2011
    Last edited: Jul 25, 2011

    ideal.dreams macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    OH
    #8
    Mine stopped working and then out of nowhere it started working again.

    Edit: I went into Time Machine last night and after I got out of it I noticed it wouldn't let me zoom. I don't know if it's a coincidence or if that's actually the problem
     
  9. dmairq macrumors newbie

    Joined:
    Jul 26, 2011
    #9
    It's a bug

    This is a bug. ctrl - zoom was working fine before Lion. Now it randomly stops working, maybe after a sleep, still trying to figure out when it stops. A reboot fixes it for a while then it stops working not long after. I use it quite a bit and it's making me crazy. The control option pinch still zooms okay when ctrl-zoom fails but it doesn't scroll when you want to pan around the window. Early adopter blues - waiting for the first point release already... I'll never learn.
     
  10. C64 macrumors 65816

    C64

    Joined:
    Sep 3, 2008
    #10
    On a clean install this zoom option is disabled by default. Perhaps turning it off and on a few times sets it right.
     
  11. radu4iasi macrumors newbie

    Joined:
    Jul 26, 2011
    #11
    same problem here :(

    I am connected to a external monitor but I think it happened when not connected too

    going crazy :(
     
  12. btbrossard macrumors 6502a

    Joined:
    Oct 25, 2008
    Location:
    Chicagoland
    #12
    When I first read this thread - control + scroll to zoom worked fine.

    Now, 20 minutes later, it's busted and doesn't work.

    Hopefully a fix will be forthcoming.
     
  13. pawelthegreat macrumors member

    pawelthegreat

    Joined:
    Jul 23, 2010
    Location:
    Guelph, ON, Canada
    #13
    Same thing for me. It works but later on it stops.

    Lion is becoming quite a hassle for me.Wish I waited.
     
  14. dmairq macrumors newbie

    Joined:
    Jul 26, 2011
    #14
    A Viable Workaround To This Bug

    On another forum someone suggested this happens if the screen saver is active when the computer goes to sleep. He suggested using a hot corner to activate the screen saver which will temporarily fix the zoom problem until it triggers again. I happened to have my screen saver on a hot corner already so I gave it a go and it worked like a champ. All I had to do was activate the screen saver for a second then popped back to the desktop and my zoom was back. This is an acceptable workaround for me until it's patched. I was starting to get frustrated with this seemingly random problem but knowing how it happens and how to work around it is half the battle. Hopefully this helps someone else.
     
  15. DHKaplan macrumors member

    Joined:
    Jul 10, 2008
    #15
    Worked for me too! You wonder how someone discovered this bug fix...
     
  16. bpetruzzo macrumors regular

    Joined:
    Oct 22, 2005
    #16
    Bizarre. This work around does the trick for me too. It's annoying, but at least its pretty clearly some kind of bug and I'm not the only one.
     
  17. lolek macrumors newbie

    Joined:
    Nov 4, 2008
    #17
    Found this solution on different forum:
    "You'll find it under "System Prefs / Universal Access / Seeing"
    - Turn Zoom "on"
    - Open the "Options" and activate the last check box ("Use scroll wheel with modifier keys to zoom")"


    IT WORKS! :)
     
  18. CyBeRino macrumors 6502a

    Joined:
    Jun 18, 2011
    #18
    Please, read the thread next time. You look like an idiot now.

    --

    I have the same problem btw. Bug for sure. It goes away seemingly randomly and then returns without much fanfare.
     
  19. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #19
    I rarely use this feature but yesterday was one of those rare occasions and I could not figure out why it wash't working! Glad to see it's not because of something wrong on my computer :p
     
  20. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #20
    This annoyed me enough that I booted into the recovery partition (holding down cmd-r at startup) and fixed file permissions with Disk Utility; LOTS of permission errors on my unclean-install of Lion. It's been a day now, and the zooming is working consistently for me.
    Perhaps it will continue to do so.
     
  21. CyBeRino macrumors 6502a

    Joined:
    Jun 18, 2011
    #21
    It wont-- this has nothing to do with permissions. Even if that is often seen as the magical fix for everything (which it isn't.)
     
  22. Shorties macrumors 6502a

    Joined:
    Jul 22, 2007
    Location:
    Southern California
    #22
    except his tip solved my problem, so it was worthwhile.
     
  23. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #23
    It didn't.
    Zoom froze again today.

    So I wrote an Applescript to automate the checkbox clicking solution in System Prefs.
    It can be found over at MacScripter.

    Now at least it's only a couple of clicks to get things working again.
     
  24. Tomple macrumors 6502a

    Tomple

    Joined:
    Dec 12, 2008
    Location:
    New York, New York
    #24
    Thanks for this!
     

Share This Page