PeanutButterJellyTime

macrumors newbie
Original poster
Aug 14, 2020
5
0
Just wanted to share with you guys some weird bug happening.
Would be nice if anyone could confirm/disconfirm if it's happening on their machine.

Happens only when you turn off "Automatic graphic switching".
Hover on any link in any browser (chrome/safari) or other app that have pointer cursor.
You will see weird shaking when cursor switching from default (arrow) to pointer.

If I record my screen with MacBook recording app it doesn't show the behaviour.
So I'm attaching video recorded from phone.

- Shaking (when automatic graphic switching off):



















- Not shaking (when automatic graphic switching on):
 

pkamb

macrumors member
Dec 19, 2011
38
4
Seattle
I posted about this same issue here:

It appears to be a flaw with the 16” MBP’s GPU.

I get it whenever the GPU is on: connected to an external monitor or when Automatic graphic switching is disabled.

B16C9935-21E3-4D4C-8F7F-B4593410AD65.gif
 

rav3nloft

macrumors newbie
Oct 14, 2020
8
1
I have this issue as well! I have been in touch with Apple's customer service and they say it is expected behaviour... What a joke!
Someone found a workaround here:

Are only so few people having this issue? It is driving me nuts while using the machine on the dGPU...
 

Sota2d

macrumors newbie
Jun 3, 2021
1
0
Are there any updates on this? I have the same issue on my MacBook pro 2016 13inch w touch bar, which doesn't have a discrete GPU. This bug appears only when I'm using an external display and it's REALLY driving me nuts!!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.