Dead Powerbook G3 firewire (Pismo) -- battery issue?

Discussion in 'PowerPC Macs' started by JimWeinrich, Sep 7, 2004.

  1. JimWeinrich macrumors newbie

    Sep 7, 2004
    San Diego, California
    [Apologies if a question similar to this has already been posted on this forum. I spent awhile looking, but couldn't find one.]

    I have the Powerbook G3 with the firewire ports... I'm told this means I have a Pismo model.

    When I took it off the shelf after 8 months of storage, it appeared to be dead. Press the power button... nothing. Plug it into the power adapter... nothing. Plug in my second power adapter... nothing. (I don't have a second power CORD connecting the electrical outlet to the round power ADAPTER, but I doublt that's the problem, eh?) Dance a jig around the unit while chanting ancient runes... nothing.

    I own two main batteries. Both of those were dead, too -- not surprising since I didn't follow instructions :( and didn't keep them charged during those 8 months. I press the little power button on them and I get... nothing. Not even one green dot out of the possible four.

    I went to the store and bought a NEW battery. Luckily it seemed to be already charged... press the little button and I get four dots out of four. Insert into battery bay, press the power button... nothing.

    Oh, yes, along the way I did all of the above both with and without the AC power connected. Same results.

    And oh yes, I did go to the Apple support website and found out how to reset the Power Manager. For the Pismo it says I should press the tiny reset button on the back of the unit for 3 seconds, release it, then press the power key. I did this... nothing. I did it with and without the AC power, with 0, 1, and 2 batteries inserted in the battery bays.

    So I gather that my next step is to buy a replacement for the PRAM battery on the motherboard, right? If that's totally dead and preventing the power manager from being reset, it's quite likely that it would have gone dead during the 8 month hiatus on the shelf, right? And that would account for all my symptoms, right?

    So I'll go order one now. If it works, great! I'll write back and let y'all know. If it doesn't work... what should my next step be?

    Is there a reset button to press on the motherboard?

    Are my symptoms the classic symptoms of a fried... something or other?

    Is there a repair shop that loves to deal with laptops of this vintage?

    Any help would be appreciated. Thanks!

    -- Jim Weinrich
  2. vraxtus macrumors 65816


    Aug 4, 2004
    San Francisco, CA
    I've had something similar happen to a much older PB... a Duo 280C where after many months of non use the comp simply refuses to boot, regardless of the battery or not... so it could be that the mobo is fried in which case it may not really be worth it to replace.

    Since you're in the SD are check out CryWolf on Convoy street... they may be able to service your Piz but it may not be worth it at this point.
  3. krimson macrumors 65816


    Oct 29, 2003
    Democratic People's Republic of Kalifornia
    if you can't get it fixed, or they're charging alot, i have spare parts laying around. I might have something that'll bring it back to life.
  4. JimWeinrich thread starter macrumors newbie

    Sep 7, 2004
    San Diego, California
    Problem solved!

    Just a quick note to finish up this thread...

    I bought a new logic board battery, replaced it, and from then on...

    ...everything worked fine! The big battery that I thought might have worn out turned out to have some life left in it, and no resetting of the Power Manager was necessary.

    Thanks, everybody!
  5. doxz macrumors newbie

    May 31, 2006
    Can anybody tell me how to replace the logic board battery in a Powerbook G3 Firewire?
  6. cswarthout macrumors newbie

    Apr 2, 2006
    No need to even replace the backup battery. Remove the keyboard & right hand slot device (DVD/CD usually) and there is a battery in there (your backup battery). Simply unplug the battery from the logic board, plug in the power adapter and press the power button. Should boot up (did when I had this problem a year ago) and then you should plug back in the connection on the backup battery and leave the machine on for a while so as to recharge the battery.
  7. wedgie macrumors newbie


    Feb 11, 2007
    I received a hand-me-down Pismo Powerbook circa 2000, but it never booted up. It was most likely in storage for over 2 years. To make a long story short, I found this thread, took out the DVD player on the right via pullout wings, lifted the keyboard, unplugged the backup battery from the motherboard, plugged in the power cord, waited about 20 seconds, hit the power button, and voila, it booted!!! :D Thanks for sharing your experience with others like me!
  8. amyr macrumors newbie

    Feb 20, 2007

    I had the same problem with a Gismo had been sitting in the basement for a few months and was completely dead. Reseting PowerManager didn't work. Read this thread, followed wedgies's post, and problem was solved in less than 5 minutes for $0. Ahh...the beauty of the internet!
  9. jetboy macrumors newbie

    Mar 1, 2007
    something else?

    I was given a pismo that had been out of use for years due to a failed ac adapter. I bought a new ac adapter - not apple - but a reliable alternative according to all accounts and followed the advice of the above thread but still get nothing. no lights, no power, no indication that the ac is plugged in at all. (the power supply is getting warm, so its working)

    I am sure the main battery and the PRAM are both dead, so i disconnected the PRAM and have done the power reset (little button on back) - still get nothing- waited 3 hours with ac in, get nothing.

    could there be something else? something fried on the board? or do i just need a new main battery? im real interested in getting this going as I want to use it as my main laptop at school as i'm low on cash and cant afford a new one. (i did the trick with the amazon credit card, got the card and the 30 dollar rebate on first purchase, bought the power supply on the card, pay the card, then cancel the card, so the ac adapter only cost me 3 dollars plus 5 shipping)

    thats the sort of deals i look for, so looking for a good deal to bring this computer back to life! any help appreciated-

  10. SallyShears macrumors newbie

    Jul 6, 2007
    Dead Pismo -- Awesome tip... Thanks!

    This tip is awesome!

    Dead Pismo, won't boot, no chimes, no nothing. No way.

    Unclip and fold down the keyboard. Slide out the DVD drive from Right bay. Unplug the little round battery. Plug in, boot, plug the battery back in, replace the keyboard. :)


    -- Sally
  11. Doctor X macrumors newbie

    Aug 1, 2007
    Sorry for thread necromancy--though someone posted a month ago!--but here is something that happened to me last week.


    I have and love my old Pismo. Upgraded processor, 100 Gig HD, and maximum RAM. I have had the AC-Power/sound board/card die before. Suddenly, I could not power up my computer. Nothing, not a tone. It appeared to be another AC-Power card failure. The symptoms are very much the same. I have been told that "if you have a working batter it should power up." This is not the case in any of two previous times I have had the card die.

    HOWEVER, usually there is a period of one or two sudden losses of power. You are happily typing away and your computer shuts down. This did not happen. I noticed only that day that I had to hit the powerbutton twice to turn it on.


    Fine, so replacing the AC card did not do it. The vendor--a very nice guy who I have used on Ebay to replace things in the past--discussed it with me. One of the things he brought up was EXACTLY what some have discussed: a bad PRAM battery. "This will [CENSORED--Ed.] everything up." He stated, in the past, he bought a bunch since the Pismo was and is very popular. "Half of them did not work!" He basically disconnected the PRAM from his Pismo and runs it without it.

    What do you lose?

    Your clock is off. As most know, this will automatically correct when you connect to Al Gore's internet! Anyways, the problems he described with PRAMs are the same as claimed HERE. In fact, he has bought "dead" Pismos for parts that turned out JUST to have a faulty PRAM!

    Logic Board:

    Well, disconnecting the PRAM did not work. Since my processor is a semi-recent G4 550 MHz upgrade--which I happened to have tested a week before--the HD is new--should reboot anyways--the AC power card was new, this left the logic board--something that is old as this old computer!

    One symptom: when I would try to boot with the new AC power card you would hear a "zap" that indicated "something" was going through the card. You do not get this with a dead card in my experience.

    As my friends will joke, I use a Mac because some knowledge man is simply not meant to know! However, even I have learned how to take this thing apart! If you can get to your AC power card, you can easily replace the logic board.

    Replace . . . voila! Happy Mac!

    Sooooooo . . . while it has been a number of months Jetboy, it may be like JimWeinrich described--you may need a new logic board.

  12. TAF macrumors newbie

    Aug 20, 2007
    Variation on the same subject "motherboard battery"

    Hi there,
    I had done this several times on different PB "PISMO". It always worked fine. TODAY it seems to be a bit different. I did it and it restarted.
    But... once I shut it down it did NOT RESTART. Mmhhh... waited few minutes, opened, unplugged, replugged and once again it did start. Made a quick hardware test with its CD. All OK. Switched off ...and again same problem. In other words, to have it start, everytime I had to do that now familiar operation. What could it be? Probably those button batteries are too old? Anyone had the same problem? Where can I get a replacement? How do I remove them? No screws... Shall I cut that brown plastic wrapper?
    Thanks for any help. :)
  13. bonitap@fasterm macrumors newbie

    Aug 24, 2007
    Instructions to revive G3 work!

    I could not be happier, as of this minute, at least. My old G3 -- now dedicated to MIDI as a studio -- has been setting in its case for several months while I focus (so to speak) on summertime photography on a G4.

    When I wanted to take the G3 for a run, it seemed to be dead. First assumption: get a new power cable and/or adapter.

    But one Google later, I found MacRumors' forum and the brief, simple instructions about opening up my baby to unplug the round battery (which is a key shape on the right near the hard drive, tucked into a black holder.) Pull gently to unseat the white "snap" and then plug in the power to your power strip and the adapter into your G3. Press and go, "Holy Cow!" Then reverse instructions, of course.

    Perhaps I'm lucky that the fix fit the problem. Whatever, I am delighted to have fixed my hardware or figured out software one more time without having to spend bucks.

  14. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    First of all: Rule. I've had this problem (dead motherboard battery pack) a couple of times before with an old Pismo, and while I'd gotten lucky somehow and gotten it working again, this time luck wasn't with me. Turning up this post with where to get to that thing's connector saved me dismantling the thing.

    Second of all: Is that actually a battery pack as opposed to a little bank of capacitors, and if so, would replacing it fix this?

    I ask because the Pismo in question is an old "backup" laptop where I work, and I learned the hard way if you leave it with the regular battery inserted for a few weeks it'll drain that, then the motherboard battery, and then of course it won't boot.

    Now, I can get people at work to remember to take the battery out before putting it into storage, but if I were to replace that motherboard bank would it actually hold a charge for a few weeks so the thing will boot normally? I'm kind of guessing that, given how long the little 1/2 AA lithium batteries in a tower last that it's just worn out, but I don't want to bother replacing it if it won't help.

    Anybody know/tried this?
  15. lp-45 macrumors newbie

    Sep 10, 2007
    Dead Pismo fixed!

    I had the same thing happen. The powerbook would simply not turn on. I read somewhere that you could test it to see if it was because of a dead PRAM battery by simply disconnecting the PRAM battery. I did this and voila! the computer started right up! There is a great article on replacing the battery here:

    The neat thing here, is that all I had to do was open up the keyboard to have access to the battery cable. I just pulled the plug on it! It is a great way to test whether the PRAM battery is causing the trouble before buying a new pram battery!

    Hope this helps.
  16. Tanner31593 macrumors newbie

    Sep 3, 2007

    So i bought an 'untested' Lombard/Bronze keyboard 400mhz off ebay for$29.99. The guy who i bought it from didnt have the cord so he couldnt test it, so he looked on the sticker for the specs and sold it. It was advertised to have 64mb ram, but i opened it up and there was 2 256MB sticks in there....nice. But no hard drive.
    Anyway, i took it to the apple store to try their cord. Immediately after the cord was plugged into it (without me pushing power) the sleep light came on (green) and was steady, not pulsing. There was nothing on the display, it just remained black. I was told this was a hardware issue, and that the PowerBook shouldnt be turning itself on right when you plug it in. At this time the PRAM battery was connected. And he pushed the reset button, waited, and still the same thing. Tried it with the battery out too, same thing.
    So, could my symptoms be a bad PRAM battery???
  17. TAF macrumors newbie

    Aug 20, 2007
    Long time has passed since my quoted post. I kept using that PISMO but never turned it OFF completely. After using it I put it to "sleep". Every time I pressed a key it woke up. Today I logged OFF and "restarted". I could hear the HD running but nothing coming on the screen. I then did EVERY possible trick, PMU, PRAM reset, unplugged/replugged the pram battery, removed both RAM, etc.etc.
    No way to have it completely back to life.
    What could it be? I'm really mad since the web is full of sites showing pictures and tips how-to replace parts but nowhere I could find some detailed repair instructions/diagrams. I believe Apple has them. Anyone knows where I could find them? Any suggestions appreciated. Thanks.
  18. California macrumors 68040


    Aug 21, 2004
    I have found that the aluminum screws on the logic board on the Pismo sometimes loosen, unseating the board. MAKE SURE the board is seated correctly. These are practically indesctructable machines, so reseat the board.
  19. TAF macrumors newbie

    Aug 20, 2007
    PISMO still doesn't boot

    I did tighten those 2 aluminium (TORX 8) screws. I unseated/reseated the daughterboard. I pressed it down very very firmly... yet, no way to resurrect the Pismo. Everytime I press the power button I can hear the HD spinning... and that is all it does. Then, to shut it down I press again for several seconds until it stop spinning.

    Anybody knows what is this problem?
  20. macsrtheshizzle macrumors newbie

    Feb 17, 2006
    This is a lot like what is happening to the Pismo I just replaced a clicking hard drive in. Once I put in the new drive and booted it, I got the blinking "?" folder as expected. I walked away for a few minutes and it went dark. I did a forced shutdown and started it back up. Got the 'bong' sound but no video. Repeated this several time while also trying to boot off of a Panther CD1. Nothing. Took it all apart to make sure everything was snug and where it should be. Put it all back together and now no 'bong' sound. It appears to be powering up as the num-lock key lights up when I press it. Now not even the CD will open without using the force eject indented button. Am I doomed?

    I can't get the optical drive to slide out of its bay to check on the PRAM. Can someone tell me the trick please? The is the first Pismo I've ever done surgery on. Thanks guys and gals.
  21. Shining macrumors newbie

    Mar 17, 2008
    macrumors newbie

    05-31-2006, 11:46 PM

    Join Date: Apr 2006

    No need to even replace the backup battery. Remove the keyboard & right hand slot device (DVD/CD usually) and there is a battery in there (your backup battery). Simply unplug the battery from the logic board, plug in the power adapter and press the power button. Should boot up (did when I had this problem a year ago) and then you should plug back in the connection on the backup battery and leave the machine on for a while so as to recharge the battery.

    To: cswarthout ...

    I have joined your forum with one express purpose, and that is to thank you for the information as above, although a simple 'Thank You' seems so inadequate. I purchased my Powerbook G3 Firewire (Pismo) many years ago, and although it was a second user machine it was boxed and in absolutely immaculate condition, and worked perfectly, this was purchased to aid me in Web/Java Development to investigate cross-platform inconsistancies between the Apple and the PC.

    Being in the middle of a Forum Software development, I had little time to spend on trying the Powerbook and was many months before I decided it was time to try it out, and to my amazement the machine just wouldn't switch on, and after many fruitless hours of searching and internet hunting and downloading information, and consulting so-called Apple experts, never found a solution, and whilst learning that if the PRAM Battery became discharged the machine would not switch on due to its control over the energy management functions, never conceived that if the battery was disconnected altogether the machine would boot normally! - so much for my electronics background - but it worked a treat. The machine had been left boxed and unused for what must be approaching 5 years, and was giving a last chance visit to the internet - before committing it to the Bin! - when I came across your posting and advice, and thought - nothing to lose - within 30 seconds of unpacking it, I was back up and running, and after a few hours charge, has powered the machine under battery power for over 3 hours without problem so the batteries are obviously all still good.

    Thank You ... Thank You ... Thank You ...

    If you think I could ever be of assistance to you, contact me ...

    ... SB ...
  22. Duke1 macrumors newbie

    Mar 28, 2008
    Backup Battery Procedure G3 Firewire Powerbook

    I have the same problem but with he Firewire G3 Powerbook. I removed the CD Drive and the keyboard. I think I found the backup battery. It is attached with red, white and black? wires ending in a light colored plug at the motherboard. I pulled lightly on the wires to de-attach the plug but it didn't budge. How hard do you have to pull? Is there a release? Don't want to cause more problems than I have already. Thanks.
  23. Duke1 macrumors newbie

    Mar 28, 2008
    Powerbook G3 Firewire Fixed

    Frustration got the better of me and I just pulled harder. The plug released and then it restarted with the power button. This is a great website. Thanks.
  24. mauvnom macrumors newbie

    Mar 28, 2008
    I used two mini flathead screwdrivers wedged under each side of the connector piece and gently pulled it up when I was fixing one of these. I was afraid to yank the wire in case of it ripping. They really didn't allow for much room in that area and it was impossible for me to remove the connector using my fingers without physically pulling the wire up, which I didn't want to do.
  25. montgoma macrumors newbie

    Jun 1, 2008
    Dead Pismo G3 HEP!

    Like most of the posts here I have gone through similar scenarios. I replaced the daughter card with a 5oomhz the last time I got four beeps. it fixed the beast. Worked okay since November 2007 until about two days ago. I unplugged the beast because we were experiencing electrical storm. it sat for an hour unplugged, and then would not start out of sleep. shut down and started up with the ominous four beeps and flashing LCD. Yuck! I opened her up and tried all the tests unplugging everything, and trying to start without the PRAM battery. No dice. I got it to make a feeble attempt once and got the grey screen with flashing icon. But now no power at all---nothing not even a HD spin up! Any clues....did the logic board die??? How do you test for that.



Share This Page