Defragmentation failed now cannot repair or erase the external HD

Discussion in 'iMac' started by yashrg, Jan 25, 2013.

  1. yashrg macrumors regular

    yashrg

    Joined:
    Feb 21, 2008
    #1
    The hard drive in question was checked with disk utility for permissions or other issues before I ran defragmentation operation on it in hopes of improving performance. But after the application crashed on me, disk repair says "Disk Utility can't repair this disk." advises me to back up my files, and reformat the disk. But I cannot even erase it. The attached screenshot shows the only message it gives me.

    I am glad the hard drive didn't contain any critical data and was completely backed up with time machine. While this is the first time this has happened with me after tens of successful defragmentation, I have learned my lesson and will not be running defrag apps on my iMac again.
     

    Attached Files:

  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
  3. pubjoe macrumors 6502

    Joined:
    Aug 14, 2007
    #3
    I've had a problem drive before that eventually worked after repeated attempts to 'verify' and 'repair'. After about 10-20 tries of getting only part way through, it finally made it through the whole process. It's been running fine in my Son's imac for a year since.
     
  4. itsamacthing macrumors 6502a

    Joined:
    Sep 26, 2011
    Location:
    Bangkok
    #4
    First off, no need to defrag, it's not windows. Secondly run SMART test, extended and you might find a failing drive
     

Share This Page