Dictionary Bugs

Discussion in 'macOS High Sierra (10.13)' started by trumpetmercenary, Jul 24, 2017.

  1. trumpetmercenary macrumors member

    trumpetmercenary

    Joined:
    Jul 24, 2017
    #1
    Three main bugs, but only one is new in High Sierra

    New:
    1) clicking on links in wikipedia articles gives the error "This page cannot be displayed in this application." Only way to get the wikipedia link to reload is to go to the search field and force it to re-load the page by typing something like a space in the search after the title.

    And two old but still present Dictionary bugs:
    2) Clicking the "X" to clear the search field sometimes results in a crash of the dictionary. (This has been around forever...see my thread at Apple)

    3) Clicking on words in wikipedia articles (just regular words, not Wikipedia links) will load a wikipedia article for that word, but not the dictionary definition. So for instance, if you are in a wikipedia article and click the word "with," it will take you to the wikipedia article for 'with,' without displaying the dictionary definition at the top. Whereas if you were to type 'with' into the search field, it would load the dictionary definition first and then the wikipedia article. The only way to get the dictionary definition to load, after clicking 'with' in the wikipedia article, is to, once again, go to the search field and force a re-load.

    (Sorry, I know that last bug is a little confusing to describe)

    Hopefully these can get worked out, because I know I'm not the only one who uses dictionary for both its definitions and wiki articles throughout the day.
     
  2. trumpetmercenary thread starter macrumors member

    trumpetmercenary

    Joined:
    Jul 24, 2017
    #2
    Happy to report that the latest patch (public beta 3) has fixed bugs 1 and 2. I am especially happy about #2, since that was in the dictionary since maybe 2014, and they finally fixed it!

    #3 is still present, but that's been in the dictionary for as long as I can remember. It might even be intended behavior, so who knows if that will ever change.
     

Share This Page