Did 3.x mess up wifi for everyone?

Discussion in 'iPhone' started by thadoggfather, Nov 28, 2009.

  1. thadoggfather Suspended

    thadoggfather

    Joined:
    Oct 1, 2007
    #1
    My wifi signal, even when two feet from my friend's wireless router, fluctuates in signal but when I turn wifi off and back on, it grabs full signal. In the apple store now, picked up a dozen iPhone 3GS and iTouches, and they all seemed to have one bar of wifi but if I turned wifi off and on, it would grab the signal at full strength. All the laptops display full signal.

    I was considering getting my iPhone swapped for the wifi acting weird since I first got the phone (signal bars fluctuate, but it still holds a signal). I think I might just hold onto my otherwise perfect iPhone 3GS... seems like the problem is fairly wide spread. Spoke to a friend who has 3GS also and he said the wifi's been popping in and out on his too. Help?

    Thanks guys.

    EDIT: i even have friends with the 3G model who used to have perfect wifi and have had flawed wifi ever since the 3.x upgrade (regardless of the updates since 3.0). hmmmm
     
  2. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #3
    I'm still on 2.2.1, but I don't remember having wifi issues when I was on 3.x.
     
  3. ntrigue macrumors 68040

    ntrigue

    Joined:
    Jul 30, 2007
    #5
    This is a real problem with 3.1.x. Lots of threads on Apple Support. My girlfriends Original iPhone can't connect to WiFi anymore and mine had distance issues so I bought an Airport Express.
     
  4. HellDiverUK macrumors 6502

    Joined:
    Oct 24, 2009
    Location:
    Belfast, UK
    #6
    No.

    In fact, it works better on 3.x than 2.x with the crappy Buffalo router in my parent's house. Though none of the networks I'm connecting to are 802.11n - they're all 802.11b/g.
     
  5. MetalAZ macrumors newbie

    Joined:
    Nov 22, 2009
    #7
    Mine's been fine. I haven't noticed any change.
     
  6. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
  7. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #10
    Don't pay attention. Special kid there...

    Also, 3.x and everything works.
     
  8. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #11
    I'm being truthful. What's not to pay attention to? I don't remember having any issues with wifi or else I probably would have been complaining about it.
     
  9. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #12
    Nope, my wifi is working perfectly, before and after the update.
     
  10. SpaceKitty macrumors 68040

    SpaceKitty

    Joined:
    Nov 9, 2008
    Location:
    Fort Collins Colorado
    #13
    I haven't had a WiFi problem on my 3G or 3GS.
     
  11. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #14
    All your posts are about OS 2 and how OS 3 sucks. So, your posts are biased at best.
     
  12. greygray macrumors 68000

    greygray

    Joined:
    Oct 22, 2009
  13. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #16
    My post wasn't about 2.2.1. I said that I don't remember having wifi problems when I was in 3.x
     
  14. Pimptastic macrumors regular

    Pimptastic

    Joined:
    Nov 27, 2006
    Location:
    Up North, UK
    #17
    I have a similar issue with the latest OS on a 3G.

    When in the my bedroom and trying to watch BBC iPlayer, i have full wifi siginal and everything starts fine, then after a few minutes, i totally lose wifi signal, and i takes a couple of minutes to get it back.

    It wont even auto-connect back to the network, i get the pop-up saying networks found and i have to select my router.

    Rather annoying.

    I do think it may be a distance issue though, as when in the living room, where the router is situated, wifi never drops
     
  15. Flhusky macrumors 6502a

    Flhusky

    Joined:
    Aug 28, 2007
    Location:
    Florida
    #18
    No issues w/WiFi & 3.x.x
    Matter fact the only issue I had was a friends 'N' network.
     
  16. aristotle macrumors 68000

    aristotle

    Joined:
    Mar 13, 2007
    Location:
    Canada
    #19
    No. I'm assuming that that OP is jailbroken. I'm running the official firmware on my 3GS.

    This really should have been a poll.
     
  17. phjo macrumors regular

    Joined:
    Jan 8, 2008
    #20
    I do have problems with wifi

    with my iphone but 3.x os update is certainly not the culprit, as my iphone 3GS has only known 3.x os...

    In fact : my iphone almost always show strong wifi signal to my access point, but sometimes it acts as if it has no connection at all and I have to turn off wifi and on again to get back online...

    (I do have a first gen ipod touch which has no problem whatsoever with wifi, and neither has my macbook any problem as well)

    phjo
     
  18. erratikmind macrumors 6502a

    erratikmind

    Joined:
    Apr 2, 2009
    Location:
    S.F./Las Vegas
    #21
    Running 3.1.2 on the original iPhone without any wi-fi issues.
     
  19. Blueline29 macrumors 68020

    Blueline29

    Joined:
    Jun 16, 2009
    Location:
    Windermere, FL
    #22
    I've never had problems with my wifi. Granted, I don't use it a ton, but it's always been available and with a decent signal when I have used it. I'm jailbroken and on 3.1.2.
     
  20. Dre325 macrumors newbie

    Joined:
    Nov 6, 2008
    #23
    I've noticed with 3.x that I can't connect to my wireless network as reliably when I'm further away from my router. With 2.x I used to be able to consistently connect in my basement without issues (where I spend a majority of my time when I'm at home). Now the network doesn't even show up most of the time. I don't have any signal strength or connectivity issues when I'm closer to my router. FYI, my laptop and Wii connect just fine via wifi from my basement. It was even worse before the latest firmware update, but it's still not as good as 2.x with my 3G.
     
  21. efp1 macrumors 6502

    efp1

    Joined:
    Oct 3, 2008
    Location:
    UK
    #24
    I have the exact same problem as the OP. It used to work fine before.

    I use an iPhone 3G, never been jailbroken.
     
  22. eivinfl macrumors newbie

    Joined:
    Apr 16, 2009
    #25
    My WiFi died after installing 3.1.2. Talked to a Apple service center, and they meant it was a very limited problem concerning only a few iPhones. Since this already is a replacement phone, i'm starting to get a bit bothered. Will get it swapped later this month (i'm currently abroad, and they want swap it here since it's out of Apples European wide warranty(three months out... darn!))
     

Share This Page