Did 3.x mess up wifi for everyone?

thadoggfather

macrumors G4
Original poster
Oct 1, 2007
11,251
8,501
My wifi signal, even when two feet from my friend's wireless router, fluctuates in signal but when I turn wifi off and back on, it grabs full signal. In the apple store now, picked up a dozen iPhone 3GS and iTouches, and they all seemed to have one bar of wifi but if I turned wifi off and on, it would grab the signal at full strength. All the laptops display full signal.

I was considering getting my iPhone swapped for the wifi acting weird since I first got the phone (signal bars fluctuate, but it still holds a signal). I think I might just hold onto my otherwise perfect iPhone 3GS... seems like the problem is fairly wide spread. Spoke to a friend who has 3GS also and he said the wifi's been popping in and out on his too. Help?

Thanks guys.

EDIT: i even have friends with the 3G model who used to have perfect wifi and have had flawed wifi ever since the 3.x upgrade (regardless of the updates since 3.0). hmmmm
 

TheSpaz

macrumors 604
Jun 20, 2005
7,033
1
I'm still on 2.2.1, but I don't remember having wifi issues when I was on 3.x.
 
Comment

ntrigue

macrumors 68040
Jul 30, 2007
3,805
1
This is a real problem with 3.1.x. Lots of threads on Apple Support. My girlfriends Original iPhone can't connect to WiFi anymore and mine had distance issues so I bought an Airport Express.
 
Comment

HellDiverUK

macrumors 6502
Oct 24, 2009
460
0
Belfast, UK
No.

In fact, it works better on 3.x than 2.x with the crappy Buffalo router in my parent's house. Though none of the networks I'm connecting to are 802.11n - they're all 802.11b/g.
 
Comment

TheSpaz

macrumors 604
Jun 20, 2005
7,033
1
Don't pay attention. Special kid there...

Also, 3.x and everything works.
I'm being truthful. What's not to pay attention to? I don't remember having any issues with wifi or else I probably would have been complaining about it.
 
Comment

Pimptastic

macrumors regular
Nov 27, 2006
119
1
Up North, UK
I have a similar issue with the latest OS on a 3G.

When in the my bedroom and trying to watch BBC iPlayer, i have full wifi siginal and everything starts fine, then after a few minutes, i totally lose wifi signal, and i takes a couple of minutes to get it back.

It wont even auto-connect back to the network, i get the pop-up saying networks found and i have to select my router.

Rather annoying.

I do think it may be a distance issue though, as when in the living room, where the router is situated, wifi never drops
 
Comment

aristotle

macrumors 68000
Mar 13, 2007
1,768
5
Canada
No. I'm assuming that that OP is jailbroken. I'm running the official firmware on my 3GS.

This really should have been a poll.
 
Comment

phjo

macrumors regular
Jan 8, 2008
147
0
I do have problems with wifi

with my iphone but 3.x os update is certainly not the culprit, as my iphone 3GS has only known 3.x os...

In fact : my iphone almost always show strong wifi signal to my access point, but sometimes it acts as if it has no connection at all and I have to turn off wifi and on again to get back online...

(I do have a first gen ipod touch which has no problem whatsoever with wifi, and neither has my macbook any problem as well)

phjo
 
Comment

Blueline29

macrumors 68020
Jun 16, 2009
2,291
517
Saint Augustine, FL
I've never had problems with my wifi. Granted, I don't use it a ton, but it's always been available and with a decent signal when I have used it. I'm jailbroken and on 3.1.2.
 
Comment

Dre325

macrumors newbie
Nov 6, 2008
29
0
I've noticed with 3.x that I can't connect to my wireless network as reliably when I'm further away from my router. With 2.x I used to be able to consistently connect in my basement without issues (where I spend a majority of my time when I'm at home). Now the network doesn't even show up most of the time. I don't have any signal strength or connectivity issues when I'm closer to my router. FYI, my laptop and Wii connect just fine via wifi from my basement. It was even worse before the latest firmware update, but it's still not as good as 2.x with my 3G.
 
Comment

efp1

macrumors 6502
Oct 3, 2008
337
22
UK
I have the exact same problem as the OP. It used to work fine before.

I use an iPhone 3G, never been jailbroken.
 
Comment

eivinfl

macrumors newbie
Apr 16, 2009
5
0
My WiFi died after installing 3.1.2. Talked to a Apple service center, and they meant it was a very limited problem concerning only a few iPhones. Since this already is a replacement phone, i'm starting to get a bit bothered. Will get it swapped later this month (i'm currently abroad, and they want swap it here since it's out of Apples European wide warranty(three months out... darn!))
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.