Digital Touch not sending from correct account

Discussion in 'Apple Watch' started by trevoclark, Sep 21, 2015.

  1. trevoclark macrumors member

    Joined:
    Jun 30, 2015
    Location:
    Tucson, AZ
    #1
    My friends informed me that drawings I'd send them are coming from the wrong contact. Updated to watchOS2 today. They are sending from my iCloud email, but its not my primary Apple ID email so they show up as not from my contact on their device. I've tried logging in and out of iMessage on the phone and I've completely restored the Apple Watch. Thoughts on a fix?
     
  2. BlueMoon63 macrumors 68000

    Joined:
    Mar 30, 2015
    #2
    Any chance you might have something setup wrong on your phone under settings / messages / send and receive? Start a new conversation from... Even if it is right, pick your icloud and then change to your cell phone or another email address.
     
  3. trevoclark thread starter macrumors member

    Joined:
    Jun 30, 2015
    Location:
    Tucson, AZ
    #3
    Have also tried. I'm starting from scratch now. Will see if that fixes it. At the moment though it seems like the update has screwed up something with my contact info and the device isn't connecting with my Apple ID
     
  4. JayLenochiniMac macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #4
    Try changing the password for that iCloud account. That disassociates all connected devices, then set up again using the correct account.
     
  5. BlueMoon63 macrumors 68000

    Joined:
    Mar 30, 2015
    #5
    And you are certain in the Apple Watch App under General / Apple ID, that is set correctly?
     
  6. chrisxglass macrumors newbie

    Joined:
    May 18, 2015
    Location:
    Orange County, CA
    #6
    Same issue here. Definitely setup correctly. On an Apple Support chat now to try to get an answer.
     
  7. trevoclark thread starter macrumors member

    Joined:
    Jun 30, 2015
    Location:
    Tucson, AZ
    #7
    Yup! Even reset the watch and started fresh (no restore from backup) and it still occurs. In the iPhone app, under General > Apple ID, it is displaying the correct Apple ID. As another person here said they are experiencing the same thing, I'm guessing there is some iCloud issue. Friends can send to me and they arrive correctly from their contact.
     
  8. trevoclark thread starter macrumors member

    Joined:
    Jun 30, 2015
    Location:
    Tucson, AZ
    #8
    Yea same here, everything is right. This only occurred after the update to OS 2. Let me know what Apple Support might suggest. I've even set up the watch as a new device, so its something with iCloud associating with Apple Watch incorrectly.
     
  9. Recognition macrumors 6502

    Recognition

    Joined:
    Jun 27, 2013
    #9
    Try sending single colour and then multicolour sketches, I found they get sent from different email accounts on my watch.
     
  10. Gilb2406 macrumors newbie

    Joined:
    Oct 18, 2011
    #10
    Me and a friend are having the exact same issue. She sends me sketches and now since watchOS 2, they are coming from her icloud.com E-Mail address, which she doesn't use and I don't have in my contacts.
    Obviously with us knowing about this, we can add it and it's fine, but let's be honest, 80% if not more of users won't have people Apple IDs/iCloud addresses in their contacts, just phone numbers!

    Surely it would make sense to follow the same settings as iMessage/FaceTime and use the same setting for the "Caller ID".

    Mind you, since iOS 7, there is a major amount of people suffering from a bug that causes iMessage to sporadically switch to the E-Mail address. Can't believe that hasn't been fixed yet.

    Looks like Digital Touch is now joining that club as of watchOS 2 :(
     
  11. Pravda macrumors 6502a

    Pravda

    Joined:
    Sep 30, 2008
    Location:
    Philly
    #11
    Exact same issue here with my and my wife's Watch. Whenever we send sketches, it's showing iCloud email account as sender and not iPhone phone number.
    Must be another bug.
     
  12. DJTJ macrumors regular

    Joined:
    May 3, 2005
    #12
    same here!
     
  13. theadz01 macrumors newbie

    Joined:
    Mar 7, 2004
    Location:
    London
    #13
    Same issue on my watch
     
  14. Pravda macrumors 6502a

    Pravda

    Joined:
    Sep 30, 2008
    Location:
    Philly
    #14
    Please let us know if they have any clues on a resolution or ETA of one.
    Thanks.
     
  15. Pravda macrumors 6502a

    Pravda

    Joined:
    Sep 30, 2008
    Location:
    Philly
    #15
    Just got off the phone with Apple Tech Support. Per Apple, this is now the new standard procedures, sketches, digital taps, etc will be send via iCloud email and not via iPhone iMessages from Watch. She said just to add the email to contacts. And this is as of Watch OS2.

    She also said if I like it the previous way better (send via my phone #), to get on Apple Feedback webpage and send them the request.
     
  16. JayLenochiniMac macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #16
    Yeah, this is highly annoying because nobody has my iCloud email.
     
  17. Pravda macrumors 6502a

    Pravda

    Joined:
    Sep 30, 2008
    Location:
    Philly
    #17
    Agreed! No clue why they changed it. I'm hopefully the Apple Tech was confused and it's a bug that they will fix soon.
     
  18. teeshot44 macrumors member

    teeshot44

    Joined:
    Aug 8, 2015
    Location:
    US
    #18
    Can't be "standard procedures". I don't have an iCloud email account and neither does my wife. You can't send or receive from something that does not exist. Both our watches, digital touch worked/work fine on Watch OS 1.0.1 and 2.0. I've had two watches, returning the first. iPhones 6 and 6+ with IOS 9.0.
     
  19. Kuroz macrumors member

    Joined:
    Oct 4, 2013
    #19
    I fixed it on mines, sign out of your main account on the Settings > ICloud tab. Just to be sure also sign out in the Settings > FaceTime by tapping the mail not switching it off.

    From my testing I isolated the problem being FaceTime. When you have FaceTime switched off, taps and sketches do not get sent/received.

    You can switch off iMessages also just in case. Keep it off for about 10-15 minutes? then restart phone and log back in iCloud settings. When you log in FaceTime again just make sure only your phone number is checked for where you can be reached by.

    I tried this fix on two apple watches that had this problem so it should work. Apple Tech support is wrong.
     
  20. Mr. Y, Sep 22, 2015
    Last edited: Sep 22, 2015

    Mr. Y macrumors regular

    Joined:
    Oct 12, 2011
    #20
    Same thing on my watch and my friend's watch. Gonna try the suggested fix -- hopefully it will work.

    UPDATE: Logged out of FaceTime and iMessage via iCloud address through phone and then rebooted and logged back in. Seems to work. Both my friend and I are reporting that sketches are not longer coming through email address.

    ...now if only we could figure out this huge battery drain issue...
     
  21. RaNdOm, Sep 22, 2015
    Last edited: Sep 22, 2015

    RaNdOm macrumors regular

    RaNdOm

    Joined:
    Jan 9, 2003
    Location:
    Albuquerque, New Mexico
    #21
    Tried this, but didn't work for me. I logged out of iCloud, FaceTime, iMessage, then turned off phone and restarted. Sketches are still coming from iCloud email.
    I'm trying it again to see if this works with a longer wait period. I'll update when finished.
     
  22. RaNdOm macrumors regular

    RaNdOm

    Joined:
    Jan 9, 2003
    Location:
    Albuquerque, New Mexico
    #22
    Update:
    Did it again with a long power off time and still didn't fix the problem.
     
  23. Kuroz macrumors member

    Joined:
    Oct 4, 2013
    #23
    Try only flipping the FaceTime switch after you log into your icloud tab. Don't tap Login with AppleID in facetime tab.

    If that doesn't work just leave FaceTime off for a while. I'm pretty sure it has something to do with it.
     
  24. LePigeonBleu macrumors 6502

    Joined:
    Jul 11, 2008
    Location:
    San Diego
    #24
    Hi!

    I just had this issue and noticed that when I looked in my FaceTime settings, my iCloud email address was selected as a way to reach me on FaceTime. I clicked to deselect it (and everything except for my phone number), and digital touch is now sending from my phone number again.

    Hope this helps!

    M
     
  25. RaNdOm macrumors regular

    RaNdOm

    Joined:
    Jan 9, 2003
    Location:
    Albuquerque, New Mexico
    #25
    I've tried just logging out of FaceTime, then turning FaceTime back on and not logging in, but it still doesn't work.
     

Share This Page