dim charge light

Discussion in 'MacBook Pro' started by AmberK, Feb 11, 2017.

  1. AmberK macrumors newbie

    AmberK

    Joined:
    Feb 11, 2017
    #1
    Okay so.. my MacBook Pro is a late 2011 1278

    I haven't done any mods to my mac.

    Yesterday I used my mac after having no charger for quite some time it had been sitting a while. I should add that I had to get a new charger because my last one burnt up. The plastic/rubber part in the charging port on the mac is gone but the prongs are still gold one is just slightly black on the side. Other than the plastic rubber stuff being gone most of the damage as far as I can tell was to the old charger.

    I plugged it in and it was fine I updated to sierra. It took a long time to update and it was running the fan a lot. It was pretty hot. I messed with it for a few and shut it down with %75 battery.

    Today it is dead.. no green lights on the side battery meter. I tried some troubleshooting like resetting the SMC. Nothing.. still a dim green charger light. I tried removing the battery.. nothing. Tried plugging the charger in without the battery and the light did go bright and then nothing again... I have ordered a new charging port. Does anyone have any other ideas? I'm really hoping that it will work after I replace the charging unit. :( I will be devastated if it is my logic board.
     
  2. Sanpete macrumors 68020

    Joined:
    Nov 17, 2016
    Location:
    Utah
    #2
    Sure hope it's only mostly dead. The lack of battery lights suggests it isn't only the port, but there are also cables and things. Let us know if the new port works.
     
  3. MBP_187, Feb 13, 2017
    Last edited: Feb 17, 2017

    MBP_187 macrumors regular

    Joined:
    May 10, 2016
    Location:
    Dhaka, Bangladesh
    #3
    I'm using the same MBP (late 2011, A1278).

    Relative newbie to MacBook Pro. But from your post, I do not think it might be the logic board. Was the MBP plugged in after shut down?

    If you shut it off working at 75% battery, then I do not think it might be a hardware issue. What OS were you running before upgrade to Sierra? (I am currently using Yosemite)

    Is current charging unit functioning? You mentioned that charger minus battery gave momentary response?...

    Wishing you good luck AmberK.
     
  4. AmberK thread starter macrumors newbie

    AmberK

    Joined:
    Feb 11, 2017
    #4
    I am putting the new part in now. We will see how it goes. I'll check in later.
     
  5. AmberK thread starter macrumors newbie

    AmberK

    Joined:
    Feb 11, 2017
    #5
    :) So I put the new charging port in and it works! So happy. I did have one issue when removing the logic board though :/ there's a serial number decal? Of some sort on the underside of the logic board. At some point my mac was too hot and it melted this decal thing to the "paper" in top of the keyboard. When removing the logic board there was no way to get it off with out tearing a little of that paper. I covered the thin rip with heat protectant tape so I'm hoping it's okay. I couldn't find much info on google about that. My mac is back to life and charging just fine :) I also cleaned the fan.. hopefully it works better now.
     
  6. Sanpete macrumors 68020

    Joined:
    Nov 17, 2016
    Location:
    Utah
    #6
    Heat protectant tape? You are well prepared! Glad it's back working.
     
  7. AmberK thread starter macrumors newbie

    AmberK

    Joined:
    Feb 11, 2017
    #7
    Here I am again with this issue. My mac got too hot and just died. I'm having the same issues as last time. Idk what to do. It won't power up with the battery out so it's dead. No battery light on the meter. I guess I could try ordering a new charger and battery??
     
  8. Sanpete macrumors 68020

    Joined:
    Nov 17, 2016
    Location:
    Utah
    #8
    Could be the port failed again. Not something I've heard many complaints about, though. You seem quite attached to this machine. Any reason you don't want to try another one?
     

Share This Page