Disabling Journalling for external drive

Discussion in 'macOS Sierra (10.12)' started by Crimson Hikari, Dec 5, 2016.

  1. Crimson Hikari macrumors member

    Crimson Hikari

    Joined:
    Apr 1, 2013
    Location:
    Guernsey, Channel Islands
    #1
    I'm trying to attach a usb flash drive to our modem/router (some Technicolor monstrosity our ISP insists on) for sharing files between my mac and my mother's.

    To attach storage, the external drive needs to be formatted to Mac OS Extended/HFS+ (Not Journaled), but Disk Utility does not allow this, even with using the Option key under 'File'; it appears greyed out.

    I'd resort to FAT32, but there is the possibility of files being bigger than 4GB, so it really isn't ideal.

    Does anyone have a solution, or an alternate way to format the drive? So far, every solution I've seen is seemingly outdated.

    OS version is Sierra, 10.12.1.
     

    Attached Files:

  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    You should be able to do this in Terminal.

    Run this command to see the physical disk number.

    Code:
    diskutil list
    Then this command to format to HFS+ (not journaled). Replace the X at the end with your actual disk number you found from diskutil list. Change "Test" there to whatever you want to name the disk.

    Code:
    diskutil eraseDisk HFS+ Test /dev/diskX
     
  3. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #3
    Disk Utility is a bit challenged sometimes. You need to unmount (not eject) the disk first to enable the option in the menu.

    You can disable journaling with this Terminal command:
    Code:
    diskutil disablejournal diskX && diskutil unmount diskX && diskutil mount diskX
     
  4. Crimson Hikari thread starter macrumors member

    Crimson Hikari

    Joined:
    Apr 1, 2013
    Location:
    Guernsey, Channel Islands
    #4

    Thank you very much for this! My router is still being picky with what partitions it wants to see, but it got the right format for the drive.
     

Share This Page