Disk not recognised firewire external drive

Discussion in 'Mac mini' started by desertweasel, May 18, 2011.

  1. desertweasel macrumors newbie

    Joined:
    May 18, 2011
    Location:
    Dubai
    #1
    I have a Mac mini 166 that has been doing great service as a download and media machine for 3 years now. Recently bought an iomega firewire external drive and that until last week was great.

    I am now getting a disk not readable error on this drive. The drive works fine on my imac, the following has been done:

    Reboots of machine and drive
    reset PRAM
    reset pmu
    replaced the hard drive in the case with new drive - this worked for a week or so until today when the dreaded DNR error is back.

    the drive is visible in disk utility but not the partition, all the repair and other options are greyed out.

    No idea what to do here, I thought the drive replacement had fixed it but seems that is not the issue, anyone got any ideas?
    thanks

    It feels like it has to be the mini, it is also struggling with USB drives though most of the time they are recognised.
     
  2. applegenius83 macrumors newbie

    Joined:
    Apr 27, 2011
    #2
    Perhaps it's time to get professional help. Do you have a warranty on your drive or computer? If so it wouldn't be a bad idea to claim them if your products aren't working.
    Have you tried a different cable? If it has a USB port try that. Try it on a different machine.
    That's all I can think of... other wise you have a bad hdd
     
  3. desertweasel thread starter macrumors newbie

    Joined:
    May 18, 2011
    Location:
    Dubai
    #3
    it is not the HDD, I bought a completely new one today and it worked for around 4 hours before doing the same as the previous drive. The drive is recognised by my other machine (imac) and works after a disk repair, the mini seems to be corrupting the partition somehow.

    In disk utility on the mini the drive appears but the partition is not visible and nothing can be done, repartitioning the drive always fails at around 50% waiting for the drive to reappear.

    it is the intermittent nature of this that is driving me mad, could it be software related? and if so what could be wrong?
     
  4. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #4
    the 1.66 mini is old. is has fw400 and usb2. I am sure you have plugged and unplugged cords into the machine for years. It may be simple wear and tear. As I recall replacement of the jacks is difficult and buying a refurb may be a better choice. How do you connect the fw to the imac do you have a fw800 to fw400 cable? or are both the imac and the hdd fw400. I want to know if you are using a different cable with the imac to hdd then the mini to hdd.
     

Share This Page