DiskUtility 10 patch for Sierra

Discussion in 'macOS Sierra (10.12)' started by afluriach, Apr 24, 2017.

  1. afluriach macrumors newbie

    Joined:
    Feb 16, 2016
    #1
    I am using 10.12.4. I am annoyed with the current Disk Utility, so I
    would like to also keep a copy of the Yosemite Disk Utility.

    It turns out that you can bypass the Mac OS version check by changing
    one CPU instruction as per this guide:

    https://justus.berlin/2015/10/restore-old-disk-utility-in-os-x-el-capitan

    However, this does not work in Sierra. Is there a way to do this?

    I tried this using Disk Utility from 10.10.5 (matching the checksum), however on Sierra 10.12.4 it produces the same error message. I reopened the file to confirm that the byte was indeed changed.
     
  2. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #2
    It is not a good idea. System programs are generally not transferable across versions of macOS. What this hack did was disable a dependency check in the program that would cause it to terminate. It wasn’t built to run on anything else and should not be forced to. Do you really want to risk corrupting data on your disks?

    If you must use it, run it from a recovery flash drive with the Yosemite installer on it.
     

Share This Page