DLNA servers keep disconnecting

Discussion in 'OS X El Capitan (10.11)' started by jjdodders, May 31, 2016.

  1. jjdodders macrumors member

    Joined:
    Aug 13, 2015
    #1
    (I don't know if this is the right subforum for this, so apologies if it's mis-categorised).

    I've been running PS3MediaServer for a few years to my PS3 and Samsung D6100 TV with no problems, but in the last few weeks its decided to stop working properly and disconnects after about 20 mins of watching something.

    I've investigated many variables...
    • Tried hosting the media on a different hard drive
    • Tried using LAN instead of WIFI
    • Tried several different DLNA Servers, including UMS, Twonky, Plex, and MediaLink
    • Tried casting files via Windows 10 in bootcamp.
    All of these still have the same problem. So its not the network or PS3MediaServer.

    I've come to the conclusion that the problem is either the TV or OS X. I'll be able to test a new tv soon, but in case anyone else has this problem, what solutions did you find? Is it Java? Is it one of the new OS X Updates? Has a setting somewhere been slyly changed? Is there a setting somewhere on my router that will stop it from disconnecting?

    Help!
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Hi JJ,

    I'm afraid I don't have personal experience with the PS3MediaServer, however as it uses Java, we can start troubleshooting from there.

    If you would be happy to download & install the latest version of Java from OS X by following that hyperlink.

    Secondly you can follow this link and then download the OS X SDK to see if this makes a positive difference. Just accept the licence agreement and install the Mac OS X version.

    Untitled.png

    Once you have done that, please can you restart your Mac with the option 'reopen windows when logging back in' disabled (unticked), and advise if this makes a positive difference?

    Thank you in advance for your patience.
     
  3. jjdodders, May 31, 2016
    Last edited: May 31, 2016

    jjdodders thread starter macrumors member

    Joined:
    Aug 13, 2015
    #3
    Ok, done all that. It was doing really well for about 45 mins and then cut off again. What do you think the next step is?

    I thought I'd share the log from Universal Media Server which shows what's going on...

    I'm interested in the sections in red text. Looks like there is a Java issue here, but not sure how to deal with it?
     

Share This Page