dmg Damage on ML

Discussion in 'OS X Mountain Lion (10.8)' started by duggram, Sep 7, 2012.

  1. duggram macrumors 6502

    duggram

    Joined:
    Apr 17, 2008
    #1
    I have two MBP. The '08 runs 10.7.4. The '09 is on 10.8.1 and can not work with a particular source of dmg, but the 10.7.4 laptop can.

    I work with an interface engine called Mirth Connect. Last night and tonight I have been trying to download a copy of the latest engine dmg. If I download it on Lion it works flawlessly.

    However, download the same file on Mountain Lion and the OS reports that the same dmg file "Mirth Connect Installer.app is damaged and can't be opened. You should eject the disk image."

    "Mirth Connect Installer.app is on the disk image mirthconnect-2.2.1.5861.b1248-macos.dmg." with the date it was downloaded.

    Tried putting the same file from Lion on a thumb drive and try it on ML, it chocks.

    The company replied to my email that "We tested it here on OSX and it works fine. The md5sum also matches. "

    On ML I can download dmg's from Adium, DBVisualizer and Firefox. They work fine. But these particular dmg's from Mirth Corp will not install on ML and will on Lion.

    Any suggestions on how I can get my dmg to install.
     
  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #2
    Why not let your company's IT department install it then? Seems like the easy and simple solution here. However, if you need it now, I suggest deleting it and re-downloading the entire file.
     
  3. duggram thread starter macrumors 6502

    duggram

    Joined:
    Apr 17, 2008
    #3
    I'm a consultant and personal Mac's aren't authorized for IT maintenance.
     
  4. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #4
    Then execute the second advice I gave.
     
  5. duggram thread starter macrumors 6502

    duggram

    Joined:
    Apr 17, 2008
    #5
    Thanks. I've downloaded this, and other versions quite a few times yesterday and today. The latest version I have at least 5 copies. Would be nice if it was that simple.
     
  6. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #6
    I have no idea... I would need to take a few minutes to take a look into it.
     
  7. laudern macrumors 6502a

    Joined:
    Jan 5, 2011
    #7
    perhaps costly and silly...but how about running a VM of lion on your 09 machine and see how it goes......
     
  8. jlocalled macrumors member

    jlocalled

    Joined:
    Oct 13, 2008
    #8
    I'm thinking that maybe it's due to GateKeeper? I believe the message for some apps that don't work properly with it will send up that error. It would make sense since it works on Lion but not ML. Try disabling it.
     
  9. duggram thread starter macrumors 6502

    duggram

    Joined:
    Apr 17, 2008
    #9
    laudern, thanks. I need to think about that.

    I also just realized a typo. The '09 is really an '11 MBP. Apologies but I'm really tired and I screwed up.

    I already have Fusion with Win7 running on the '11 laptop. I don't know enough about Fusion to know whether or not I can install two different guest OSes on one instance. That would be interesting (ML, L and Win7). It has 8GB RAM which should help.

    Seriously if I could do that I'd put Ubuntu on it too!

    ----------

    You got it. Works like a charm. I'll let Mirth Corp know about this because I know there are quite a few mac users there that will be interested.

    Thank you all.

    I still need to check out that multiple guest os'es on Fusion. I'd like to try Ubuntu.
     

Share This Page