Do Not Disturb Allows Spam Calls

Discussion in 'iPhone Tips, Help and Troubleshooting' started by kittonian, Feb 23, 2018.

  1. kittonian macrumors member

    kittonian

    Joined:
    Aug 4, 2008
    Location:
    Austin, TX
    #1
    I have all the settings set to not allow any calls through when do not disturb is active, including silence set to always, no multiple rings allowing calls, etc. and yet every day these spam calls are getting through and ringing my phone.

    I have read so many articles on the subject, forum posts, etc. and nothing is answering the question of why these calls are still coming through. If anyone has insight I would really appreciate it.

    This is an iPhone 6 running the latest iOS revision on AT&T.
     
  2. Allyance macrumors regular

    Allyance

    Joined:
    Sep 29, 2017
    Location:
    East Bay, CA
    #2
    Other than the multiple rings setting (I have watched spammers call back immediately), some how their number is your address book as a known number, also is your screen locked at the time?
     
  3. kittonian thread starter macrumors member

    kittonian

    Joined:
    Aug 4, 2008
    Location:
    Austin, TX
    #3
    The screen is locked and no, the number (which always changes) is not in my address book or contacts list. I just double checked but we use a corporate contacts server and I also checked if there was anything local stored on the phone. There is not. Like I said, it doesn't make sense.
     
  4. chscag macrumors 68030

    chscag

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #4
    You might want to download the free "Hiya" app (caller id app) from the iTunes app store and try that for awhile. Once the spam numbers are loaded into its data base you won't get annoyed by them any longer. The problem with spam phone calls is that the spammers can change numbers and locations multiple times. Just keep in mind that any app that works with caller ID and looks for spam calls is going to eat into your battery up time.
     
  5. Allyance macrumors regular

    Allyance

    Joined:
    Sep 29, 2017
    Location:
    East Bay, CA
    #5
    I used to block every spam call, now I just ignore. I agree your problem doesn't make sense. I know that spammers now create false caller IDs. I live in CA, but my phone number is my old business number from NY State, so most of my spam calls appear to be originating from the same area code. What I don't know is what number the iPhone actually reads, the originating number or the false caller ID.
     
  6. Allyance macrumors regular

    Allyance

    Joined:
    Sep 29, 2017
    Location:
    East Bay, CA
    #6
    I did a little google research and there is a true phone number that that can be revealed, but only by 800 numbers that pay for the incoming call. It is called:
    Automatic number identification (ANI) is a feature of a telecommunications network for automatically determining the origination telephone number on toll calls for billing purposes. Automatic number identification was originally created by AT&T Corporation for internal long distance charging purposes,[1][2] eliminating the need for telephone operators to manually request the number of the calling party for a toll call.

    It would be great service if Apple had a setting that would display the ANI number so that you could block it.

    Note: it is legal under some circumstances to spoof the caller ID.
    --- Post Merged, Feb 23, 2018 ---
    This might be a little extreme, but here is an app that will solve your problem except service is $4.95 per month.

    https://www.trapcall.com
     
  7. kittonian thread starter macrumors member

    kittonian

    Joined:
    Aug 4, 2008
    Location:
    Austin, TX
    #7
    I should not have to pay for a service because Apple can't get Do Not Disturb to function correctly in iOS.

    As far as I understand it, even if the person spoofs the caller ID, it's the caller ID that comes up that tells the iPhone whether or not to block or accept. So, it's shouldn't matter either way.

    One thought that seems to be a bit of a pattern is that the calls that are getting through have my cell phone number except for the last two digits (i.e. XXX-XXX-XXYY). I wonder if this is a do not disturb bug where it's allowing calls due to only the last two digits being different?
     
  8. Allyance macrumors regular

    Allyance

    Joined:
    Sep 29, 2017
    Location:
    East Bay, CA
    #8
    You got believe that the spammers will try to be one step ahead of the system, I wouldn't pay $5 a month either, but their service offers alot of tools for more serious problems. I don't think Apple intended their DND function to try to out smart the spammers, but more of a function to give you some privacy. I run mine from 10PM to 6AM and it seems to work fairly well. Not sure about your pattern, but one favorite trick is to call back right away to get around the DND. there is more to a call than just the caller ID and ANI that these guys try and exploit. I don't get it, because I will never buy anything from a cold call.
     
  9. kittonian thread starter macrumors member

    kittonian

    Joined:
    Aug 4, 2008
    Location:
    Austin, TX
    #9
    I don't care if it's a spammer or not. If the phone rings when it's not supposed to, that's a problem. That's the issue I am trying to solve. We need to stop focusing on a spam call or a regular call. If the device is in DND and everything is turned off so that when it's in DND it should never make a sound, it should be silent!
     
  10. Allyance macrumors regular

    Allyance

    Joined:
    Sep 29, 2017
    Location:
    East Bay, CA
    #10
    Apple felt there are situations where calls should be let through for emergencies and family calls, the number has to be in the contacts list. You are right in that unknown callers should not bypass the feature, something is definitely wrong. For the time being, you can turn your ringer off as a backup.
     
  11. kittonian thread starter macrumors member

    kittonian

    Joined:
    Aug 4, 2008
    Location:
    Austin, TX
    #11
    That's actually the entire point. I want emergency family calls to be able to come through. I do not want to be awakened by spam calls or any other calls that are not family emergencies. Turning off my ringer is not an option.
     
  12. NoBoMac, Feb 24, 2018
    Last edited: Feb 24, 2018

    NoBoMac macrumors 68020

    Joined:
    Jul 1, 2014
    #12
    Maybe "Allow Calls From" is hosed in the configuration? Maybe toggle that on then off to get it to stick? Might want to look into setting up the phone as new to see if that clears things up (might be a messed up configuration file).

    Barring that, can setup a default silent ring tone and then assigning a real ringtone to your important contacts. I have done this for the rare occasions spam does get through. "Rare occasions" due to I have the Hiya app (free) installed and it has been working like a champ to silence spam calls, including the first-six digit spoof numbers (everything gets sent to voicemail via Hiya in my settings).

    DnD disturb has always worked for me.
     
  13. kittonian thread starter macrumors member

    kittonian

    Joined:
    Aug 4, 2008
    Location:
    Austin, TX
    #13
    No question it's very strange, but after searching the web I find I am not the only one who is experiencing this by a long shot. I downloaded Hiya and got it setup. Hopefully that will solve the issue and I appreciate all the replies.
     
  14. Allyance macrumors regular

    Allyance

    Joined:
    Sep 29, 2017
    Location:
    East Bay, CA
    #14
    Keep us posted, hope you can limit them to a dull roar!
     
  15. chscag macrumors 68030

    chscag

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #15
    Be sure to keep an eye on your battery usage. Hiya will eat into your battery as more and more calls get dumped into the caller id blocking column. Can't be helped but it's nice to be aware of.
     
  16. Stevey1976 macrumors newbie

    Joined:
    Dec 31, 2014
    #16
    Hi,

    I was playing around with my iPhone XS today and while at work I decided to try the DND function, so I turned Do not disturb on and called my handset from my work phone which has no caller id - my iPhone rang. I asked the guy sat next to me to call my mobile number from his mobile and it sent him directly to voicemail, so right away it seems there is an issue with caller withheld/no caller id numbers getting through even when iPhone is set to Do Not Disturb.

    The fix for this? As crazy as it sounds is to turn off the setting for: Repeated Calls. When I set that to off and called my iPhone from my work phone it went straight to voicemail.

    Hope this helps.

    Steve
     
  17. tromboneaholic Suspended

    tromboneaholic

    Joined:
    Jun 9, 2004
    Location:
    Clearwater, FL
    #17
    This has some logic to it.

    If the caller's number is "unknown," the phone can't check to see if it is a repeated call since there is no phone number to compare it to (to see if it's the same caller). It probably doesn't check to see if there was a previous call because it doesn't have anything to compare.

    It probably should be changed so that it automatically blocks "unknown."
     
  18. chscag macrumors 68030

    chscag

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #18
    I rarely if ever get a call with an unknown caller ID, but it's good to know that can be sent to voicemail. Good tip, thanks.
     

Share This Page

17 February 23, 2018