Does anyone else have this issue with the SGP EX Crystal? Pics...

GDVI

macrumors regular
Original poster
Jul 7, 2010
139
0
The front went on fine the first time but the back was like this with the first screen and the second (the one pictured) in the box. I figured I'd give it sometime to adhere...it's now 1 1/2 weeks later. I managed to apply it both times perfectly (no dust underneath) but the back corners still did not want to stay. Anyone else? Maybe its just a defective batch (because the front came out beautifully)? Should I get a refund or an exchange?
 

Attachments

GDVI

macrumors regular
Original poster
Jul 7, 2010
139
0
Have you tired pushing it down with your fingernail (a lot?)
I have. I've tried EVERYTHING. I even put cardboard on either side of the phone and clamped it with a potato chip bag clip and it just kept coming up.
 

Xombie11

macrumors regular
Nov 2, 2009
123
12
Sounds like it's defective. Send SGP an email with these pics and see what they say.
 

reliantj

macrumors 6502
Sep 8, 2008
283
0
hm maybe remove it. reinstall it with the wet method then blow dry it to let the adhesive cure again?
 

ram8727

macrumors member
Apr 9, 2010
75
0
I did have issues with the speaker and home button not laying down on both screen shields. I sent SGP an email with these pics and they sent me the Oleophobic as replacement.



***Glad I chose to get the SGP Ultra Oleophobic for a replacement because they are amazing compared to the EX Crystal screen shields IMO.***
 

Dtown213

macrumors newbie
Jun 21, 2010
21
0
I had a very similar issue with mine. 2 back screens one front, so basically 3 out of the 4 in the package had an issue (didn't try the second front). Luckily I was able to get a perfect application of an oleophobic film after the first one appeared to have had bubbles on part of the adhesive. Too bad I didn't take pictures of that one. I also tried everything to get the edge to stay. The front film had an interesting line running parallel to the bottom and right corner that I couldn't get rid of either. I'm still awaiting a reply from SGP after I sent them pictures.
 

Attachments

asleep

macrumors 68040
Sep 26, 2007
3,452
1,404
Only around the earpiece cutout ... but, yep, can't "fix" it.
 

pikkashoe

macrumors regular
Jun 29, 2010
181
0
I had the same issues with the ear phone cut out and the home button cut out. I could not get them to stick no matter what I tried.
I tried to deal with sgp but they where just so bad with their customer service that I just returned the protectors for a refund.

I currently have a switch easy screen protector (came with the nude) on the phone, which went on with no issues. No issues around the home button or earphone area.

Im going to order a PS soon.
 

3goldens

macrumors 68000
Feb 26, 2008
1,779
97
they have been known to do this. you need to contact them and send them these pictures because it seems to be happening more and more and if they don't know about they can't do anything about it.

I am about to forward them pictures of mine to get replacements for the iPhone and iPad.

personally I think some screens have this problem and others do not, may be the screen itself, just a guess but do contact them!
 

Hennesie2000

macrumors 68000
Sep 29, 2007
1,512
37
Maryland
I bought an Ex set to use on my phone and my wifes phone. I had that issue on the back that I installed on mine and the front on hers. The other two pieces of film went on perfectly. On my phone I have switched to a power support set and will probably do the same thing with my wifes phone. It was very frustrating with the SGP films and I was disappointed with them.
 

ChubZ

macrumors regular
Jul 13, 2010
164
101
i had the same problem with 2 of the EX films I received and it's easier to get through to the whitehouse than it is to SGp's CS
 

chanerz

macrumors 65816
Jul 7, 2010
1,137
326
same problem but mine was around the ear piece. i just switched to power support and now is perfect!
 

funkeruski

macrumors regular
Apr 3, 2010
134
0
I am on my 4th SGP Ultra and none of them have adhered properly around the earpiece and home button. They actually sent me two free sets, so I am going to try 5 and 6 so see if I get lucky. If not, then I'm going Power Support.
 

Ferrd

macrumors regular
Jan 24, 2008
119
6
same problem but mine was around the ear piece. i just switched to power support and now is perfect!
Same for me. I emailed their support twice and never received a reply. I ordered the Power Suport crystal films and I am much happier with their product. No bubbles and the easiest dry install EVER!
 

GDVI

macrumors regular
Original poster
Jul 7, 2010
139
0
If SGP is willing to send me a replacement WITHOUT me having to send my current protectors back then Ill go with that. If not, I'm going to PS.
 

zeeflyboy

macrumors regular
Apr 25, 2009
231
0
to be fair, mine went on brilliantly... so yours is definitely not normal and you should get it replaced.

I even lifted the front of mine up again using the tape to remove a speck of dust that had snuck in and it went back down again perfectly.


So far very happy!
 

thesumokid

macrumors newbie
Jul 29, 2010
18
0
sucks for u dude mine went on perfectly. u got a defect send it back they'll give u a replacement that is if they respond to their dam emails
 

SwitchmonkeyB

macrumors newbie
Jul 16, 2010
1
0
I've got the same issue (a very thin line where it's not adhering to the glass) across the left edge of my phone. I even tried pulling off the first one and replacing it completely with the other front and it has the same problem. Very disappointing.
 

countzero2k10

macrumors member
Jun 15, 2010
94
11
Alabama
Yep!

Had some issues with mine too around the edges and also with them with the bumper on. Replaced the SPG with the Powersupport films and have been happy ever since. No lifting and works great with the bumper :)
 

dunxxx

macrumors regular
Jul 15, 2010
140
23
SF, CA
Im having the same issues, in the same exact spots. Since I have a bumper on the side issues dont really bother me because I can't see it. The issue around the home button is what gets me. May have to look into another brand to replace
 

Dtown213

macrumors newbie
Jun 21, 2010
21
0
Im having the same issues, in the same exact spots. Since I have a bumper on the side issues don't really bother me because I can't see it. The issue around the home button is what gets me. May have to look into another brand to replace
They did finally respond a week after my initial e-mail, so i sent in pictures. After not hearing from them for another week I called them and explained the issue and the lady looked for my e-mail with the pictures, but couldn't find it. She still sent me out replacements screens and it even came with extra. Maybe I got lucky but calling them helped a ton.
 

GameraFan

macrumors regular
Feb 5, 2008
138
0
Exact same problem as the original post. The original back film was fine but it had the flash problem. Got a free replacement back with the flash cutout and it won't lay flat along the edges. Guess it's time for a different company's product...
 

Menzo

macrumors member
Jul 14, 2010
51
0
I got and installed my front screen protector (Ultra Clear Crystal), and the bottom left corner has this issue. I tried squeegeeing it down, tried flattening it down for a few minutes, fingernails, no change.

Oh well. Guess it'll tide me over till I find a better solution.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.