Does your 7/7+ touch screen ever stop working?

Discussion in 'iPhone' started by thadoggfather, Dec 7, 2016.

  1. Newtons Apple Suspended

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #26
    My opening day 7+ did this several times the first month or two but has not in a while now. Not sure if it was an update or what but has not happened in a while now.
     
  2. thadoggfather thread starter macrumors G4

    thadoggfather

    Joined:
    Oct 1, 2007
    #27
    Such an odd bug after a day or two it started doing it again.

    Oh well. I'm going to go with software
     
  3. pippakay macrumors member

    pippakay

    Joined:
    Nov 8, 2009
    #28
    ah, sorry, if i press power it *does* lock. sometimes i hold and swipe just to be really thorough. :)
     
  4. thadoggfather thread starter macrumors G4

    thadoggfather

    Joined:
    Oct 1, 2007
  5. thadoggfather, Dec 19, 2016
    Last edited: Dec 19, 2016

    thadoggfather thread starter macrumors G4

    thadoggfather

    Joined:
    Oct 1, 2007
    #30
    And it happened again. So much for that.

    Anyways I think it helped in general

    For people this is happening to is it also happening on your non 7/7+ iOS 10 devices too?
     
  6. lclev macrumors regular

    lclev

    Joined:
    Jul 29, 2013
    Location:
    Ohio
    #31
    I have a 7+ that I got on launch day. I have never experienced any issues like the ones being described. I remember reading that the modem is different in Sprint, Verizon, and Sim-free versus AT&T and T-Mobile. I wonder if we compare carriers if that could be an issue. (My carrier is Sprint.) I don't know of any other hardware differences but if anyone else does this could also be an issue.
     
  7. blkjedi954 macrumors member

    blkjedi954

    Joined:
    Feb 15, 2012
    Location:
    Florida
    #32
    It happens to me just as the screen dims to auto-lock. How bout you?
     
  8. thadoggfather thread starter macrumors G4

    thadoggfather

    Joined:
    Oct 1, 2007
    #33
    Seems random for me but the fix is easily reproducible every time
     
  9. DrewDaHilp1 macrumors 6502a

    DrewDaHilp1

    Joined:
    Mar 29, 2009
    Location:
    All Your Memes Are Belong to US
    #34
    Happens to me sometimes. Seems to only do it when I've left the screen on and it tries to go to "sleep mode" it will be dimmed down but touching the screen doesn't seem to reawaken it. Hitting the sleep buttons seems to get it going again.
     
  10. thadoggfather thread starter macrumors G4

    thadoggfather

    Joined:
    Oct 1, 2007
    #35
    People who had issues have they been resolved with a software update ?
     
  11. CPx macrumors 6502a

    Joined:
    Sep 6, 2013
    #36
    This happened to me a few times in the early days. But now that you mention it, it hasn't happened for quite a while.
     
  12. thadoggfather thread starter macrumors G4

    thadoggfather

    Joined:
    Oct 1, 2007
    #37
    same unit that used to, right?

    thats good to know!

    I'm still on 10.1.1 because bound to jailbreak, doesn't do it as often but still does. 100% fixable when it hiccups, re-locking/unlocking, so all good
     
  13. npolly0212 macrumors 65816

    Joined:
    Sep 21, 2015
    #38
    Mine still does this (As did the first one i had that got replaced).
    Mine will also freeze up to the point nothing works and i can't power it off or anything for a few minutes
     
  14. thadoggfather thread starter macrumors G4

    thadoggfather

    Joined:
    Oct 1, 2007
    #39
    7 or 7+?

    restoring from backup or set up as new?
     
  15. npolly0212 macrumors 65816

    Joined:
    Sep 21, 2015
    #40
    7+
    both have been set up as brand new
    have nothing saved that needs to be restored from backup lol
     
  16. tl01 macrumors 68020

    Joined:
    Jun 20, 2010
    #41
    I have had it happen all mine...and I have gotten my phone replaced for other reasons and have started fresh and it still happens. It has been an intermittent issue for a while.
     
  17. thadoggfather thread starter macrumors G4

    thadoggfather

    Joined:
    Oct 1, 2007
    #42
    hmmm interesting

    still doing it on 10.3 or 10.3.1 or whatever is latest? thats interesting,

    I wonder what other peoples' findings are,

    have both your devices always frozen up? don't have that issue,

    and has the unresponsiveness been happening the same, or less frequnetly/more since software updates ?
     
  18. npolly0212 macrumors 65816

    Joined:
    Sep 21, 2015
    #43
    Had this exact same problem and both phones do the same thing. The my new one does it more.

    None of the software updates have changed any way my phone acts. There are just random days that it happens 5-6 times and then it can go 2-3 weeks without happening and then all happens again
     
  19. thadoggfather thread starter macrumors G4

    thadoggfather

    Joined:
    Oct 1, 2007
    #44
    That's crazy and interesting.

    Are you guys beginning to think it's hardware specific to all devices or just an unresolved longstanding bug?

    I also wonder if 7 users experience this or just 7+
     
  20. tl01 macrumors 68020

    Joined:
    Jun 20, 2010
    #45
    I don't think it is hardware. It happened pre 7plus for me too. I think it is just a software issue. I have another forever softwarenissue where my phone gets stuck in landscape when texting even though I didn't put it into landscape position. I have to close and restart the app like twice a day sometimes for that. That has been happening for years.
     
  21. CPx macrumors 6502a

    Joined:
    Sep 6, 2013
    #46
    Same unit. Interesting that others are still having problems.
     
  22. thadoggfather thread starter macrumors G4

    thadoggfather

    Joined:
    Oct 1, 2007
    #47
    That's true lol. The landscape bug will never die. Doesn't happen as often as 6 plus tho that was the worst.

    I don't think it's at all relevant but just curious is it the intel or Qualcomm model for people who have had or are still having this intermittent hiccup?
     
  23. orbital~debris macrumors 6502a

    orbital~debris

    Joined:
    Mar 3, 2004
    Location:
    England, UK, Europe
    #48
    Same here. iPhone 7 Plus, 128GB, UK (O2 network).
     
  24. thadoggfather thread starter macrumors G4

    thadoggfather

    Joined:
    Oct 1, 2007
    #49
    I also wonder for people still having the issue if a clean restore (not ota update) fixes it. Ota can do strange things and hold onto old bugs
     
  25. willmtaylor macrumors G4

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    Here(-ish)
    #50
    My iPhone 7 used to do it several times a week. Apparently it's been fixed with software updates though because it hasn't caught my attention in some time.
     

Share This Page