don't want to connect iphone to same router as ipad

Discussion in 'iOS 9' started by daryl.harkin, Oct 15, 2015.

  1. daryl.harkin macrumors newbie

    daryl.harkin

    Joined:
    Oct 15, 2015
    #1
    Hi folks,

    long-time lurker, first time poster.

    having an issue where joining a network on my iPad causes my iPhone to connect to the same network and there doesn't seem to be any really obvious way of preventing this from happening.

    the problem is that at work I regularly connect my iPad to a router that is connected to an audio-mixer giving me control via my iPad - it's not connected to anything else - no Internet. When I do that, my phone also connects to this network effectively cutting me off from the outside world. As much as this is probably desirable to my employers, I'd rather that didn't happen!

    anyone know of any fixes that can be done through iOS?

    cheers

    daryl
     
  2. TheAppleFairy macrumors 68020

    TheAppleFairy

    Joined:
    Mar 28, 2013
    Location:
    The Clinton Archipelago unfortunately
    #2
    go to settings>Wi-Fi> click on the little "i" to the right of network you are connected to on your phone. Click "forget this network"
     
  3. daryl.harkin thread starter macrumors newbie

    daryl.harkin

    Joined:
    Oct 15, 2015
    #3
    that is causing it to forget the network on both devices.
     
  4. TheAppleFairy macrumors 68020

    TheAppleFairy

    Joined:
    Mar 28, 2013
    Location:
    The Clinton Archipelago unfortunately
    #4

    That's odd, I have done this just recently on iOS 9 and out none of my other 3 devices forgot the network.

    Well maybe someone else has some helpful solution.
     
  5. daryl.harkin thread starter macrumors newbie

    daryl.harkin

    Joined:
    Oct 15, 2015
    #5
    yea, I don't remember this being an issue until quite recently... I'm running the most recent beta. Might be time to send some feedback!
     
  6. I7guy macrumors G5

    Joined:
    Nov 30, 2013
    Location:
    What Exit?/Saguaro Country
    #6
    This is not happening on iOS 9.0.2. My iPad and iPhone can connect to independent networks/Ssids.
     
  7. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #7
    Not sure if this is what it is, but I think if you have iCloud Keychain enabled then it will remember passwords and connections across devices.
     
  8. I7guy macrumors G5

    Joined:
    Nov 30, 2013
    Location:
    What Exit?/Saguaro Country
    #8
    I have iCloud Keychain on my Idevices and this behavior doesn't happen.
     
  9. daryl.harkin thread starter macrumors newbie

    daryl.harkin

    Joined:
    Oct 15, 2015
    #10
    thank you! so it's not a new issue then! this is really odd - it definitely wasn't happening before, and I'm pretty sure I have had Keychain in effect since it launched! weird. I'll try turning keychain off on my iPad, if that's possible.
     
  10. 3568358 macrumors 6502

    Joined:
    Jun 11, 2015
    Location:
    United States
    #11
    If you log into a router on one device, it will pick it up on all devices, duh. BUT If you change the wifi network you are connected to on the second device, it should connect to that one first, since you manually connected- telling your phone that the selected wifi network is the one you want to be on when on that device. The phone should and will connect to that one every time, unless it is unavailable, which in that case it will connect to any wifi network that you have previously connected to on any of your devices.
     
  11. daryl.harkin thread starter macrumors newbie

    daryl.harkin

    Joined:
    Oct 15, 2015
    #12
    yea, but there's just one router - i want the iPad to connect to it and I don't want the iPhone to connect. I could just turn off the WiFi on my iPhone every time I go to work, but what is this, 2012?!?

    The biggest headscratcher about it is that it didn't happen before.
     
  12. 3568358 macrumors 6502

    Joined:
    Jun 11, 2015
    Location:
    United States
    #13
    just turn wifi off from control center on that device if you don't want it to connect at work.. once you leave the building or get home, turn wifi back on from control center...
     
  13. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #14
    Not sure what's so "duh" about it given that for various people it seems like it doesn't work like that or didn't work like that before.
     
  14. daryl.harkin thread starter macrumors newbie

    daryl.harkin

    Joined:
    Oct 15, 2015
    #15
    yea, i can do that, but that's a complete pain in the hole. i've sorted it by turning off keychain on the pad.
     

Share This Page