Downgrading from 4.0 to 3.1.3

Discussion in 'iPhone' started by AHDuke99, Apr 9, 2010.

  1. AHDuke99 macrumors 68020

    AHDuke99

    Joined:
    Nov 14, 2002
    Location:
    Charleston, SC
    #1
    So I know this was possible in past betas, but I was wondering if there was a downgrading solution as of yet? Apparently my iPhone won't work with many apps I use daily on 4.0, and I really can't be without them. Anyone know if it's possible to downgrade yet?
     
  2. WmSledd macrumors newbie

    Joined:
    Apr 9, 2010
    #2
    having the same issue here. upgraded to 4.0 and half my apps wont work. Need to be back to 3.1.3 asap without jail breaking my iphone.
     
  3. stoneo macrumors newbie

    Joined:
    Feb 9, 2008
    #3
    This was posted on another forum and it worked for me using blackrain .
    Stoneo





    I have just successfully downgraded from 4.0 to 3.1.3 on an iphone 3gs so it's definetely possible! It took a lot of fiddling around and some heart pounding but I eventually got it. I'll try to describe as best I can the steps I took.
    First, I put the iphone into dfu mode and attempted to restore back to 3.1.3 using itunes
    This failed and gave me a 10xx error code
    Next, I followed one of the tutorials on this site to change the apple authentication servers to saurik's as i have all my shsh's on file
    After changing this and attempting another restore I was still stuck with the 10xx error code and an iphone in recovery mode
    Finally, I attemped to use blackra!n to "bump" it out of recovery mode
    blackrain was not able to jailbreak the phone but it did the trick and after a reboot I was back to 3.1.3!
    I'm sure this isnt the best description, but I was fiddling with it at the time and wasnt too sure what I was doing. I'm sure this could be refined.
     
  4. WmSledd macrumors newbie

    Joined:
    Apr 9, 2010
    #4
    success! I unknowingly upgraded to 4.0 for fun which has turned into a 4 am battle with my iphone.

    I'm back to 3.13 after ALOT of research and some helpful post. Here is what worked for me.

    I did a restore to 3.1.3 got the error code 1015 blah. I then ran blackrain to "unlock" my phone. My 3GS went black and the blackrain message was wait for device to reboot. I waited forever and the screen was still black. I held the power/menu button until the phone restarted and there it was 3.1.3 on my phone. I'm restoring all my settings and files now. But phone came on I don't think its actually unlocked (i have no idea since ive never unlocked my phone before) but it was activated and my AT&T service is working.
     
  5. mmalto macrumors regular

    Joined:
    Mar 6, 2008
    #5
    here's what i did:

    put 3g into DFU mode
    restored to 3.1.3 in itunes
    loaded irecovery on my mac and ran:
    1. setenv auto-boot true
    2. saveenv
    3. /exit

    held in sleep and home for 10 secs

    phone rebooted and then activated (i have at&t). restored from last 3.1.3 backup prior to loading 4.0

    viola, back to 3.1.3
     
  6. bova80 macrumors 6502a

    Joined:
    Jul 8, 2008
    Location:
    Pittsburgh, PA
    #6


    this is what i did. worked as well.
     
  7. rossihvac macrumors regular

    rossihvac

    Joined:
    Jun 22, 2009
    #7
    Do I need to have my ssh on file? to do the above
     
  8. michaelfields macrumors regular

    Joined:
    Apr 8, 2010
    #8
    I did the option+restore to downgrade to 3.1.2 then got error 1015 and used blackra1n and my phone jailbroke then restarted and everything but then when it comes on it's got no service and won't connect to at&t..... I've tried twice now
     
  9. Revelation78 macrumors 68000

    Revelation78

    Joined:
    Dec 18, 2008
    Location:
    North Carolina
    #9
    First off, I'm glad things worked out for you...

    Secondly - HOW can you "unknowingly" upgrade to 4.0? I'm allergic to BS and I haven't stopped sneezing since I read your post...
     
  10. matttye macrumors 601

    Joined:
    Mar 25, 2009
    Location:
    Lincoln, England
    #10
    This is why you shouldn't upgrade to beta software on a mobile phone you need to be able to use..
     
  11. michaelfields macrumors regular

    Joined:
    Apr 8, 2010
    #11
    yeah this was my first/last time ever doing any beta until I have a backup to do it on haha. I'm restoring to 3.1.3 right now sucks but oh well
     
  12. sportguy0913 macrumors 6502

    Joined:
    Jul 8, 2008
    Location:
    USA
    #12

    .... if you "unknowingly" did it, how was it for fun?....
     
  13. wingnut8 macrumors 65816

    wingnut8

    Joined:
    Jun 8, 2007
    #13
    so i did this, and it worked. now it makes me curious to know if it would work to do this with 3.1.2
     
  14. goobot macrumors 603

    goobot

    Joined:
    Jun 26, 2009
    Location:
    long island NY
    #14
    if your on a 3g or ipod 2g just hit restore and then jailbreak when you hit a error near the end. if your a 3gs or ipod 3g you need to use shsh to get to 3.1.2 and then jailbreak to get rid of the same error.

    this is all from experience of downgrading this very firmware yesterday.
     
  15. bmwguy80 macrumors member

    Joined:
    Jun 25, 2007
    #15


    Worked like a champ on my 3GS... thanks!
     
  16. Jamesniz macrumors newbie

    Joined:
    Apr 11, 2010
    #17
    Sorry upaymeifixit, i hadnt seen your link before i tried downgrading back to 3.1.3

    I tried the irecovery and terminal once id restored to 3.1.3 and got the itunes 1015 error but got nowhere, im sure this is my fault but in irecovery i couldnt type anything, it just said process completed and using terminal, i typed in what i was supposed to and it didnt recognise it

    I then just downloaded blackrain, clicked make it rain, got the black screen, done a reboot by holding home and the power button and im back to 3.1.3

    As i say, im sure this is user error on my part but i was getting nowhere with irecovery

    Thanks

    James
     
  17. ynnoj macrumors member

    ynnoj

    Joined:
    Sep 18, 2007
    #18
    This is the error I'm getting in Terminal:
    Code:
    dyld: Library not loaded: /usr/local/lib/libusb-0.1.4.dylib
      Referenced from: /Users/J/Downloads/Tools/./iRecovery
      Reason: no suitable image found.  Did find:
    	/usr/local/lib/libusb-0.1.4.dylib: stat() failed with errno=20
    	/usr/local/lib/libusb-0.1.4.dylib: stat() failed with errno=20
     
  18. Jamesniz macrumors newbie

    Joined:
    Apr 11, 2010
    #19
    Sorry mate i cant help, sure others can but i just used blackrain after no success with irecovery or terminal
     
  19. Boblister macrumors 6502a

    Joined:
    Mar 14, 2008
    Location:
    North West UK
    #20
    I had this. Turned out the version I had downloaded didn't have the associated lib. My son gave me a link to another that worked fine. If you don't get sorted I can try and find the link again.
     
  20. ynnoj macrumors member

    ynnoj

    Joined:
    Sep 18, 2007
    #21
    If you could link me that'd be great. Thanks.
     
  21. Boblister macrumors 6502a

    Joined:
    Mar 14, 2008
    Location:
    North West UK
    #22
  22. upaymeifixit macrumors 6502a

    upaymeifixit

    Joined:
    Feb 13, 2009
    #23
    If you guys had read my guide, you would have been able to easily fix that problem, my guide has the libusb-0.1.4.dylib attached. You don't even have do jailbreak. Try not to ignore this help. - Downgrade / Fix iTunes error 1015 - Guide I bet you it's the easiest guide for this.
     
  23. wickerman1893 macrumors 6502

    wickerman1893

    Joined:
    Dec 16, 2008
    #24
    To downgrade from 4.0 to 3.1.3 this is all you have to do.

    1. Download this program: http://blackra1n.com/ ( there is a windows and mac version)
    2. After it is installed, push the button that says make in rain.
    3. it will then say "searching for device", put the iphone in DFU mode and the program should then recognize the phone
    4. The screen will turn black but not go off, wait about a minute then hold down the home button and the power button until the apple logo shows up.
    5. It should take less than a minute to restore and you will then be asked to re-sync.

    I went through this last night around 1 in the morning and it worked thank god. :rolleyes:
     
  24. AppleMatt389 macrumors regular

    Joined:
    Jun 11, 2007
    Location:
    Australia
    #25
    This worked. Great advice! Thanks

    :apple:Matt
     

Share This Page