Duplicate Google accounts in Calendar

Discussion in 'OS X El Capitan (10.11)' started by HallStevenson, Jul 5, 2016.

  1. HallStevenson macrumors 6502

    HallStevenson

    Joined:
    May 1, 2012
    #1
    How do I stop Calendar from showing my (personal) Google account twice ? Searching on this issue and about the only thing I found was "View, Refresh Calendars", which doesn't help or solve anything. If I right-click, Get Info on each in the left-hand-pane, they're pointing to the same account. Under System Preferences, Accounts, there's only (1) entry for that Google account. I also have my work account (a Google Apps account) and it only shows once.

    The left-hand pane has:

    ----------------
    On My Mac
    • Home
    • Work
    Google
    • (my Google account)@gmail.com
    • (my Google account)@gmail.com (1)
    • Birthdays
    • Birthdays (1)
    • Holidays in United States
    • Holidays in United States (1)
    (my Google Apps account)
    • (my Google Apps account)@companyname.com
    • Holidays in United States
    • Birthdays

    Other
    (snip)
    ----------------
    (1) The entries marked are un-checked - no doubt related to the duplicate account

    I have removed my personal Google account and re-added it more than once trying to start over.

    How do I make Calendar forget everything so I can start over ?
     
  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    When you removed the account was it removed from both Calendar>Preferences>Accounts and System Preferences>Internet Accounts?

    Also, what calendars do you see on the Google web version of your calendars?
     
  3. HallStevenson thread starter macrumors 6502

    HallStevenson

    Joined:
    May 1, 2012
    #3
    I removed them from System Preferences, Internet Accounts (doing that removes them from Calendar, Preferences, Accounts). You probably know this ;) but removing, or trying to remove, items from the Calendar preferences dialog will take you to the System Preferences dialog.
    I see the same ones (but only (1) of each, not duplicates).
     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    Right...unless they're something like a CalDAV account added via Calendar>Preferences. You could try unchecking "Calendar" for the Internet Account that's causing you trouble and adding it via CalDAV in Calendar>Preferences>Accounts to see what kind of result you get that way.

    I'm thinking, though, that you're going to have to clean out your calendar data files that reside in your User "Library" folder.

    I don't know the cause or answer so that's the kind of stuff I'd try. See if anyone else weighs in first, though.
     
  5. HallStevenson thread starter macrumors 6502

    HallStevenson

    Joined:
    May 1, 2012
    #5
    I have unchecked and re-checked these multiple times. I also did end up finding a site that talks about removing Calendar-related items in ~/Library, which I've done. Now, Calendar only shows "Home, Work, and Birthdays".... :( Neither my personal Google calendar nor Google Apps account calendar are showing up. Strangely though, I do get notifications for calendar events !
    --- Post Merged, Jul 6, 2016 ---
    By the way, this behavior is happening on my iMac. It does NOT occur on my MBA using the same Google account (my personal account - I don't sync the Google Apps account on the MBA).
     
  6. HallStevenson thread starter macrumors 6502

    HallStevenson

    Joined:
    May 1, 2012
    #6
    Logging out and back in seems to have been necessary to fully sort this out. OS X reminds me more of Windows every day....
     

Share This Page