DVDs won't play "Supported disc is not available"

Discussion in 'Mac Basics and Help' started by Ryvius, Jan 12, 2007.

  1. Ryvius macrumors member

    May 4, 2004
    This is going to be one of those questions where I get yelled at to search the forums using a slightly different search string than what I used...

    But I can't play DVDs. Data and music cds work fine. Burning is fine.

    But every DVD I put in is unreadable and unmountable. DVD icon doesn't show upon desktop, DVD Player gives me a "Supported disc is not available" message.

    Its not just one damaged DVD, its a whole sampling of my collection and other programs like VLC don't help anything.

    Any ideas of what could be wrong?
  2. FadeToBlack macrumors 68000


    Apr 27, 2005
    Accoville, WV
    Try repairing permissions. Seems like I had this problem once and repairing permissions fixed it.
  3. Ryvius thread starter macrumors member

    May 4, 2004
  4. TheAnswer macrumors 68030


    Jan 25, 2002
    Orange County, CA
    Seems to do a few people having this problem around the net, but no clear solution:

    You might try using Cocktail or Onyx to run the cron scripts and clean out the system and user caches.

    Also, post your machine specs for us...and is this a new problem or something that just started happening?

    Good luck.
  5. theez1 macrumors newbie

    Jan 14, 2007
    I'm having the same exact problem. I've spent all day looking into it and haven't found anything to fix my problem yet.

    Here's what's going on for me:
    DVDs won't play in my PowerBook's superdrive or via my external DVD drive.
    The DVDs don't mount either.
    I have tried DVDs that have worked in the past and new ones.
    I can see the file size of the DVD's via Disk Utility and Toast.
    I have reset the PRAM.
    I updated my computer with 10.4.8 thinking that it may have a patch or fix.
    I also used Cocktail and permission repairs with no luck.

    I have a 1.67 Ghz G4 Powerbook.
  6. dllavaneras macrumors 68000


    Feb 12, 2005
    Caracas, Venezuela
    Is the combo/superdrive multizone compatible? If a DVD is from a different region than the one your mac can play, that could be the problem
  7. theez1 macrumors newbie

    Jan 14, 2007
    I don't know much about zones, but it's definitely not the dvds that are the problem. I've tried ones that have worked in the past as well as new ones. I'm wondering if my zone preferences got screwed up with an OS update or something. Anyone know how I can check which zone is my preference?
  8. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    My guess is that something's happened to UDF support. In OS 9, I'm pretty sure that there was a UDF extension that had to be installed. I think the OS X equivalent of this extension has been damaged :(

    I'll post back if I figure anything else out.
  9. theez1 macrumors newbie

    Jan 14, 2007
    Is there a way for me to test this extension?
  10. theez1 macrumors newbie

    Jan 14, 2007
    Well I looked into it some more and found an application called Region X, which allows you to change your dvd drive's region. When it started up it said that my region couldn't be found and an unknown error occurred. After that it let me assign region 1 (U.S.) but it was still a no go.

    I threw in my OS X Tiger install dvd today and it worked fine, so it is definitely a dvd video problem.
  11. theez1 macrumors newbie

    Jan 14, 2007
    Does anyone know who I can go to for help on this matter? I've been trying to figure this out for over a week and have posted on several forums but haven't had any luck fixing the problem. Is my next step to see an Apple certified technician or is there a way I can send my problem to Apple? I don't have any service plans and my warranty just expired.
  12. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    Have you tried a new user account? Are you able to put the drive in a different computer and see whether the discs mount?
  13. GlynJones macrumors 6502

    Jun 15, 2005
    I had the exact same problem on my Powermac G5.

    Last weekend I tried (unsuccessfully) to upgrade the graphics card in the machine and one of the tests I did to try and get the card working was to backup the primary drive to a Firewire drive, clean install of Tiger and migrate from the hard drive when prompted by Tiger initial setup.

    This did not fix the graphics card problem but it did fix the DVD player.

    I know it's a bit drastic but it worked for me.
  14. devman macrumors 65816


    Apr 19, 2004
    My kids iBook had the same problem. Applecare swapped the DVD drive and all was good again.
  15. MacBoobsPro macrumors 603


    Jan 10, 2006
    Ive had this problem for AGES. The dvds work fine on my iBook and MacBook but refuse to play on my G5. However I farted around with the drive firmware but I cant remember what i did as I just fumbled my way through it and it seemed to fix the problem. I used DVRflash or something. :confused: :D

    I bought a new drive when my first drive started playing up and all was fine but then one day it started saying 'unsupported disc' for some discs. Wierd and VERY frustrating. Luckily it hasnt done it for a while now.

    *goes to bookies to bet that drive no longer works when he gets home*

    EDIT: Now my drive takes ages to read disks and needs to attempts at ejecting them. When i try to eject it the first time the disk unmounts then about 10 seconds later reappears on the desktop without physically ejecting. TBH it is fecking annoying.

    Hopefully Nermal can figure something out for us because over Apple Discussions there are hundreds of people with the 'not supported' problem and I think my latest problem is related. However I dont even know what UDF is so i cant do diddly apart from buying a new drive again.
  16. whooleytoo macrumors 603


    Aug 2, 2002
    Cork, Ireland.
    DVD Player in my home G5 stopped playing DVDs some time ago too. However, I can still watch DVDs using VLC though!
  17. theez1 macrumors newbie

    Jan 14, 2007
    I haven't tried a new account or reinstalling Tiger yet. I'm hoping not to have to. The drive is not the problem for me because neither my external nor my internal drive will play the discs.
  18. kaneap macrumors newbie

    Feb 27, 2007
    My superdrive won't play dvd's

    I got the same problem with my

    1.5GHz PowerPC G4 (512MB ram)

    My superdrive is:
    ATA-3 Bus:


    Manufacturer: MATSHITA
    Model: MATSHITA DVD-R UJ-835E
    Revision: GAND
    Serial Number:
    Drive Type: CD-RW/DVD-RW
    Disc Burning: Apple Supported/Shipped
    Removable Media: Yes
    Detachable Drive: No
    Protocol: ATAPI
    Unit Number: 0
    Socket Type: Internal

    When i insert any DVD disk (whether I have burnt it or it is a movie etc...) my mac says "there is no volumes that mac osx can read" It is fine with any cd! I can't figure it!

    Stupidly, i bought an external dvd drive from a mac shop thinking that would fix it. BUT the problem still exists. Please help! has anyone a solution?
  19. chasemac macrumors 6502a


    Jan 30, 2005
    In a house.
    Nice. Real helpful.
  20. theez1 macrumors newbie

    Jan 14, 2007
    Well I haven't had time to work on this and it still isn't fixed. I was hoping it would happen to enough people and someone would have found a fix by now. I need to have it fixed within a month before I start traveling.
  21. cubbie5150 macrumors 6502a


    Mar 4, 2007
    Huh, this happens to me also on my brand new 15" MBP (2.16 C2D).. I've tried 4 DVD movies & get the same "not supported" message in DVD player (when I tried VLC, when I click the play button, it just doesn't do anything). Heck, all of these DVDs play just fine in my Windows laptop!!

    EDIT: After trying to view these movie DVDs, now when I insert a data DVD, it won't mount on my dekstop. I opened disk utilities, and it's listed there, but the option to mount it is greyed-out--I can only select unmount or eject... Maybe a faulty super drive? Music CDs work fine...
  22. t1937r0 macrumors 6502a

    Sep 5, 2006
  23. cubbie5150 macrumors 6502a


    Mar 4, 2007
    Would repairing permissions help this issue? I won't be near my MBP until tonight, so I can't try it now....
  24. failsafe1 macrumors 6502a


    Jul 21, 2003
    I am trying to solve this problem and one other. In addition to the unsupported error message sometimes the video goes black but the time code keeps running like the disc is playing normally. It crops up on me every so often. I thought it might be the type of disc I was using to record with on my DVR but I have changed several brands and the problem keeps coming back. I fixed this problem in the past by trashing my DVD prefs. I am trying to find where the DVD player keeps the previously played list so it can go back to that spot when you insert the disc again. I would like to trash those also.

Share This Page