Dysfunctional Album Artwork is driving me mad

Discussion in 'iPod touch' started by itsliz89, Sep 19, 2008.

  1. itsliz89 macrumors member

    Joined:
    Sep 9, 2008
    Location:
    california
    #1
    So much for being excited over the new ipod touch...

    At first, I noticed that the album art didn't show up for about 4 of the albums, blank black screen (I don't have many albums to begin with).

    I tried multiple times on itunes to try to add the missing artwork, no luck. Then for some reason, it worked on random attempts for of the 2 albums. Oh wait, but then those two items started showing up for other albums as well. Like for example:

    [​IMG][​IMG]

    Albums in the Incubus category would have a Britney Spears and The Fray photo...

    But then the The Fray artwork randomly went away, going back to plain black.

    Now, multiple albums under one artist goes back to the default music note graphic like the photo above.

    I looked up possible problems and solutions. I don't apply artwork individually to one track. I select all titles in the same album, get info, and apply artwork to them all. I can't deselect the "show artwork" on the ipod or whatever it is because I don't see that option anyway on itunes 8.0...

    I want to scream on the top of my lungs. Never had problems with itunes and my older nano. I wanted to also note that artwork looks fine on itunes for me as well. This darn ipod...

    Do I have a janky ipod??
     
  2. stainlessliquid macrumors 68000

    Joined:
    Sep 22, 2006
    #2
    I have a few albums that are invisible that used to not be invisible. I think its iTunes doing it and not the ipod, since they only turned invisible after doing stuff in itunes.
     
  3. itsliz89 thread starter macrumors member

    Joined:
    Sep 9, 2008
    Location:
    california
    #3
    So we're going to have to live with it until an update comes out? How long do those usually take? I'm so anal about album artwork and seeing a Britney Spears photo randomly show up for a Jack Johnson song is making me go bonkers.

    Coincidentally, the charger for my macbook is ripping with fiber things sticking out and my macbook is having errors updating and installing firmware. I'm having the worst luck with Apple products all of a sudden >:[
     
  4. Darkroom Guest

    Darkroom

    Joined:
    Dec 15, 2006
    Location:
    Montréal, Canada
    #4
    you don't have to live with anything... have you tried erasing / reformatting / restoring? try that...

    if that doesn't work and if it's a recent purchase from apple: you're covered under warranty, so you can take it back to the apple store and have it fixed. or, if it's within 2 weeks of purchase, you can take it back for a quick exchange so you don't have to wait for fixing.
     
  5. Strategy macrumors member

    Joined:
    Jul 13, 2008
    #5
    I have this same problem, about 10 of my albums have the a black box for the album artwork and dont show up properly in cover flow.
     
  6. granavefenix macrumors newbie

    Joined:
    Sep 18, 2008
    #6
    I suggest you to take the tracks with black cover album problem, and erase all the artworks of each song, then close the itunes, re open it, and add only the desired artwork. It worked for me. I was upset like you say you are.
     
  7. guywoodman7 macrumors member

    Joined:
    Jan 28, 2008
    Location:
    New York
    #7
    I had this same issue a while back. It took me a bit of experimenting but I finally figured it out.

    In my scenario, I was hitting up Amazon to nab artwork for albums iTunes did have (like radiohead) and I was saving their artwork directly from their site and loading it into iTunes. These saved files tended to be .jpeg files. It would normally show up in iTunes, but when I synced to my iPod it was there sometimes, and absent other times.

    The solution I found was, instead, using Mac OS X's screenshot utility (Command + Shift + "4") and marqueeing the album artwork and THEN applying it into iTunes. By default this creates a PNG file which iTunes AND the iPod seems to like MUCH more.

    There is one unknown in this equation however. There were a few times where I would make my own album artwork in Photoshop for whatever reason and SAVE as a .png from Photoshop and I had the old .jpeg problem I initially wrote about. I don't know why that was faulty, but then I just started taking screen shots of my Photoshopped custom artwork, and again, worked every time!

    So, if your using OS X, give that a shot! If your using something else, try saving the artwork as a .png file and hopefully you'll have better luck.
     
  8. itsliz89 thread starter macrumors member

    Joined:
    Sep 9, 2008
    Location:
    california
    #8
    I deleted the album artwork with black screens and applied the desired artwork. I checked my ipod and saw that instead of the black screen, there was now that music note image. Woo hoo, some progress? Then I realized that I did not close itunes as you had said.

    So, I deleted the album artwork again, closed itunes, reopened it, applied the desired album artwork, checked my ipod, and it's back to a blank black screen.

    I love how inconsistent itunes is! :rolleyes:
     
  9. itsliz89 thread starter macrumors member

    Joined:
    Sep 9, 2008
    Location:
    california
    #9
    That sounds convenient...

    But doing all that would point the cause at the ipod no? It sounds like I'm not the only person having problems with itunes 8.0. I've read that problems emerged only after people have "upgraded". I didn't figure that out at first since I got a new device and just upgraded from a really old version because of it. I didn't really have a before to compare with.

    I hope it's an issue with itunes rather than the ipod itself. That would suck.

    I wish I could downgrade to an older version to see, but nope, I HAVE to use 8.0! :)
     
  10. itsliz89 thread starter macrumors member

    Joined:
    Sep 9, 2008
    Location:
    california
    #10
    I at first thought that you meant the Grab application, which saves my images at Tiff. I tried it anyway and there was a bit of progress. At least the album art was showing somewhere...

    http://img216.imageshack.us/img216/8744/photo44qb2.jpg

    But still blank black screen:

    http://img367.imageshack.us/img367/6625/photo45bd1.jpg

    So I tried exactly as you said with the :apple:, shift, 4 and got a png file. Applied it to the album and it worked!

    Then I realized that album artwork oozing onto other unrelated albums.

    http://img146.imageshack.us/img146/9126/photo46at3.jpg

    I continue, same process, and success again!

    http://img205.imageshack.us/img205/4556/photo47fo5.jpg

    Just as I was about to conclude that itunes or my ipod is prejudice against anything not png, I tried it once more for the next album and...

    http://img502.imageshack.us/img502/9606/photo48sm1.jpg

    It wiped out the art for the previous album. That one is back to black again.

    edit: I just noticed something. This album is blank:
    http://img217.imageshack.us/img217/9306/photo43zl5.jpg
    But just as I flipped the ipod...
    http://img207.imageshack.us/img207/796/photo44js7.jpg
    Hi artwork! Why you hiding?


    Although the artwork did not show up for the latest album attempt in the album list, it did show up in individual songs:

    http://img171.imageshack.us/img171/1211/photo49tn0.jpg

    I can't have it all...
     
  11. itsliz89 thread starter macrumors member

    Joined:
    Sep 9, 2008
    Location:
    california
    #11
    OKAY. New discovery. I used guywoodman7's technique again and again and it seems to work. I don't know why it wiped out the info for the previous album that one time. HOWEVER, I have to apply artwork to the album twice for it to work. It's weird! I select all the songs, go to get info, and apply the PNG artwork to them all. When I go to check my ipod, nothing. But when I do the exact same thing for a second time, it shows up on the ipod. I've been doing this for about 4 albums so far and it seems to be the trend. I have to do it twice to work.

    So stupid... :mad:
     
  12. txhockey9404 macrumors 6502a

    Joined:
    Feb 25, 2008
    #12
    Mine is doing the exact same thing, but it is mixing up mostly Music Video artwork and Music artwork (Although I do have the Anchorman cover for one of my albums). I am using 2.1 and iTunes 8.0, but I had this exact problem on 1.1.4 and iTunes 7.7.?. So, I am convinced that it is the iPod, because between 1.1.4 and 2.1, I have restored about 15 times, sometimes it works ok, sometimes not. It is really angering me that I have to leave my iPod for a full 10 hours while it restores and reloads music every 2 weeks.(Since 2.0, that has been the average). I made a report at the Apple Store with 1.1.4, and I am going back Monday to try to see if they can actually help me. The guy I had for 1.1.4 found it odd and interesting that not only was my artwork messed up, but my Music app would sometimes morph into the iPhone iPod app. A $400 iPod should NOT have this many problems, and although some are forgivable since I purchased a 1st generation product, the amount I have had is beyond what most people would call reasonable. My warrantee is up in a week, so I am going to see if I can get help one more time before I am completely stranded.

    I will report back if anything happens. I am convinced that it is not just a software issue because it disappereared from my iPod for about 5 months, then returned exactly the same. (If I put my House episodes back from the 1.1.4 install, I might also become infected with House album artwork)
     
  13. itsliz89 thread starter macrumors member

    Joined:
    Sep 9, 2008
    Location:
    california
    #13
    I'm going to the apple store too to see what's up. Again, I really hope it's an itunes issue. I need to know for sure though since I can't risk the time to lounge around waiting for an itunes update.
     
  14. txhockey9404 macrumors 6502a

    Joined:
    Feb 25, 2008
    #14
    I am going to the Genius Bar on Monday, so I will report back with my findings. I sure hope he/she knows how to fix this.
     
  15. txhockey9404 macrumors 6502a

    Joined:
    Feb 25, 2008
    #15
    So, the guy at the Genius bar said this:

    1. restore iPod-done before
    2. reinstall iTunes-done before
    3. Check album artwork in iTunes-done before
    4. Delete the Album Artwork Folder in your iTunes folder. -didn't do this one (restoring iPod now to see if it fixes problem, if not back to Genius bar with iPod, iMac, External HD) UGH!

    This better work. At least the guy was very pleasant and helpful. Hope this advice can save some of you from a trip to the Apple store.
     
  16. stainlessliquid macrumors 68000

    Joined:
    Sep 22, 2006
    #16
    Are you applying the art to the songs on the ipod or the songs on your computer and then redragging them to the ipod? The ipod doesnt seem to like it when you add art or change tags to files directly on it.
     
  17. txhockey9404 macrumors 6502a

    Joined:
    Feb 25, 2008
    #17
    No, I am changing them on the computer. I do automatic syncing, not manual.
     
  18. txhockey9404 macrumors 6502a

    Joined:
    Feb 25, 2008
    #18
    OK. That method seemed to work, but I have not used my iPod much since then. The album artwork is all correct except for 1 album which I will check in iTunes (oddly enough, it worked on the previous install). IDK, but if that 1 album is an early symptom of the same disease, I have to make another appointment with a Genuis, but this time, the iMac, External HD, and iPod get to tag along. Talk about a pain in the a$$.
     
  19. itsliz89 thread starter macrumors member

    Joined:
    Sep 9, 2008
    Location:
    california
    #19
    I'm manually uploading directly onto the ipod. It's how I've always done it with my ipod video 1g and ipod nano (when the red first came out?). Never had a problem with any of them, however the ipod touch is just clashing when it comes to manual artwork uploads. Someone told me to add the music into itunes library, have itunes get the artwork themselves rather than me looking for one on google, and then drag it into the ipod. This has worked. I hate having itunes make extra copies though. I'm very very anal when it comes to organization of files on my notebook. Multiple files are a no no! It's a change in habit for me, but I guess it'll have to do.

    Even though the problem is slightly "fixed", there still poses the threat of not being able to upload artwork manually. What if I have music from an artist unknown to itunes? Not that I do right now, but it's something to consider.

    Also, I'm not liking how inconsistent this whole itunes, ipod, or whatever process is. Stainlessliquid, you say that ipods don't like it when you do things directly onto it. Why is that? Ideally, it should work shouldn't it? Software bug or something??

    I was going to go to the genius bar today, but I forgot my ipod...
     
  20. Ivan P macrumors 68030

    Ivan P

    Joined:
    Jan 17, 2008
    Location:
    Home
    #20
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 2_1_1 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5F138 Safari/525.20)

    It isn't iTunes. I had the same problem with the 1.1.3 firmware in iTunes 7.7. Luckily a couple days later a firmware update came out which fixed it for me.
     
  21. Gix1k macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
    #21
    I am having this issue and it is driving me crazy. My work PC has IT8 and my home PC has IT7...I can add images on IT7 and it stays with my 1st gen IPT, but if I bring to work and add an album using IT8, I get a black box. I am highlighting all the songs, right clicking, get info, and dragging .jpeg to artwork box. Worked like a charm..Now I have a 2gen IPT and I MUST use IT8, I have 67 albums on it and like 30 have black screen....I have manually applied the image back to each of them more times than I want to and it is pissing me off....why on earth is this not working....I'm using Windows, so the solution found by guywoodman will not work for me....Ideas??


    **screaming**


    Here is mine.....

    [​IMG]

    See black box.....a few of them...notice one with arrow.
    [​IMG]

    This is the album with the arrow...So the art is there, but does not appear correctly....WTH!

    [​IMG]
     
  22. txhockey9404 macrumors 6502a

    Joined:
    Feb 25, 2008
    #22
    If you don't mind manually re-adding all of your songs, you could try the method that the Genius gave me before you make another appointment. First, take a screenshot of all your screwed up album covers and copy them to your computer for proof in case you should need to return to the Genius bar.
    1. Close iTunes
    2. Go into /Users/(Your Username)/Music/iTunes/ then, delete the folder Album Artwork (be sure to empty your trash)
    3. Reopen iTunes
    4. Check album artwork and get album artwork from iTunes
    5. Get all other album artwork, but save it as a .png (use a screenshot)
    6. Restore iPod NOT from backup
    7. Put music back-see if it works
    8. If not, make a Genius appt.



    Follow the directions for itsliz89, but when you are at #2, your Artwork folder should be in Documents and Settings/(Username)/My Documents/My Music/iTunes (XP)
    IDK what it is for Vista (haven't used it much yet)

    For #5, use this app to save as a a .png (you will need the Microsoft .NET framework for it to work)

    You will also want to not jailbreak when you restore to rule out that as a possibility for your problems.
     
  23. Gix1k macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
    #23
    OK.....OK!!!! I figured it out. Here is what I did. Every CD that had a black box. I highlighted all songs, right click, get info. I check the artwork box with nothing in it. It goes through all the songs...I close iTunes...I open it again....select all songs that now have a what music symbols instead of black box on iPod....right click, get info....drag my .jpeg to box....hit ok. It goes through all the songs again and BAM...artwork is there....stays, too.


    POS apple crap!!!
     
  24. Gix1k macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
    #24
    OK......just finished ALL my albums...Get this crap...All of the images show from both views...On the landscape view I can see an album cover....when I get to it...it's black...I scroll past it to next album and the one that was just black appears again...if you select it...black. I'm so ready to slam this on the concrete. :mad:
     
  25. itsliz89 thread starter macrumors member

    Joined:
    Sep 9, 2008
    Location:
    california
    #25
    Boy do I know that feeling. I must say that I was a lot happier without the ipod touch! The messed up album art frustrated me like no other. I would only expect such performance from a cheap bootleg device. Anyway, are you adding the songs and albums directly onto the ipod? Maybe try adding to the library, then onto the ipod. I've always added directly onto my past ipods, and it's always worked. However, not with the touch. I guess because it has to deal with coverflow, an album list, and individuals songs; three locations for album art instead of one and more room to mess up.

    Isn't it interesting how we have to download separate programs, go through a list of procedures, etc over something that should be easily working in the first place?
     

Share This Page