Echo issues with Webcam (C920) and FaceTime

Discussion in 'Mac Accessories' started by Lorenzo F, Dec 25, 2014.

  1. Lorenzo F macrumors member

    Joined:
    Sep 13, 2014
    Location:
    Oakland, CA
    #1
    I bought a Logitech C920 webcam for my late 2014 Mac Mini. When I make FaceTime calls to friends, they tell me that they get a lot of echo of their own voice. I use external speakers and after some testing, find it likely that their voice is coming out of these speakers and going back into the built-in microphone of the C920.

    I bought the Logitech on the recommendation of what I had read on various reviews and forums, including here. Clearly there are others who use the C920 and other webcams successfully with FaceTime.

    Advice, anyone?
     
  2. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #2
    I have the same camera and experienced the same echo's as well. I use it on either a MBP or an iMac. What I do is tell FaceTime to use the built-in mic and use the C920 for video. That solves it.

    I assume that by using the built-in mic, OS X can manage the noise canceling between it and the speakers.
     
  3. Lorenzo F thread starter macrumors member

    Joined:
    Sep 13, 2014
    Location:
    Oakland, CA
    #3
    I don't believe the 2014 Mac Mini has a built-in mic. If I bought an external mic and connected it to one of the USB ports, would that solve my problem?
     
  4. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #4
    Hmm.. I'm not sure. The camera is also an external mic, so I don't know how a different one would correct the issue.

    Have you tried adjusting settings in Sound under System Preferences?
     
  5. Lorenzo F thread starter macrumors member

    Joined:
    Sep 13, 2014
    Location:
    Oakland, CA
    #5
    yes, I tried adjusting the Input volume for the webcam in System Preferences. I also tried adjusting my external speakers. And I tried using the internal speakers on the Mac Mini instead of the external speakers. None of those methods worked, unfortunately.

    I don't have the ability to adjust the external mic settings for the C920 in System Preferences in Yosemite. There is a Logitech app, but that doesn't appear to allow me to adjust the sound settings for the webcam, only the video settings.
     
  6. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #6
    I guess I'd contact Logitech Support and see if they have any suggestions.
     
  7. Lorenzo F thread starter macrumors member

    Joined:
    Sep 13, 2014
    Location:
    Oakland, CA
    #7
    Ok thanks SandBoxGeneral. I may also try the C615 which is officially supported for use for Mac by Logitech. The C920 is not officially supported, but I'm not sure why this would make a difference necessarily. I will see.
     
  8. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #8
    If you get an answer from them, do post it back here; I'd be interested to hear what they say.
     
  9. itcrashed macrumors regular

    itcrashed

    Joined:
    May 4, 2010
    #9
    You're not alone. This is why so many resort to wearing a headset to completely isolate the audio from the mic.

    If you can't wear a headset...
    Bring down the mic to the lowest useable sensitivity and then attempt to point your speakers away from the direction of the camera/mic.
     
  10. Lorenzo F thread starter macrumors member

    Joined:
    Sep 13, 2014
    Location:
    Oakland, CA
    #10
    Yikes. Because I also have an iPhone and iPad, the thought never occurred to me that getting a Mac Mini would mean that I don't have built-in, engineered background noise cancellation.

    One of the reasons I was excited about getting a separate webcam is that the field of view is larger, so that I can accommodate others in my family with me while doing FaceTime with other relatives.

    Hmmm...
     
  11. BinilV macrumors newbie

    Joined:
    Feb 4, 2015
    #11
    Has anyone found a better solution to this? Picked up the C920 because I thought it was a great solution to my webcam issue with the mac mini.. but the echo is very frustrating with facetime calls. Also having an issue when answering phone calls (through continuity) on the mac mini where the person calling can't hear me. Anyone else having that issue?
     
  12. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #12
    You may try using a separate external microphone. I use a Blue Yeti and it works very well.
     
  13. Lorenzo F thread starter macrumors member

    Joined:
    Sep 13, 2014
    Location:
    Oakland, CA
    #13
    Hi all, didn't mean to leave you hanging, especially SandBoxGeneral!

    I ended up getting the Logitech C615 for my Mac Mini...and it worked! Facetime works seamlessly; there is no more echo. Why? The only explanation I can find is by comparing the C615 and C920 on Logitech's website:

    http://www.logitech.com/en-us/webcam-communications/webcams?a1=1&a2=2&a3=3&a4=4&compproducts=9442%2C8041&view=34

    The main difference I can see is that the C615 has an echo-canceling microphone while the C920 does not. For what it's worth, it also appears that the C920 has a noise-canceling microphone while the C615 does not.

    Hope this helps others, particularly BiniIV.
     
  14. iamtheonlyone4ever macrumors regular

    iamtheonlyone4ever

    Joined:
    May 27, 2016
    #14
    i know this is an old threat but i know what causes this issue and how to fix it, i can't let c920 look bad, so here it is go to utilities - audio mdi setup
    look for c920 and change the format to the highest option available
    now try it and it will sound good, like it normally does
    i wrote this tutorial like 2 years ago in some other forum and all the users got the camera working good
    i know this is an old threat but i wrote the answer for future references
    sorry for my bad english
     
  15. kingkassis macrumors newbie

    Joined:
    Dec 19, 2016
    #15

    Hi there, do you have solution for this on a mac running MacOS Sierra? You solution seems to be for PC, the original poster had this issue with the c920 on a mac using FaceTime which is precisely what I am experiencing.
     
  16. boast macrumors 65816

    boast

    Joined:
    Nov 12, 2007
    Location:
    Phoenix
    #16
    Audio MIDI Setup is a built-in app in macOS.
     
  17. iamtheonlyone4ever, Dec 19, 2016
    Last edited: Dec 19, 2016

    iamtheonlyone4ever macrumors regular

    iamtheonlyone4ever

    Joined:
    May 27, 2016
    #17
    it is the same thing, except that i did it on a hackintosh instead of a real mac but is the same process, right now i'm running sierra 10.12.2 and the method still works
    --- Post Merged, Dec 19, 2016 ---
    sorry for the typo
    is not audio mdi setup
    is Audio MIDI Setup
    just like boast mentioned

    simply change 16,000 for 32,000 and problem solved
    here are some pictures
    after you do this then try face time again
    [​IMG]


    [​IMG]
     
  18. mercan macrumors newbie

    Joined:
    Dec 20, 2016
    #18
    I'm using C920 on my hackintosh.C920 is work without eco problem with Skype. Problem only on facetime. And i've applied midi setup but It doesn't work.
     
  19. kingkassis macrumors newbie

    Joined:
    Dec 19, 2016
    #19
    Thanks a lot. But this fix did not work for me. When I went to the Audio MIDI Setup (see attached) the format for the C922 was already set to 32,000 Hz the highest setting. Still getting the echo. Are you sure the c920 has echo cancelling capability? My MAC mini is connected to external speakers through the headphone jack out.
     

    Attached Files:

  20. mercan macrumors newbie

    Joined:
    Dec 20, 2016
    #20
    This solution did not work for me either. I think C920 is not capable of echo fix and Skype has own echo cancelling feature.
     
  21. iamtheonlyone4ever, Dec 20, 2016
    Last edited: Dec 20, 2016

    iamtheonlyone4ever macrumors regular

    iamtheonlyone4ever

    Joined:
    May 27, 2016
    #21
    ok maybe is something else somewhere, i skipped the part about input and outputs because i figure that most likely you already have that part set up. i was going to mentioned but i didn't want to over complicate things also my english is not perfect

    this is what i mean about input and outputs

    the C920 has it own microphone, so you have to go to system preference - sound
    and go to the input tab and select the microphone from the C920 camera
    no the microphone from you Mac
    so make sure you are not getting mix with the settings there
    just make sure you have the right one selected

    this also has to be done in face time
    video tab - microphone
    select c920 microphone instead of mac microphone
    you can also do it backwards if for some reason still doesn't work for you

    don't use the camera microphone and use the MAC microphone
    something very important is to not set the mic volume too high

    if you still get the echo problem with your mac mic then the problem is not the camera mic because it also happens with the mac mic

    i'm sure it has to be a setting configuration problem somewhere
    check face time and Skype input and output settings and make sure everything is correct
     
  22. mercan macrumors newbie

    Joined:
    Dec 20, 2016
    #22
    @iamtheonlyone4ever The settings you recommended are correct. But there are other factors. Problem is C920 can't handle echo cancel.. check this message:
     

Share This Page