El Capitan has broken Mail

Discussion in 'OS X El Capitan (10.11)' started by DP812, Oct 13, 2015.

  1. DP812 macrumors regular

    Joined:
    Aug 13, 2009
    Location:
    Japan
    #1
    Since upgrading to El Capitan yesterday, Mail has been a total nightmare to use. It started with it crashing every time I opened it until I found a tip to disable all the email accounts and then re-enable only one, let it download all emails, then repeat the process until all the accounts were enabled.

    That worked for about twenty-four hours. But now, I'm having a whole host of issues. Now whenever I open Mail, it slows my entire computer down to a crawl before everything just completely freezes. I've tried the disable/re-enable trick, but that doesn't work. I only managed to re-enable one account before my Mac completely froze up again.
     
  2. Eduardot macrumors member

    Joined:
    Mar 30, 2013
    #2
    Same happened to me, so i got my Time machine backup and returned to yosemite.
     
  3. stereo247 macrumors newbie

    stereo247

    Joined:
    Oct 9, 2014
    #3
    Oh apple what have you done (again)!!
    Its as though every time these fools update and "improve" OSX they bust up mail. Currently I can't get gmail or iCloud to run properly in mail either - only exchange runs quite ironically.

    It won't download or sync or delete any emails.

    For the biggest company in tech this is actually just a poor show. I will be using the web browser interface or downgrade to Yosemite by the weekend if this gets on my nerves too much. I wish instead of coming out with the latest gimmick they actual do proper beta testing and bring out a working product.

    I have other problems with 10.11 I won't mention. Apologies for the rant (thread jacking).
     
  4. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #4
    Mail has been running fine for me. Google, iCloud and Exchange have all been working flawlessly on 10.11.
     
  5. stereo247 macrumors newbie

    stereo247

    Joined:
    Oct 9, 2014
    #5
    So what would you suggest Simon?
     
  6. Queen6 macrumors 603

    Queen6

    Joined:
    Dec 11, 2008
    Location:
    Enjoying Better Things
    #6
    That`s far for my experience of Mail 9.0 & OS X 10.11.0 just a mess nor am I alone with issues related to Mail

    Q-6
     
  7. IndyBob macrumors member

    IndyBob

    Joined:
    Sep 23, 2012
    Location:
    Indianapolis
    #7
    I updated Saturday and mine is working just fine. iCloud, Exchange and Gmail.
     
  8. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #8
    I'm not saying you're the only person(s) with issues, all I'm saying is that's my experience. 10.11 has been running very well on my late 2011 MBP. I still have a spinning HD in my laptop. I also did a clean install of the GM then update to Public so not sure if that has anything to do with it. I typically do clean installs anytime there is a major rev (i.e. From Lion to Yosemite, Yosemite to El Cap). Also, I've always used Thunderbird for my email, as Mail always gave me probs in previous releases. For whatever reason, Mail has been quite stable this time around so I'm going to stick with it. I'm trying to use as much of the Apple ecosystem as possible.
     
  9. Queen6 macrumors 603

    Queen6

    Joined:
    Dec 11, 2008
    Location:
    Enjoying Better Things
    #9
    Sure, don't get me wrong there are likely more who have had no issue, however for those of us that do/have it`s incredibly frustrating, and in some cases very time consuming. In general I have not had any major issues with an OS X OS upgrade, until 10.11 as I prepare the system prior to the upgrade.

    A clean install is not strictly necessary, the way OS X functions, equally it does help to reduce the OS footprint etc. For me a clean install will require several days of work to bring the system back up to the same level, right now I am more inclined to do a clean install back to 10.10.5 as the more time I spend with 10.11 the more buggy it appears.

    A good friend of mine always stays a full OS X version behind, which I am starting to think is "wisdom" he still gets regular updates, the OS is well developed, he very rarely has any issue. Given Apple`s overly ambitious 12 month cycle for OS X, his "mantra" is making more sense by the day...

    Q-6
     
  10. leman macrumors 604

    Joined:
    Oct 14, 2008
    #10
    Mail actually works better for me with gmail than it ever has. Before Mavericks, gmail setup was always a hassle, with Mavericks and Yosemite I had these mail blackouts. El Capitan just simply works.

    I recommend you deleting all your account data, reseting mail and synching again. Maybe there is some weird config that got stuck. Also, check whether gmail might have blocked your computer from connecting.
     
  11. kemperman macrumors regular

    kemperman

    Joined:
    Jul 15, 2009
    Location:
    UK
    #11
    so my mail issue is a different one to those already posted... When scrolling to the top of any mailbox, where it would normally have the 'rubber band' animation the messages just continue to scroll down with a white space above. Also, when I try to scroll through a specific message using my magic mouse, it just continues to scroll all messages even if i have clicked onto that message (but not opened a new window). It's very odd!
     
  12. Queen6 macrumors 603

    Queen6

    Joined:
    Dec 11, 2008
    Location:
    Enjoying Better Things
    #12
    Try booting into safe mode, as this cleans up many caches. Equally the way OS X is going "Voodoo dolls" may be a viable alternative....

    Q-6
     
  13. Allthings-I macrumors 6502

    Joined:
    Jul 25, 2014
    #13
    Anyone know how to group emails by sender? It seems since upgrading to El Capitan, all my emails are now showing up as individual. In Yosemite and all older, my emails were grouped by sender across all mailbox.

    Please advise.
     
  14. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #14
    Are trying to group by sender or group by conversation?
     
  15. DP812 thread starter macrumors regular

    Joined:
    Aug 13, 2009
    Location:
    Japan
    #15
    When I chatted with Apple Support, they suggested I reinstall El Capitan, which of course did nothing. But fortunately, someone on the Apple Support forums had a solution. This completely worked for me and hopefully it will work for others who are having this problem:

    https://discussions.apple.com/message/29120087?ac_cid=op123456#29120087

    Step 1 is the only one I needed to do and then the problem was solved.
     
  16. JustinBW macrumors member

    Joined:
    Oct 5, 2009
    #16
    Try holding shifting when starting the app (and continue to hold for a few seconds after the app starts) if you are experiencing freezes at startup.

    There were major issues with Mac Mail an 10.10, and it usually had something to do with users having multiple (3+) g/email accounts in the app.
     
  17. matrix07 macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #17
    Can't register Exchange account. Says "unable to verify account name or password" though both are correct (checked by logging in on the web). iCloud and gmail are fine. Anyone has solution?
     
  18. LCD macrumors member

    Joined:
    Dec 28, 2012
    Location:
    USA
    #18
  19. DP812 thread starter macrumors regular

    Joined:
    Aug 13, 2009
    Location:
    Japan
    #19
    Tried it, didn't work. The solution I posted above did.
     
  20. Rhinoevans macrumors 6502

    Joined:
    Oct 5, 2012
    Location:
    Las Vegas, NV
    #20
    Sa
    same
     
  21. MrNomNoms macrumors 65816

    MrNomNoms

    Joined:
    Jan 25, 2011
    Location:
    Wellington, New Zealand
    #21
    Clean install, clean install, clean install - oh, and don't install third party crap that hacks and relies on private api's.
     
  22. djsound macrumors 6502a

    djsound

    Joined:
    Dec 4, 2006
    #22
    mine is screwed too.......everytime i open it it says that the certificates are not valid or whatever for all my accounts....ive adjusted everything and it was fine then again starting today....same thing. We need a fix...
     
  23. Allthings-I macrumors 6502

    Joined:
    Jul 25, 2014
    #23
  24. CTHarrryH, Oct 18, 2015
    Last edited: Oct 18, 2015

    CTHarrryH macrumors 65816

    Joined:
    Jul 4, 2012
    #24
    I can't see my folders under my GMAIL account - they still exist - can see on iPhone and iPad and in web GMAIL - just not on mail app - used to before El Capitan;


    UPDATE - I deleted the GMAIL account and re-added and folders now show up
     
  25. Helmer77 macrumors newbie

    Helmer77

    Joined:
    Oct 24, 2015
    #25
     

Share This Page