Error 1 while restoring custom pwnaged iOS 4.3 ipsw to iPhone 4

Discussion in 'Jailbreaks and iOS Hacks' started by Patosh, Mar 20, 2011.

  1. Patosh macrumors newbie

    Joined:
    Mar 20, 2011
    #1
    Hi all,

    I've been trying to jailbreak a new ATT iPhone 4 for the last several hours with no luck. Unfortunately I'm stuck with iOS version 4.3 (don't have SHSHs for previous versions).

    I'm a Mac user, and followed the steps outlined in this article:
    http://www.iphonefirmware.com/2011/...reak-ios-4-3-gm-on-iphone-4-using-pwnagetool/
    I tried using both the listed version of Ramdisk Fixer (1.5) and the new one (1.6) which I was pointed to while building the custom ipsw in Pwnage 4.2.

    I got everything working, except I'm unable to restore the custom ipsw (iPhone3,1_4.3_8F190_Custom_Restore.ipsw) from iTunes.

    I tried editing the hosts file, commenting and uncommenting the lines for Apple's server:
    #74.208.10.249 gs.apple.com
    #127.0.0.1 gs.apple.com

    When both lines are commented (as shown above) I keep getting Error (1).
    When I uncomment the first line (points to Cydia's server) I get Error (1600).

    The whole point why I'm trying to jailbreak the phone is because I relocated overseas and I need to unlock the phone in order to use a local carrier. But I don't think there's any way to unlock an iPhone without jailbreaking it first.

    Any ideas or suggestions of what may be going wrong are greatly appreciated.

    These are the details of my device:
    iPhone 4
    Model MC318LL
    iOS Version 4.3
    Modem firmware: 04.10.01

    Thanks.
     
  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #2
    Don't do anything. Just restore as normal your iPhone. Stop trying to jailbreak it. If you were at 4.3.0 from the start there is no easy way right now. Just wait. Go back to stock.
     
  3. Patosh thread starter macrumors newbie

    Joined:
    Mar 20, 2011
    #3
    @jav6454

    Thanks for your reply. Any ideas on how long it usually takes the dev teams to release an unthetered jailbreak after an iOS release?

    Also, I'm not familiar at all with basebands... Should I leave mine as is or is this something I need to upgrade as well?

    Thanks again.
     
  4. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #4
    Nobody knows when a untethered JB will be release, except people working in it and they don't usually say before hand.

    And, even if there was a JB, you still would have to wait for a unlock for your new 4.10 baseband. And, that takes much longer. The 2.10 (OS 4.1) and 3.10 (OS 4.2.1) baseband still haven't been unlocked.
     
  5. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #5
    There is a jailbreak already, but it is beta (as in it requires command line style steps and other very technical steps) and it is a tethered approach (as in rebooting requires to be hooked to your computer).

    As per baseband, if your iPhone was at 4.3.0 or 4.2.1 or 4.1.0 from the start, you were already out of luck. Only the baseband from 4.0.0 has been unlocked and only users who kept that baseband can unlock.
     
  6. Prodo123 macrumors 68020

    Prodo123

    Joined:
    Nov 18, 2010
    #6
    I had a similar error, and it turned out to be very easy to fix. Download iReb, and put your iPhone to Pwn-DFU mode with it. It has the instructions. Also, download TinyUmbrella just in case this doesn't work and you have to kick your phone out of recovery.
    After iReb does its magic and your phone's in Pwn-DFU mode, head over to iTunes and restore to the JB IPSW. It should work; if it doesn't, try saving the SHSH blobs via TinyUmbrella without Cydia, and try this again with the TSS server running.

    EDIT: DO NOT JAILBREAK! YOUR BASEBAND CANNOT BE UNLOCKED!! IF YOU DID UNLOCK IT YOUR PHONE CAN SCREW UP!
     
  7. Patosh thread starter macrumors newbie

    Joined:
    Mar 20, 2011
    #7
    Thanks to all for the replies.

    I think it all comes down to 2 options now:

    1. Wait for a more stable (hopefully unthetered) jailbreak for iOS 4.3
    2. Try to find a custom ipsw for iOS 4.2.1 online and try to restore it on my phone.

    I'm not sure whether 2 is really an option, as I'll probably have issues with the signing of the device.

    I'll update once I have new info, thanks again.
     

Share This Page