Error 21, 1601 Will not restore iPhone 3G

Discussion in 'Jailbreaks and iOS Hacks' started by marker227, Dec 7, 2008.

  1. marker227 macrumors 6502

    Joined:
    Mar 29, 2004
    #1
    Here's what I did... I was going from 2.1 to 2.2.


    1. I hit restore and update from iTunes. My JB iPhone 3G was restored and whipped clean and then updated.

    2. I used the new pwnage to make an ISPW.

    3. I put the phone into DFU mode and tried to restore with iTunes.

    4. iTunes errors out saying Error code 21, 1601.

    I started from scratch. I set the phone up as a new phone and everything.


    What should I do?
     
  2. calvy macrumors 65816

    Joined:
    Sep 17, 2007
    #2
    Try it this way. Turn the phone off, unplug it from the computer, hold down the home button and continue to hold it down while plugging the phone back into the computer. Wait until you get the "connect to itunes" message and try again with the jailbroke ipsw.
     
  3. marker227 thread starter macrumors 6502

    Joined:
    Mar 29, 2004
    #3
    I keep getting Error 21.

    I can restore and completely activate the phone with the stock firmware, but the pwn firmware gives me a Error 21 code.

    Custom firmware will not restore...

    Is it because I didn't move the bootloaders into my pwnage folder?
     
  4. Four20 macrumors 6502a

    Four20

    Joined:
    Sep 22, 2007
    #4
    go and delete the ipsw file and redownload it(maybe manually. . .or let itunes download it. . .at least try both)

    I hear 1600 errors are from corrupt ipsw files. it's too bad that apple doesn't supply a hash to verify this
     
  5. marker227 thread starter macrumors 6502

    Joined:
    Mar 29, 2004
    #5
    I don't need iTunes to download it automatically. I have it already...

    I'm saying I can't JB anymore to 2.2. I'm on 2.2 Original Firmware from iTunes.

    How do I successfully JB without an error code?
     
  6. marker227 thread starter macrumors 6502

    Joined:
    Mar 29, 2004
    #6
    Okay, so I've started over.

    I have a non-jailbroken iPhone 3G with the current version of Pwnage and Quickpwn. I downloaded the 2.2 IPSW.

    I am on 2.2 with my iPhone.


    How do I jailbreak without receiving an error code?
     
  7. The General macrumors 601

    Joined:
    Jul 7, 2006
    #7
    QuickPwn
     
  8. marker227 thread starter macrumors 6502

    Joined:
    Mar 29, 2004
    #8
    Quickpwn will NOT work. It says "The firmware you have is not supported. Please check our website."
     
  9. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #9
    Error 21 or error 1601 means there is something wrong with your USB connection or with the communication between iTunes and the iPhone.

    Best thing is Restart iTunes and then retry. If this doesn't help go ahead and restart your Mac.

    If that won't help, restore to a stock .ipsw and then try again with your phone in DFU. Takes a while sometimes.
     
  10. marker227 thread starter macrumors 6502

    Joined:
    Mar 29, 2004
    #10
    The funny thing about that is, I don't have any problem when I'm restoring to stock firmware or syncing with stock firmware. I already tried unplugging the USB connection and putting it back in (it's directly plugged into the computer). I restarted the computer before and iTunes...

    How do I jailbreak if I can't use quickpwn? I have pwnage, but I don't think I placed the bootloader folder in the right spot which I got from a site that had the current pwnage.

    I have a "iPhone1,2_2.2_5G77_Restore.ipsw" that I can use in Pwnage...


     
  11. mlemonds macrumors 6502a

    mlemonds

    Joined:
    Apr 9, 2008
    Location:
    Lexington, KY
    #11
    you wouldnt happen to be using a aluminum macbook would you?
     
  12. marker227 thread starter macrumors 6502

    Joined:
    Mar 29, 2004
    #12
    No. Mac Pro.

     
  13. marker227 thread starter macrumors 6502

    Joined:
    Mar 29, 2004
    #13
    No good...

    I held option down and picked the IPSW that I just made.

    It says "could not be restored error 21"


    *update*

    2nd attempt. The phone is in recovery mode. I selected the custom IPSW again... It's attempting to restore.. The "Restoring iPhone Software" bar is moving.

    *update again*

    Damn.. It wasn't the custom firmware with cydia in it.. It was stock firmware :(. It did restore completely though.

    *update 3rd time*

    Held option and selected the PWNED firmware.

    Immediately when I select the JB firmware, it said error code 17.


    *4th attempt*

    Seems to be restoring with pwned firmware.

    Success. I corrected the problem when I made yet another new IPSW and put the phone into DFU mode.
     
  14. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #14
    Good to know everything turned out fine. Sometimes the problem is iTunes is too picky, so you must force iTunes to do stuff.

    That does the trick.
     
  15. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #15
    Wirelessly posted (iPhone 3G (white): Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5G77 Safari/525.20)

    I had the 1601 (?) error over and over again last night - I solved it by connecting the iPhone to my iMac through the keyboard USB plug, rather than through the powered hub I usually use.
     
  16. Bear Hunter macrumors 6502a

    Bear Hunter

    Joined:
    Aug 10, 2008
    #16
    You jailbreaking again?
     
  17. hughesdc macrumors newbie

    Joined:
    Dec 29, 2007
    #17
    I finally did! Error 21 GONE!

    I Followed instructions exactly. The problem was I was using a powered USB hub not the back of my computer. Worked perfectly when I did that.



     
  18. chiclops macrumors newbie

    Joined:
    Oct 8, 2008
    #18
    Finally fixed my "Error 21" problem... If you are getting "Error 21", then the problem is that you are ending up in Recovery Mode and not in DFU Mode. See here:

    http://thebigboss.org/guides/dfu-mode/

    Not sure if you can get into DFU Mode directly once your iPhone is in recovery mode, but what did work for me was to do a normal restore (to 3.0), then put the phone in DFU mode, then follow the instructions to downgrade to 2.2. Be sure to confirm you end up in DFU mode this time.

    Hope this helps others.
     
  19. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #19
    Errors in the 160x range are related to USB miscommunications or bad interface using USB.

    A simple change of ports or a restart of the machine clears the problem out.
     
  20. chiclops macrumors newbie

    Joined:
    Oct 8, 2008
    #20
    You should not use a USB Hub, because they are most of the time USB 1.1, not 2.0.

    I solved my 160x problem by restoring the firmware in BootCamp with iTunes 8.0.2 rather than the latest release. Parallels just mess it up because of the USB Connection (Mac/VM), you have to use BootCamp or a Windows machine.

    In BootCamp, it worked in the first time and my iPhone came back from the dead.

    I then restored the backup in Mac OS.

    All OK now.
     
  21. Pablissimo macrumors newbie

    Joined:
    May 5, 2009
    #21
    FIXED! I was having trouble restoring as well. I got error type 21 when in the "normal" recovery mode, and the iPhone was not recognized by iTunes in DFU mode.

    What I did to fix:

    Created a new user account in System Preferences:Accounts with administrator privileges. Restarted computer and logged into the newly created account. Then it all worked!

    Hope this helps someone.
     
  22. justsun macrumors newbie

    Joined:
    May 6, 2009
    #22
    Error 21, 1601, 1603, 2001

    Ha! Thanks to a bunch of smart people out there I was able to get my 3G 2.2.1 Pwned .ipsw installed! After 20+ attempts I found the issue was not my Pwn job but the recent Mac OSX update to 10.5.6.

    This is way above my head but again thanks to those in the know there is an Apple Developer page where you can revert to Leopard 10.5.5 which has a different usb driver that allows your MAC to recognize the iphone in DFU eliminating all the stupid errors and allowing you to update. Google iousbfamily-315.4-log.dmg for more information.
     

Share This Page