Error 3194 - this device isn't eligible for the requested build

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Zs1195, Jan 1, 2013.

  1. Zs1195, Jan 1, 2013
    Last edited: Jan 1, 2013

    Zs1195 macrumors newbie

    Joined:
    Jan 1, 2013
    #1
    I'm so so sorry for posting the same question as everybody else does, but the solutions that were given to them are not working for me.
    I've been trying to upgrade my iphone 3GS from ios 4.0 (jailbroken) to 5.1.1, since some applications require higher ios. The problem is whenever I tried to restore a pop-up comes up saying that my device isn't eligible for the requested build. I clicked the more information and these steps came out:

    1. Update to the latest version of iTunes.
    2. Check that your security or firewall software is not interfering with ports 80 or 443, or with the server gs.apple.com.
    3. Follow Troubleshooting security software. Often, uninstalling third-party security software will resolve these errors.
    4. An entry in your hosts file may be redirecting requests to gs.apple.com.

    I've done all of those steps correctly and the problem is still there. I've also searched in Google and Youtube and these solutions came out

    1. edit the hosts (adding "#" before 74.208.10.249 gs.apple.com) / (deleting the 74.208.10.249 gs.apple.com) / (changing 74.208.10.249 gs.apple.com into #127.0.0.1 gs.apple.com)
    2. restarting my imac
    3. changing the USB Port
    4. creating a custom IPSW
    5. using tiny umbrella (unchecking "set host to cydia on exit') - this is the most confusing step for me, as whenever I open tiny umbrella, the box is already unchecked

    I've done all of those steps TOO!!! and the problem is STILL there. I don't get it, am I the only one that still have this problem even after I did all of the resolutions??
    pleaseee HELP me!!!:(
     
  2. Tyler23 macrumors 603

    Tyler23

    Joined:
    Dec 2, 2010
    Location:
    Atlanta, GA
    #2
    Apple is not signing the 5.1.1 firmware anymore. Unless you have SHSH blobs saved for 5.1.1, you can not upgrade/downgrade, your only choice would be upgrading to iOS 6.
     
  3. Zs1195 thread starter macrumors newbie

    Joined:
    Jan 1, 2013
    #3
    thank you, but error 3194 is still there even when I'm trying to upgrade it to ios 6.. could it be that my device is broken?? :(
     
  4. morphojay macrumors newbie

    Joined:
    Jan 19, 2013
    #4
    Same problem Error 3194 IPAD 3 WIFI

    Hello I'm just new on this forum and I have a iPad 3 WIFI from my friend which has jailbreaked it with Rocky Racoon after that the iPad responds very bad on touches and the screen 's flikkering now and then. I thought ok then upgrade it to Ios 6.0 but y friend does not saved the blobs from the stock firmware which was originally on the IPad 3.

    So after many times and hours wasted I'm still getting randomly the errors below:
    error 3194 and Error 11.
    I also used Tinyumbrella Redsnow to restore a stock firmware ( says firmware does not work for this program)

    Thanks for the time.

    Sincerely Jay ( Newbie)
     
  5. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #5
    Is that the latest 6.0.1 or 6.0.0? You can only do the first, not the latter.
     
  6. iPhone Bits macrumors newbie

    Joined:
    Jan 20, 2013
    #6

    Place your device in DFU mode first then try to restore to OS 6 , post results
     
  7. divingstcon macrumors newbie

    Joined:
    Feb 2, 2013
    #7
    Please Help! Error 3194 while upgrading from 5.1.1 to 6.0.1

    I have no doubts this fix works for most of people... Similar had worked for me too some time ago, when I upgraded my wife's manufacture-unlocked iPhone 4 to Firmware 5.1.1.
    But now I am trying to upgrade the same phone to 6.0.1 on Mountain Lion, and tried to do many things: deleting any reference to apple.com or gs.apple.com, modifying the host address with numbers from different tutorials (tried 74.208.10.249 and 74.208.105.171), added and removed # in front of the line - still got en error!

    Can you, please, try to help, Geeks? This iPhone was bought legally from Apple UK :apple: online store being factory-unlocked, and was never JB'en. The error might come from my JB'en iPhone 3SG that I still use.
    I am puzzled :confused: as I have no problems upgrading iPad 2 and iPad Mini.
     
  8. brittag macrumors newbie

    Joined:
    Jun 15, 2011
    #8
    Apple wants you to only be able to restore to the newest available version of iOS for your device, so iTunes automatically asks Apple for permission before it installs an iOS version on your device. Error 3194 basically means "you don't have permission". If you try to upgrade an iPhone 4 to iOS 6.0.1 when iOS 6.0.1 is no longer the latest available version (in other words, no longer "signed"), iTunes gives you this error message. You have to restore to whatever the latest iOS version is instead.

    This "you don't have permission" error message also happens when people have modified hosts files as discussed earlier in this thread, because those hosts files are redirecting the checking process to saurik's servers instead of Apple's servers (in order to try to trick iTunes), and that method doesn't work for restores to 5.x or 6.x. That method was successful for restores to 4.x if you had cached SHSH blobs (digital signature files) on saurik's servers, so a lot of people still have that entry lingering in their hosts files. You can now trick the signing process using redsn0w and SHSH blobs in some cases - see this guide at JailbreakQA for more details. The Wikipedia article for SHSH blob might also be helpful.

    I know this is a late reply, but I'm hoping that this answer might help future people finding this thread via Google as well.
     

Share This Page