Ever since installing SL...

Discussion in 'macOS' started by ryguy2303, Sep 8, 2009.

  1. ryguy2303 macrumors 6502

    ryguy2303

    Joined:
    Jul 27, 2009
    #1
    the website: www.isketch.net doesn't work for me. I play on the site nearly every day, so it is a big deal to me. I don't know if it's Java or Adobe that is causing the problem but ever since installing SL, it doesn't work. What happens is nothing loads. Any help or suggestions would be appreciated!

    Thank you
     
  2. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #2
    Apparently it's because the Shockwave plug-in is 32-bit, and Safari in SL opens in 64-bit by default. I was able to load your link's Shockwave app by launching Safari in 32-bit mode.

    If you use it often, you can make a copy of Safari, call it "Safari 32" (or whatever), and set it to launch in 32-bit mode. You can have both instances of Safari running at the same time (64 & 32bit).

    (Change the mode by selecting Safari, then Finder > File > Get Info (cmd-I) and checking the "Open in 32-bit mode" option.)
     
  3. ryguy2303 thread starter macrumors 6502

    ryguy2303

    Joined:
    Jul 27, 2009
    #3
    Wow amazing. Thank you for such a quick reply, as well. I will do just that.
    Also, there an anticipated update from shockwave to fix this?

    Edit:

    Unchecking Rosetta Stone made it work for me.
     
  4. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #4
    Glad it helped.

    Checking the "Rosetta" option, while the "Open in 32-bit mode" option is checked will result in Safari reverting back to 64-bit mode. Looks like it's just an interface bug. The "Rosetta" option shouldn't be available if the application is Intel only (not a Universal app).

    (btw: it's just "Rosetta". "Rosetta Stone" is a language training app...)

    edit: OS-X Feedback Bug report submitted
     
  5. ryguy2303 thread starter macrumors 6502

    ryguy2303

    Joined:
    Jul 27, 2009

Share This Page