Excessive Disk access from secondary Drive.

Discussion in 'iMac' started by pubjoe, Jan 17, 2011.

  1. pubjoe macrumors 6502

    Joined:
    Aug 14, 2007
    #1
    Hi,

    I have a problem with the following two main symptoms:

    • OS X starts up and the secondary hdd will rumble away non-stop for around 5-15 minutes.
    • When I shut down the imac, it will get stuck on a blue-screen with the rotating thingy [​IMG]

    This problem began occurring consistently a few days ago. When I shut down, I eventually hold down the power button to turn it off. I have a 27" 2010 imac with a 60GB ssd bootdrive (15GB free atm) and a 1TB secondary hdd. The 1TB hdd is split into an 200GB NTFS bootcamp partition and an 800GB "Mac OS Extended" storage partition. I have recently followed Chysaor's guide to enable NTFS read write access. I have also excluded the NTFS partition from spotlight cataloging.

    The storage drive is set as my time machine backup, but this problem has been occurring when time machine is not running.

    I guess I should disable the ntfs read/write access and see if that helps. :rolleyes:

    Is ntfs r/w known to be unstable and casue this problem? (It would be a shame to lose the functionality).
    Is there another likely cause of my problems?

    Thanks.
     
  2. chris98vf macrumors regular

    chris98vf

    Joined:
    Mar 3, 2010
    #2
    see about running a test on the hdd, it sounds like it may be on it's way out. Apple uses Seagate drives for the most part and I'm surprised they don't fail more often. In the PC world they are the worst ever since they bought Maxtor...
    Hopefully it's still within it's warranty and if not it's not all that hard of an upgrade if you wanted to install a WD Black drive. Go to ifixit.com for install instructions if you must upgrade or take it to Apple and have them do the dirty work.
     
  3. pubjoe thread starter macrumors 6502

    Joined:
    Aug 14, 2007
    #3
    Thanks.

    The drive is actually a WD caviar black (3-platter version) - Model: WDC WD1001FALS-40Y6A0 ...I was quite happy to get this drive as I have a good history with WD drives and it is much quieter than the seagate that I've heard in other imacs.

    I've had the imac since October 2010. The hdd is in regular use for time machine backups and for booting windows. But it is not used as a boot/paging drive. My boot drive is a corsair F60 ssd.
     
  4. pubjoe thread starter macrumors 6502

    Joined:
    Aug 14, 2007
    #4
    I didn't have time to attempt to solve the problem for the last few days, but I did need to turn on the computer a couple of times to use the printer.

    My God! Kaleidoscopedelic! I was tearing my hair out. Launch Word > Freeze. cmd+opt+esc, Force quit, try again > Freeze. cmd+opt+esc, cmd+opt+esc, cmd+opt+esc dammit > No response at all. Power off, try again. ...Open word, cmd+P > freeze!! Arrgh! At one point, I tried to shut it down, and I got the kernel panic screen (it's the first time I've ever seen it).

    Anyway, I (think I) finally fixed it today. Verify Disk claimed all disks to be fine. So I removed ntfs r/w support and excluded the "Bootcamp" and "Storage" partitions from spotlight indexing. Now Only the 60GB ssd is indexed, which is a slight inconvenience but at least I can use the computer again.

    I've never had this problem in years of using spotlight. I expect it was the ntfs indexing causing the problem, but I can't be sure.

    Hopefully it'll keep working.
     

Share This Page