Expresscard/34 esata controller available from Addonics

Discussion in 'Mac Accessories' started by lssmit02, May 3, 2006.

  1. lssmit02 macrumors 6502

    Mar 25, 2004
  2. DMPDX macrumors 6502

    Dec 4, 2005
    If that has a sata II port on it only, how will you power the drive itself? Because I would like to find a sata card for pcmcia as well. Any idea?
  3. lssmit02 thread starter macrumors 6502

    Mar 25, 2004
    I'm not sure exactly what you're looking for, but I have the Coolmax CD-311 combo sata/usb2/firewire400 enclosure, which has an external power supply, so it was always my intent to power the drive externally.
  4. lssmit02 thread starter macrumors 6502

    Mar 25, 2004
    Update: Card doesn't work

    My fault for buying a card that didn't specifically say it was compatible with OS X. The Addonics ADEXC34-2E work's find in my macbook pro running Windows, but is not recognized when booted into OS X. It's not that it's not recognized at all-when booted into OSX with the card inserted in the slot, I get an icon at the top, which when you click it shows the following:
    "Unknown Vendor
    Mass Storage Controller
    Power off Card"

    The first two are grayed out. So the hardware is being recognized at some level, although the card is not recognized in the System Profiler.

    The card uses the Silicon Image 3132 chipset, which has OS X 10.4 drivers (available on the Silicon Image website). So, there must be some Addonics-only chipset in the card that requires a specific driver. Interestingly, on the Windows XP side of things, Addonics says that you can tell if the card is properly installed if under the device manager you see "Silicon Image SiI 3132 SATALink Controller" under 'SCSI and RAID Controllers.' So, apparently its the Silicon Image chipset that is recognized by Windows XP-there's no reference to Addonics or the card in the device manager. When I asked Addonics if they would be supplying drivers, I was told: "We're sorry, we don't have MacOS driver for any SiI chipsets."

    Any ideas?
  5. captainbrendo macrumors newbie

    Mar 19, 2006
    Too bad

    I want an eSATA express card too!

    Too bad about the addronics

    maybe the vydeo or lycom cards work? I heard that they are actually the same card

    The firmtek was reviewed on w/a macbook pro so at least something works!
  6. lssmit02 thread starter macrumors 6502

    Mar 25, 2004
    Addonics card now works

    I received this message from alx a while back, and just recently had the time to test out the driver. I can confirm that with this new driver from silicon image, the addonics Expresscard/34 esata controller now works in the Macbook Pro.
  7. auxio macrumors newbie

    Oct 5, 2006
  8. MacWarriorX macrumors newbie

    Sep 1, 2004
    Hey thanks to the brave guinea pigs that tried this out...I saved about $50 on one of these things!

    There's a new version of the Silicon Image driver (at the link posted above) just released yesterday. Not sure what's changed, but I upgraded and everything still works! :cool:
  9. n0d3 macrumors regular

    Oct 12, 2006
    Does anyone know where the drivers are stored? I was wondering if I need to clear out the old ones because I have at least 3 versions of the Silicon driver.
  10. brodie macrumors member

    Mar 17, 2007
    I bought two of these and have tried both the 1.16 & 1.19 silicon images drivers from the link,but to no avail. I just get the greyed out menu with only Power off available.

    Im using a MB Pro 2.33GHz core 2 Duo, and ideas? did you do anything else to get it to work other than installing the driver?
  11. Lucidmyth macrumors member

    Apr 12, 2007
    The Netherlands
    I bought the ADEXC34R5-2E today, unfortunately the above drivers don't work.
    At least not without modification :-(

    Is there anything I have to do besides installing the universal binary drivers from the siliconimage website. Perhaps modifying Info.plist?

    I also tried both versions only to find the greyed-out menu.
    I will post my findings if any.

    Is it possible that only the ADEXC34-2E works (without RAID/JBOD) ?
  12. Lucidmyth macrumors member

    Apr 12, 2007
    The Netherlands
    Ok, I have it working now.

    I have tried so many things that I do not know exactly what made it work.
    So for everyone who cannot get the standard SiliconImage driver working, try this:

    Install the before mentioned drivers from the SilicomImage website.
    Download the attached driver package and unpack it in "/System/Library/Extensions"
    Reboot and hope for the best.
    After rebooting my Macbook Pro took a few minutes to come back up, but at least it detected my external sata drive :)

    Attached Files:

  13. Lucidmyth macrumors member

    Apr 12, 2007
    The Netherlands
    Today I reinstalled my Mac and needed the modified driver available in my other post. After copying the driver there are some file permissions you have to take care of.
    This can be done by running the following command in the terminal as root:
    chown -R root:wheel /System/Library/Extensions
    After a reboot the driver should work.

    Let me know if it works.
  14. Lucidmyth macrumors member

    Apr 12, 2007
    The Netherlands
    I keep posting to myself :)
    I think I know why for some people it works out of the box and for others not.

    The Addonics ADEXC34-2E (without RAID/JBOD) works by just installing the siliconimage universal drivers. The ADEXC34R5-2E which has softraid capabilities does not work out of the box. You need to at least change the Info.plist file and change field:




    Another option is to flash the RAID BIOS to a non-RAID BIOS.

    The BIOS files are found on the siliconimage website.
    Use the FreeDOS livecd and inject the flashupdate tool + bios files in the FreeDOS livecd image with for example UltraISO.
    Boot from the livecd select option 5 (be quick it will freeze if you wait for more then 5 seconds)
    After FreeDOS is loaded type: "X:" <enter>
    type: "UPDFLASH.EXE b7313.bin -v -ID3132" <enter>

    After updating the bios the universal drivers will work without modification.
    You can always revert back to the original BIOS (r7313.bin)

    I tested this on my MacBook Pro and for me it works, but i do of course take no responsibility what so ever for any problem that may or may not happen after reading / following this
  15. tekfx19 macrumors newbie

    Apr 23, 2007
    Im right here with you pal...

    I bought the same exact card. The raid5 version doesnt work with either my parallels, os x, or bootcamp. Im running a macbook pro 2.33 c2d. Im very interested in making this work, as it would be a huge pain to have to send it back. I am looking into your bios manipulation technique. I hope it works. I just wanted to let you know that your not posting for just yourself. Thanks for all the help. By the way when I tried to copy the kext file into my extensions folder it worked for a bit but a few days later it said something about the extension not being installed correctly, So I removed it.
  16. Lucidmyth macrumors member

    Apr 12, 2007
    The Netherlands

    The easiest way is to load a default non-raid bios, at least if you don't care about the RAID/JBOD functionality. This is what I did and my card works now without having to edit the driver.

    I have a nice bootable FreeDOS image with the required bios update and flash tools in it. I will send you a private message with a link to this cd image.

    Burn it and follow the instructions in my earlier post.
    I believe it's save and you can always revert back to the RAID/JBOS bios image.

    Good luck
  17. Lucidmyth macrumors member

    Apr 12, 2007
    The Netherlands
    Booting from the ExpressCard

    I'm currently trying to boot Mac OS X from a SATA disk attached to the Addonics eSATA ExpressCard....

    A lot of people say that it can't be done, but I think it might be possible.
    I'm already able to boot Linux and Vista from eSATA/ExpressCard and it significantly boosts the performance. It would be great to be able to do this with OS X.

    I think booting for now is only possible by using the legacy BIOS emulation provided with either rEFIt or Bootcamp. I have tried using the patched osx86 images like JaS etc. They are capable of booting from a BIOS by using the Darwin Bootloader, those images are only tailored at mainstream "IBM PC" compatible pc's and freeze on a MacBook Pro...

    If anyone is trying the same, let me now
  18. tekfx19 macrumors newbie

    Apr 23, 2007
    Changing the bios

    So let me get this straight, I can boot to this freedos image(base cd? or full?) on my macbook pro with the expresscard installed and it will boot to the cd and then I can flash the bios with (which file?). I looked at a few of them and I was not completely sure which one to use. After that I will be able to use my card with bootcamp, and within mac osx? Thanks for clarifying.
  19. Lucidmyth macrumors member

    Apr 12, 2007
    The Netherlands
    First of all, I think you should already be able to use the ExpressCard in XPX/Bootcamp.
    Not sure about Parallels/XP beacause the card might not be visible in the VirtualMachine.
    Are you sure you installed the Bootcamp Driver cd and the drivers from the Addonics cd?

    The image I gave you is the full FreeDOS image (for the livecd functionality)

    You should use this instruction from my earlier post:

    "Boot from the livecd select option 5 (be quick it will freeze if you wait for more then 5 seconds)
    After FreeDOS is loaded type: "X:" <enter>
    type: "UPDFLASH.EXE b7313.bin -v -ID3132" <enter>
    This will print out some information and asks you to confirm that you want to update the bios.

    So "UPDFLASH.EXE" and "b7313.bin" are the files you will use.

    Now you should be able to use your card in Mac OS X too.
    But you probably have to reinstall the drivers
  20. tekfx19 macrumors newbie

    Apr 23, 2007

    It actually worked for a short time in bootcamp but I cant do anything with my esata drive. If I try to boot to bootcamp with the expresscard installed after I installed the drivers and the java raid5, It would hang indefinitely. Device manager sees it but when I plug my drive into it, I cant get it to mount to a drive letter. It doesnt even show up in disk management. I got the Java Raid 5 to see it, but I didnt want to lose the data on the drive so I didnt want to create an array which was the only option. Im gonna just start from scratch and reinstall bootcamp, try the drivers from siI from there website. Screw the addonics drivers.
  21. Pressure macrumors 68040


    May 30, 2006
    Nice, since I am still stuck with the first generation MacBook Pro and therefore lack a FireWire800 port this could be a great solution for getting RAID 0 for my video-editing. Don't have a Mac Pro yet (hopefully after summer).
  22. Klatuu macrumors newbie

    May 4, 2007
    A little more help please?

    I'm having the same problem as you with the ExpressCard34 for RAID and JBOD. I've tried downloading the additional file you have attached to your post. I'm not sure what to do next. How do I unpack this file in my Extensions?

    Thanks very much for any clarity!

    I'm very much a newbie!

  23. Lucidmyth macrumors member

    Apr 12, 2007
    The Netherlands
    Driver installation

    Hello Klatuu,

    The first thing you have to do is install the Universal drivers from the silicon image website
    Download the zipped driver attached in my earlier post.
    Unzip it and drag it to /System/Library/Extensions, that is on your main drive "Macintosh HD". This will give you a warning "The item "SiliconImage3132.kext" could not be moved because "Extensions" could not be modified" Click on the Authenticate button and give your password. Now the file has been copied you have to restore the file permissions.
    Go to the Disk Utility and click on the partition where Mac OS X is installed. No click on the "Repair Disk Permissions"

    Reboot and see if it works.
  24. pst macrumors newbie

    May 8, 2007
    What exactly is the difference between the components installed by the Silicon Image driver and those provided by your zipped driver? Did you change the Info.plist file or the actual driver or what? The reason I ask is that I have the latest SI driver installed and the kext files are already there (after doing a reboot, they weren't found by the kernel before reboot).

    Much thanks for all your help,
  25. Lucidmyth macrumors member

    Apr 12, 2007
    The Netherlands
    I do not know exactly what made it work as stated earlier.
    I haven't changed the actual driver (it's binary) but did at least change the Info.plist.
    After I got it all working I wondered what exactly did it. It must be more then only Info.plist because only changing that isn't going to work. The kext file is also larger then the 1.1.9 version from the sil. website.

    After digging around I finally gave up because after all the driver already worked for me.
    It's possible that I copied some files from a driver released for the SeriTek2SM2 (another sil 3132 eSATA ExpressCard) but I can't remember..

    At this very moment I use the standard driver without modification because I flashed the card to Non-RAID/BASE. Now the official driver will always work, also with new updates.

Share This Page